var URL_HEADER='http://grafika-online.com'; var SITE_ROOT=''; var ADMIN_ROOT='/admin'; var AUTO_REFRESH_TIME=0; var AUTO_ONLINE_TIME=120000; var CONTROL_USER_ACTIVITY=0; var DATE_FORMAT=0; var WEEKDAY=Array('Воскресенье','Понедельник','Вторник','Среда','Четверг','Пятница','Суббота') var MONTH=Array('Январь','Февраль','Март','Апрель','Май','Июнь','Июль','Август','Сентябрь','Октябрь','Ноябрь','Декабрь') /* // ============================================================================\ Functions: makeSure() errorNotAllLoaded() handleError() handleErrorAlert() disableJSError(w,alert) handleContext(e) stopContext(w) makePullDown(source,name,width,height) AssocArray() // ============================================================================/ */ var W=window var T=top var D=document var NOW=new Date() var allLoaded=0 var TMP // ---------------------\ // Make sure (ask confirmation) // ------------------------------------\ function makeSure() { return confirm('Вы уверены, что хотите это сделать?') } // ------------------------------------/ // -------------------------\ // Error handling functions // ------------------------------------\ function errorNotAllLoaded() { alert("Страница была неполностью загружена. Операция прервана.\nПерезагрузите страницу перед продолжением работы") return false } function handleError() { return true } function handleErrorAlert() { alert("There was an Java-Script error. Operation terminated") return true } function disableJSError(w,alert) { if (! w) w=window w.onerror=alert ? handleErrorAlert : handleError } // ------------------------------------/ // ---------------------\ // Disable context menu // ------------------------------------\ function handleContext(e) { if (e && e.which) return e.which==1 else return false } function stopContext(w) { if (! w) w=window var d=w.document if (d.captureEvents) d.captureEvents(Event.MOUSEDOWN) d.oncontextmenu=d.onmousedown=handleContext } // ------------------------------------/ // ----------------------\ // Make Pull-Down Window // ------------------------------------\ function makePullDown(source,name,width,height) { var win_prop="location=no,toolbar=no,directories=no,menubar=yes,status=yes,"+ "scrollbars=yes,resizable=yes,dependent=no,width="+width+",height="+height if (window.screen) { var x=Math.floor((screen.width-width)/2) var y=Math.floor((screen.height-height)/2) win_prop+=",screenX="+x+",screenY="+y+",left="+x+",top="+y } var win=open(source,name,win_prop) win.focus() return win } // ------------------------------------/ // -------------------------\ // Create associative array // ------------------------------------\ function AssocArray() { var obj=this.window ? new Object : this var argv=AssocArray.arguments var l=argv.length for (var i=0; i'9') return null } return eval(str) } // ------------------------------------/ // ------------------\ // Check float value // ------------------------------------\ function checkFloat(str) { var l=str.length if (!l) return null var point=0 for (var i=0; i'9') return null } return eval(str) } // ------------------------------------/ // ----------------\ // Check ZIP value // ------------------------------------\ function checkZip(str) { return (str.length==5 && checkInt(str)) } // ------------------------------------/ // -------------------\ // Check E-mail value // ------------------------------------\ function checkEmail(str) { var l=str.length if (!l) return false var ata=0 var point=0 var cch='' for (var i=0; i'Z') && (ch<'a' || ch>'z') && (ch<'0' || ch>'9') && (ch!='_') && (ch!='-')) return false cch=ch } return (ata && point) } // ------------------------------------/ // ---------\ // Check IP // ------------------------------------\ function checkIP(str) { if (!str.length) return false var arr=str.split('.') if (arr.length!=4) return false var s=0 for (var i=0; i<4; i++) { var val=checkInt(arr[i]) if (val==null || val>255) return false s=s*256+val } return s } // ------------------------------------/ // -----------------------------\ // Check date and get its parts // ------------------------------------\ function getDate(str,format) { if (format==null) format=W.DATE_FORMAT var mlen=Array(31,28,31,30,31,30,31,31,30,31,30,31) var l=str.length var dd=str.substr(0,2) var mm=str.substr(3,2) var yy=str.substr(6,4) if (format) { var tmp=dd; dd=mm; mm=tmp } var d=checkInt(dd) var m=checkInt(mm) var y=checkInt(yy) var ml=mlen[m-1]+1+ ((m==2 && (y%400==0 || (y%4==0 && y%100!=0))) ? 1 : 0) var res= (l==10 && str.charAt(2)=="." && str.charAt(5)=="." && d && ddate2) return 1 else if (date2>date1) return 2 else return 0 } // ------------------------------------/ // --------------\ // Compare times // ------------------------------------\ function cmpTime(str1,str2) { var time1=getTime(str1) var time2=getTime(str2) if (! time1) return -1 if (! time2) return -2 time1=eval(time1.join('')) time2=eval(time2.join('')) if (time1>time2) return 1 else if (time2>time1) return 2 else return 0 } // ------------------------------------/ // ---------------------------------\ // Get dd.mm.yyyy/mm.dd.yyyy string // ------------------------------------\ function getDateStr(date,format) { if (! date) date=new Date if (format==null) format=W.DATE_FORMAT var dd=date.getDate() var mm=date.getMonth()+1 var yy=date.getYear() if (dd<10) dd="0"+dd if (mm<10) mm="0"+mm if (format) { var tmp=dd; dd=mm; mm=tmp } return (""+dd+"."+mm+"."+yy) } // ------------------------------------/ // ----------------------\ // Get hh:mm string // ------------------------------------\ function getTimeStr(date) { if (! date) date=new Date var hh=date.getHours() var mm=date.getMinutes() if (hh<10) hh="0"+hh if (mm<10) mm="0"+mm return (""+hh+":"+mm) } // ------------------------------------/ // ----------------------\ // Get hh:mm string // ------------------------------------\ function getFullYear(date) { if (! date) date=new Date var y=date.getYear() if (y<1000) y+=1900 return y } // ------------------------------------/ /* // ============================================================================\ Functions (constructors): Rollover(name,dir,current,disable_roll_current, imgs_off,imgs_on,imgs_off_current,imgs_on_transparent, nn_document,preload) Layer(name,nn_document) DropDownMenu(name,centeredWidth,delayOff, hSubLeft,hSubTop,subLeft,subTop,subWidth, bgColor,headHTML,tailHTML,hItemDelimHTML, subBgColor,subHoverColor,subHeadHTML,subTailHTML,itemDelimHTML, hItemHoverColor,hItemHeadHTML,hItemTailHTML,hItemLinkClass,hItemLinkAttrs, itemHoverColor,itemHeadHTML,itemTailHTML,itemLinkClass,itemLinkAttrs, rollover,items) Item(text,href,target, bgColor,hoverColor,headHTML,tailHTML,linkClass,linkAttrs,beforeHTML,afterHTML, subMenu) SubMenu(left,top,width,bgColor,hoverColor,headHTML,tailHTML,itemDelimHTML, itemHoverColor,itemHeadHTML,itemTailHTML,itemLinkClass,itemLinkAttrs, rollover,items) or SubMenu(direction,alignment,...) direction='[value][+/-offset]' t - top b - bottom v - vertical ('t' or 'b' choosed automatically) l - left r - right h - horizontal ('l' or 'r' choosed automatically) alignment='[value][+/-offset]' b - begin c - center e - end a - auto // ============================================================================/ */ var tStr='string' // ========================\ // Special DHTML functions // ============================================================================\ var DOM=D.getElementById ? 1 : 0; var IE4=D.all ? 1 : 0 var NN4=D.layers ? 1 : 0 var DHTML=(DOM || IE4 || NN4) var LAYERS=[] var ROLL=[] var MENU=[] // -------------------------------\ // Create special rollover object // ----------------------------------------------------------------------------\ function __RolloverPreload() { if (this.rollover) { var tmp=this.TMP var dir=this.dir var imgs=this.imgs for (var i in imgs) if (imgs[i][0]) (tmp[i]=new Image).src=dir+'/'+imgs[i][1] } } function __RolloverSwitch(num,pos,nn_document) { var t=this if (!nn_document) nn_document=t.nn_document var d=(NN4 && nn_document) ? eval(nn_document) : D var img=d.images[t.name+num] var im=t.imgs[num] if (t.rollover && img && im && im[0]) img.src=t.dir+'/'+im[pos ? 1 : 0] } function Rollover(name,dir,current,disable_roll_current, imgs_off,imgs_on,imgs_off_current,imgs_on_transparent, nn_document,preload) { var obj=this.window ? {} : this obj.name=name obj.rollover=(D.images && imgs_off) obj.dir=dir if (IE4 && imgs_on_transparent) imgs_on=imgs_on_transparent obj.imgs=[] for (var i in imgs_off) obj.imgs[i]=[imgs_off[i],imgs_on[i]] if (current>=0) { var curr=obj.imgs[current] if (imgs_off_current) curr[0]=imgs_off_current[current] if (disable_roll_current) curr[1]=curr[0] } obj.nn_document=nn_document obj.TMP=[] // ------------------------------------\ obj.preload=__RolloverPreload obj.Switch=__RolloverSwitch // ------------------------------------/ if (preload!=0) obj.preload() W.ROLL[name]=obj return obj } // ----------------------------------------------------------------------------/ // ---------------------\ // Special layer object // ----------------------------------------------------------------------------\ function __LayerParams(left,top,layerLeft,layerTop,pageLeft,pageTop,width,height) { var t=this var l=t.layer var p=t.properties if (!l) return null var x,y,layerX,layerY,pageX,pageY,w,h // ------------| if (NN4) { x=l.left y=l.top layerX=pageX=l.pageX layerY=pageY=l.pageY var pL=l.parentLayer if (pL!=W) { layerX-=pL.pageX layerY-=pL.pageY } var d=l.document w=d.width h=d.height // =============\ // VERY SPECIAL | // ====================================\ var l1 if (l1=d.layers['layerBody']) { d=l1.document w=d.width h=d.height } if ((l1=d.layers['layerWidth']) && (l1.document.width>w)) w=l1.document.width // ====================================/ } else { x=parseInt(p.left) || 0 y=parseInt(p.top) || 0 layerX=pageX=l.offsetLeft layerY=pageY=l.offsetTop var pL=l while (pL=pL.offsetParent) { pageX+=pL.offsetLeft pageY+=pL.offsetTop } w=l.offsetWidth h=l.offsetHeight } // ------------| if (left!=null) p.left=(typeof(left)==tStr) ? eval(x+'+('+left+')') : left if (top!=null) p.top=(typeof(top)==tStr) ? eval(y+'+('+top+')') : top if (layerLeft!=null) p.left=eval(x+'+('+layerLeft+')')-(typeof(layerLeft)!=tStr)*layerX if (layerTop!=null) p.top=eval(y+'+('+layerTop+')')-(typeof(layerTop)!=tStr)*layerY if (pageLeft!=null) p.left=eval(x+'+('+pageLeft+')')-(typeof(pageLeft)!=tStr)*pageX if (pageTop!=null) p.top=eval(y+'+('+pageTop+')')-(typeof(pageTop)==tStr)*pageY if (!NN4) { if (width!=null) p.width=width if (height!=null) p.height=height } // ------------| return { left: x, top: y, layerLeft: layerX, layerTop: layerY, pageLeft: pageX, pageTop: pageY, width: w, height: h } } function __LayerColor(color) { var t=this var p=t.properties if (!p) return null var c=NN4 ? p.bgColor : p.backgroundColor if (color!=null) p[NN4 ? 'bgColor' : 'backgroundColor']=(NN4 && !color) ? null : color return c } function __LayerVisibility(pos) { var t=this var p=t.properties if (!p) return null var v=(p.visibility.substr(0,3)=='hid') ? 0 : 1; if (pos!=null) p.visibility=pos ? 'visible' : 'hidden' return v } function Layer(name,nn_document) { var obj=this.window ? {} : this obj.name=name obj.nn_document=nn_document+'.layers.'+name+'.document' var l=null var d=(NN4 && nn_document) ? eval(nn_document) : D if (DHTML) l=DOM ? D.getElementById(name) : d[IE4 ? 'all' : 'layers'][name] obj.layer=l obj.properties=(l && !NN4) ? l['style'] : l // ------------------------------------\ obj.params=__LayerParams obj.color=__LayerColor obj.visibility=__LayerVisibility // ------------------------------------/ return obj } // ----------------------------------------------------------------------------/ // ===============\ // Drop-down menu // ============================================================================\ // -------------\ // VERY SPECIAL // ----------------------------------------------------------------------------\ var SCREEN={ size: 0, params: function() { if (!DHTML) return null var size=this.size.params() var x=NN4 ? pageXOffset : D.body.scrollLeft var y=NN4 ? pageYOffset : D.body.scrollTop return { left: x, top: y, width: size.width, height: size.height } } } // ----------------------------------------------------------------------------/ // -------------------\ // Create menu object // ----------------------------------------------------------------------------\ function __DropDownMenuInit() { if (DHTML && !SCREEN.size) { D.write(NN4 ? "
" : "
") SCREEN.size=Layer('pageSize'); } var t=this var items=t.items // ------------| for (var i in items) { var item=items[i] item.init(t,t,i) if (item.subMenu) item.subMenu.create(t,item) } } function __DropDownMenuCreate() { var t=this var items=t.items // ------------| D.write(t.headHTML) // ------------| var n=0 for (var i in items) { if (n) D.write(t.hItemDelimHTML) items[i].create() n=1 } // ------------| D.write(t.tailHTML) // ------------| if (DHTML) for (var i in items) { var item=items[i] item.layer=Layer((NN4 ? 'layerBody' : item.name),'D.layers.'+item.name+'.document') } } function __DropDownMenuSwitch(allNum,pos,fromSubMenu) { var t=this var inc=pos ? +1 : -1 var item=this.allItems[allNum] // ------------| var sM=item.subMenu if (sM) sM.layer.color((fromSubMenu && pos) ? sM.hoverColor : sM.bgColor) // ------------| do item.position+=inc while (item=item.parent.parent) // ------------| setTimeout('W.MENU["'+t.name+'"].allItems['+allNum+'].Switch()',15)//40) } function DropDownMenu(name,centeredWidth,delayOff, hSubLeft,hSubTop,subLeft,subTop,subWidth, bgColor,headHTML,tailHTML,hItemDelimHTML, subBgColor,subHoverColor,subHeadHTML,subTailHTML,itemDelimHTML, hItemHoverColor,hItemHeadHTML,hItemTailHTML,hItemLinkClass,hItemLinkAttrs, itemHoverColor,itemHeadHTML,itemTailHTML,itemLinkClass,itemLinkAttrs, rollover,items) { var obj=this.window ? {} : this obj.allItems=[] obj.z=1 // --------------| obj.name=name obj.centeredWidth=centeredWidth obj.delayOff=(delayOff>0) ? delayOff : 0 obj.hSubLeft=hSubLeft obj.hSubTop=hSubTop obj.subLeft=subLeft obj.subTop=subTop obj.subWidth=subWidth obj.bgColor=(bgColor || '') obj.headHTML=(typeof(headHTML)==tStr) ? headHTML : '
' obj.tailHTML=(typeof(tailHTML)==tStr) ? tailHTML : '
' obj.hItemDelimHTML=(typeof(hItemDelimHTML)==tStr) ? hItemDelimHTML : ' ' obj.subBgColor=(subBgColor || '') obj.subHoverColor=(subHoverColor || '') obj.subHeadHTML=(typeof(subHeadHTML)==tStr) ? subHeadHTML : '
' obj.subTailHTML=(typeof(subTailHTML)==tStr) ? subTailHTML : '
' obj.itemDelimHTML=(typeof(itemDelimHTML)==tStr) ? itemDelimHTML : ' ' obj.hItemHoverColor=(hItemHoverColor || '') obj.hItemHeadHTML=(hItemHeadHTML || '') obj.hItemTailHTML=(hItemTailHTML || '') obj.hItemLinkClass=(hItemLinkClass || '') obj.hItemLinkAttrs=(hItemLinkAttrs || '') obj.itemHoverColor=(itemHoverColor || '') obj.itemHeadHTML=(itemHeadHTML || '') obj.itemTailHTML=(itemTailHTML || '') obj.itemLinkClass=(itemLinkClass || '') obj.itemLinkAttrs=(itemLinkAttrs || '') obj.rollover=rollover obj.items=items // ------------------------------------\ obj.init=__DropDownMenuInit obj.create=__DropDownMenuCreate obj.Switch=__DropDownMenuSwitch // ------------------------------------/ W.MENU[name]=obj obj.init() return obj } // ----------------------------------------------------------------------------/ // -----------------\ // Create menu item // ----------------------------------------------------------------------------\ function __ItemClick(href,target) { if (event && event.srcElement && event.srcElement.tagName=='A') return W.open(href,(event && event.shiftKey) ? '_blank' : ((target && target!='0') || '_self')) } function __ItemInit(menu,parent,num) { var t=this var m=t.menu=menu var p=t.parent=parent t.num=num var isHead=t.isHead=(menu==parent) ? 1 : 0 t.allNum=m.allItems.length // ------------| m.allItems[t.allNum]=t t.name=m.name+'_'+t.allNum // ------------| if (typeof(t.bgColor)!=tStr) t.bgColor=isHead ? m.bgColor : '' if (typeof(t.hoverColor)!=tStr) if (isHead) t.hoverColor=m.hItemHoverColor else t.hoverColor=(typeof(p.itemHoverColor)==tStr) ? p.itemHoverColor : m.itemHoverColor if (!t.hoverColor) t.hoverColor=t.bgColor // ------------| if (typeof(t.linkClass)!=tStr) if (isHead) t.linkClass=m.hItemLinkClass else t.linkClass=(typeof(p.itemLinkClass)==tStr) ? p.itemLinkClass : m.itemLinkClass if (typeof(t.linkAttrs)!=tStr) if (isHead) t.linkAttrs=m.hItemLinkAttrs else t.linkAttrs=(typeof(p.itemLinkAttrs)==tStr) ? p.itemLinkAttrs : m.itemLinkAttrs } function __ItemCreate() { var t=this var m=t.menu var p=t.parent var isHead=t.isHead // ------------| D.write(t.beforeHTML) var tmp1='' var tmp2='' if (t.href!='') { tmp1='cursor:hand;' tmp2=' onClick="__ItemClick(\''+t.href+'\',\''+t.target+'\')"' } D.write(NN4 ? '') // =============\ // VERY SPECIAL | // ====================================\ if (NN4) D.write('
') // ====================================/ // ------------| if (typeof(t.headHTML)==tStr) D.write(t.headHTML) else if (isHead) D.write(m.hItemHeadHTML) else D.write((typeof(p.itemHeadHTML)==tStr) ? p.itemHeadHTML :m.itemHeadHTML) // ------------| if (t.href && t.href.length) D.write('',t.text,'') else D.write(t.text) // ------------| if (typeof(t.tailHTML)==tStr) D.write(t.tailHTML) else if (isHead) D.write(m.hItemTailHTML) else D.write((typeof(p.itemTailHTML)==tStr) ? p.itemTailHTML : m.itemTailHTML) // ------------| D.write(NN4 ? '' : '') D.write(t.afterHTML) } function __ItemSwitch(immediate) { var t=this var m=t.menu var p=t.parent var pos=t.position var del=m.delayOff // ------------| var b=0 for (var i in m.allItems) if (m.allItems[i].position) b=1 // ------------| if (del && t.subMenu && !(pos || immediate || b)) setTimeout('W.MENU["'+m.name+'"].allItems['+t.allNum+'].Switch(1)',del) else { var r=p.rollover if (r) r.Switch(t.num,pos,t.layer.nn_document) t.layer.color(pos ? t.hoverColor : t.bgColor) if (t.subMenu) t.subMenu.Switch() var pI=t while (pI=pI.parent.parent) pI.Switch(immediate) } } function Item(text,href,target, bgColor,hoverColor,headHTML,tailHTML,linkClass,linkAttrs,beforeHTML,afterHTML, subMenu) { var obj=this.window ? {} : this obj.menu=obj.parent=0 obj.allNum=0 obj.isHead=0 obj.num=0 obj.name='' obj.layer=0 obj.position=0 //---------------| obj.text=text obj.href=href obj.target=target obj.bgColor=(typeof(bgColor)==tStr) ? bgColor : 0 obj.hoverColor=(typeof(hoverColor)==tStr) ? hoverColor : 0 obj.headHTML=(typeof(headHTML)==tStr) ? headHTML : 0 obj.tailHTML=(typeof(tailHTML)==tStr) ? tailHTML : 0 obj.linkClass=(typeof(linkClass)==tStr) ? linkClass : 0 obj.linkAttrs=(typeof(linkAttrs)==tStr) ? linkAttrs : 0 obj.beforeHTML=(beforeHTML || '') obj.afterHTML=(afterHTML || '') obj.subMenu=subMenu // ------------------------------------\ obj.init=__ItemInit obj.create=__ItemCreate obj.Switch=__ItemSwitch // ------------------------------------/ return obj } // ----------------------------------------------------------------------------/ // ---------------\ // Create submenu // ----------------------------------------------------------------------------\ function __SubMenuParsePos(str) { if (typeof(str)!=tStr) return null var off=0 var i=str.indexOf('+') if (i<0) i=str.indexOf('-') if (i>=0) { off=str.substr(i) str=str.substr(0,i) } str=(str.charAt(0) || 0) off=(parseInt(off) || 0) return [str,off] } function __SubMenuCreate(menu,parent) { if (!DHTML) return var t=this var m=t.menu=menu var p=t.parent=parent var name=this.name=p.name+'_body' this.z=parent.parent.z+1 var items=this.items // ------------| if (t.left==null) t.left=p.isHead ? m.hSubLeft : m.subLeft if (t.top==null) t.top=p.isHead ? m.hSubTop : m.subTop if (t.width==null) t.width=m.subWidth if (typeof(t.bgColor)!=tStr) t.bgColor=m.subBgColor if (typeof(t.hoverColor)!=tStr) t.hoverColor=(m.subHoverColor || t.bgColor) // ------------| var d=__SubMenuParsePos(t.left) var a=__SubMenuParsePos(t.top) if (d) { t.direction=(d[0] || (p.isHead ? 'v' : 'h')) t.dirOff=d[1] t.alignment=(a[0] || (a[1] ? 'b' : 'a')) if (a[0]!='a') t.alignOff=(a[1] || 0) t.left=t.top=0 } // ------------| if (NN4) D.write('') if (!NN4) D.write('
') // ------------| D.write((typeof(t.headHTML)==tStr) ? t.headHTML : m.subHeadHTML) // ------------| var delim=(typeof(t.itemDelimHTML)==tStr) ? t.itemDelimHTML : m.itemDelimHTML var n=0 for (var i in items) { if (n) D.write(delim) items[i].init(menu,t,i) items[i].create() n=1 } // ------------| D.write((typeof(t.tailHTML)==tStr) ? t.tailHTML : m.subTailHTML) // ------------| if (!NN4) D.write('
') D.write(NN4 ? '' : '') // ------------| t.layer=Layer(t.name) for (var i in items) { var item=items[i] item.layer=Layer((NN4 ? 'layerBody' : item.name),'D.layers.'+t.name+'.document.layers.'+item.name+'.document') if (item.subMenu) item.subMenu.create(menu,item) } } function __SubMenuSwitch() { if (!DHTML) return var t=this var m=t.menu var p=t.parent var l=t.layer var pos=p.position // ------------| if (pos) { var tmp tmp=SCREEN.params() var scrW=tmp.width var scrH=tmp.height var scrL=tmp.left var scrT=tmp.top var scrR=scrL+scrW-1 var scrB=scrT+scrH-1 // ----------| tmp=p.layer.params() var elW=tmp.width var elH=tmp.height var elL=tmp.pageLeft var elT=tmp.pageTop var elR=elL+elW-1 var elB=elT+elH-1 // ----------| var w=t.layerW var h=t.layerH if (!w) { // MOZILLA & OPERA BUG CORRECTION var tmp=l.params() w=t.layerW=tmp.width h=t.layerH=tmp.height } if (!NN4) l.params(null,null,null,null,null,null,w,h) // ----------| var d=t.direction var dO=t.dirOff var a=t.alignment var aO=t.alignOff // ----------| var x=t.left var y=t.top var l1,l2 // ----------| if (d) { if (d=='h') { l1=(elL-dO)-scrL l2=scrR-(elR+dO) d=(l2l2) ? 'l' : 'r' if (d=='l') dO=-dO } if (d=='v') { l1=(elT-dO)-scrT l2=scrB-(elB+dO) d=(l2l2) ? 't' : 'b' if (d=='t') dO=-dO } // --------| if (d=='l') { x=elL+dO-w d='h' } else if (d=='r') { x=elR+dO+1 d='h' } else if (d=='t') { y=elT+dO-h d='v' } else { // (d=='b') y=elB+dO+1 d='v' } // --------| if (d=='v') { if (a=='a') { l1=(elR+aO)-scrL+1 l2=scrR-(elL+aO)+1 a=(l2l2) ? 'e' : 'b' } if (a=='c') x=elL-Math.floor((w-elW)/2)+aO else if (a=='e') x=elR+aO-w+1 else x=elL+aO // (a=='b') } else { // (d=='h') if (a=='a') { l1=(elB+aO)-scrT+1 l2=scrB-(elT+aO)+1 a=(l2l2) ? 'e' : 'b' } if (a=='c') y=elT-Math.floor((h-elH)/2)+aO else if (a=='e') y=elB+aO-h+1 else y=elT+aO // (a=='b') } // --------| } else if (m.centeredWidth) { var offsetX=Math.floor((scrW-m.centeredWidth)/2) x=t.left+((offsetX>0) ? offsetX : 0) y=t.top } // ----------| l.params(x,y) } // ------------| l.visibility(pos) } function SubMenu(left,top,width,bgColor,hoverColor,headHTML,tailHTML,itemDelimHTML, itemHoverColor,itemHeadHTML,itemTailHTML,itemLinkClass,itemLinkAttrs, rollover,items) { var obj=this.window ? {} : this obj.menu=obj.parent=0 obj.name='' obj.direction=obj.dirOff=0 obj.alignment=obj.alignOff=0 obj.z=0 obj.layer=0 obj.layerW=obj.layerH=0 // --------------| obj.left=left obj.top=top obj.width=width obj.bgColor=(typeof(bgColor)==tStr) ? bgColor : 0 obj.hoverColor=(typeof(hoverColor)==tStr) ? hoverColor : 0 obj.headHTML=(typeof(headHTML)==tStr) ? headHTML : 0 obj.tailHTML=(typeof(tailHTML)==tStr) ? tailHTML : 0 obj.itemDelimHTML=(typeof(itemDelimHTML)==tStr) ? itemDelimHTML : 0 obj.itemHoverColor=(typeof(itemHoverColor)==tStr) ? itemHoverColor : 0 obj.itemHeadHTML=(typeof(itemHeadHTML)==tStr) ? itemHeadHTML : 0 obj.itemTailHTML=(typeof(itemTailHTML)==tStr) ? itemTailHTML : 0 obj.itemLinkClass=(typeof(itemLinkClass)==tStr) ? itemLinkClass : 0 obj.itemLinkAttrs=(typeof(itemLinkAttrs)==tStr) ? itemLinkAttrs : 0 obj.rollover=rollover obj.items=items // ------------------------------------\ obj.create=__SubMenuCreate obj.Switch=__SubMenuSwitch // ------------------------------------/ return obj } // ----------------------------------------------------------------------------/ // ============================================================================/ // ============================================================================/ /* // ============================================================================\ Functions: autoRefresh() setUserOnline() changePortion(sel) checkFilled(field,alertMessage) // ============================================================================/ */ // ------------------------------------\ // Special online monitoring functions // ------------------------------------\ var SET_USER_ONLINE_IMG var userActive=new Array(0,1) function setUserActive(e) { if (!W.CONTROL_USER_ACTIVITY) return userActive[0]=userActive[1]=1 if (D.releaseEvents) D.releaseEvents(Event.MOUSEMOVE) W.onfocus=D.onmousemove=D.onkeydown=null } function setUserPassive(n) { userActive[n]=1 if (!W.CONTROL_USER_ACTIVITY) return userActive[n]=0 if (D.captureEvents) D.captureEvents(Event.MOUSEMOVE) setTimeout("W.onfocus=D.onmousemove=D.onkeydown=setUserActive",100) } function autoRefresh() { if (userActive[0]) location.reload() setUserPassive(0) if (W.AUTO_REFRESH_TIME) setTimeout("autoRefresh()",AUTO_REFRESH_TIME) } function setUserOnline() { if (userActive[1]) { var IMG=new Image IMG.src=SET_USER_ONLINE_IMG } setUserPassive(1) if (W.AUTO_ONLINE_TIME) setTimeout("setUserOnline()",AUTO_ONLINE_TIME) } // ------------------------------------/ // ---------------------------------\ // See special.php, make_page_bar() // ------------------------------------\ function changePortion(sel) { var f=sel.form var pageURL=f.pageURL.value var oldInd=eval(f.oldIndex.value) var ind=sel.selectedIndex; if (ind!=oldInd) location.href=pageURL+sel.options[ind].value } // ------------------------------------/ // ----------------------\ // Check if field is filled // ------------------------------------\ function checkFilled(field,alertMessage) { if (! field.value.length) { alert((alertMessage!=null) ? alertMessage : "Пустое значение недопустимо!") field.focus() return false } return true } // ------------------------------------/


Все о векторной и растровой графике: CorelDraw

Главная » Основы CorelDraw
CorelDraw 10

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

следующая»

Векторная графика

Итак, начинаем знакомство с векторной графикой. Графика бывает двух типов - векторная и растровая. Для работы с растровой графикой есть замечательная программа Corel PhotoPaint. Для работы с векторной - не менее замечательный CorelDraw.

Что же такое векторная графика? В чем преимущества и недостатки вектора?

Можно сказать, что векторная графика - это рисунок, сделанный цветными карандашами, в то же время растровую графику можно сопоставить с фотографическим изображением.

Основное отличие - в принципе хранения изображения. Векторная графика описывает изображение с помощью математических формул. По своей сути любое изображение можно разложить на множество простых объектов, как то - контуры, графические примитивы и т.д. Любой такой простой объект состоит из контура (на рисунке изображен красным цветом) и заливки (синий цвет).

Основное преимущество векторной графики состоит в том, что при изменении масштаба изображения оно не теряет своего качества. Отсюда следует и другой вывод - при изменении размеров изображения не изменяется размер файла. Ведь формулы, описывающие изображение, остаются те же, меняется только коэффициент пропорциональности. С другой стороны, такой способ хранения информации имеет и свои недостатки. Например, если делать очень сложную геометрическую фигуру (особенно если их много), то размер "векторного" файла может быть гораздо больше, чем его "растровый" аналог из-за сложности формул, описывающих такое изображение.

Из всего вышесказанного можно сделать вывод, что векторную графику следует применять для изображений, не имеющих большого числа цветовых фонов, полутонов и оттенков. Например, оформления текстов, создания логотипов и т.д.

Далее приступаем к изучению векторной графики на основе работы с программой CorelDraw.

следующая»
Полезное
Copyright © 2005 Юрий Кордык
All Rights Reserved
 Дизайн сайта
Katal Design Group


Векторная графика: Стартовое окно CorelDraw

Главная » Стартовое окно

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Стартовое окно программы

Итак, начинаем изучать векторную графику при помощи замечательной канадской программы Corel Draw.

Коль уж Вы читаете эти строки, разрешите предположить, что элементарные навыки обращения со строками меню, панелями инструментов, контекстными меню и т.д., Вы уже имеете. Т.е. Вы знакомы с текстовым редактором Word или электронными таблицами Excel. Если, вдруг окажется, что я ошибаюсь, посетите ресурс "OnLine обучение Word, Excel" и ознакомьтесь с первыми уроками, там все подробно изложено.

Все же я хочу сказать пару слов о стартовом окне программы Corel Draw, т.к. оно немного отличается от уже ранее встречавшихся Вам.

В самом верху, как и всегда, находится "Строка заголовка". Поде ней - "Строка меню". Затем идут панели инструментов. На рисунке в частности показаны следующие панели: "Стандарт" и "Панель свойств". Еще ниже располагается собственно само рабочее окно программы. Слева от окна находится "Панель инструментов". Справа - пристыковываемые окна. Еще правее пристыковываемых окон находится панель палитры цветов. В самом низу находится "Строка состояния". Чтобы не забивать изначально голову многими новыми вещами - все панели будем рассматривать по ходу изучения материала.

Напоследок бы хотелось пару слов сказать об очень удобном средстве навигации - кнопке "Навигатор".

Этот интерактивный элемент дополняет такие средства навигации как полосы прокрутки и инструмент "Рука". Внешне он представляет собой раскрывающееся окно, внутри которого содержится миниатюра активного изображения с наложенной на него рамкой, ограничинвающей выводимый в данный момент на экран фрагмент изображения. Можно легко перемещать рамку по миниатюре изображения с помощью указателя мыши, делая видимыми нужные участки изображения.

Для отображения раскрывающегося окна "Навигатор" достаточно нажать мышью расположенную в правом нижнем углу окна изображения квадратную кнопку с пустым квадратиком внутри ее.

Следует сказать, что кнопка "Навигатор" становится доступной только тогда, когда изображение полностью не помещается в окне изображения. Это возможно в случае использования большого экранного увеличения либо большого размера исходного изображения.

«предыдущая | СorelDraw | следующая»

top


Векторная графика: рисование прямоугольников

Главная » Рисование прямоугольников

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Рисование прямоугольников

Рисование прямоугольников
Закругление углов
Рисование прямоугольников

Прямоугольник - самая простая из базовых форм.

Для того, чтобы нарисовать прямоугольник надо проделать следующие операции:

1. На панели графики надо выбрать инструмент "Прямоугольник" (F6). После этого курсор примет вид маленького перекрестья. Справа внизу от перекрестья изображается небольшой прямоугольник.

2. Щелкните левой кнопкой мыши в точке расположения одного из углов будущего прямоугольника, и, удерживая левую кнопку мыши, протяните мышь по диагонали к противоположному углу прямоугольника.

3. Отпустите кнопку мыши. Прямоугольник готов!

Обратите внимание, что после того как выбран какой-либо инструмент рисования, на панели инструментов автоматически появляется панель, соответствующая выбранному инструменту. После того как прямоугольник нарисован и отпущена кнопка мыши, в строке состояния (внизу окна) появляется сообщение о том, что на слое 1 имеется выделенный прямоугольник, а на панели атрибутов выводятся окончательные значения его высоты, ширины и координат центра.

Если при рисовании прямоугольника удерживать клавишу CTRL, то размеры его сторон автоматически выравниваются до геометрически правильного квадрата. Если при рисовании удерживать клавишу Shift, то прямоугольник будет рисоваться не от угла, а от центра. Это очень удобно в тех случаях, когда точно известны координаты центра прямоугольника. Следует сказать, что клавиша CTRL является универсальным выравнивателем в программе CorelDraw. Так при рисовании эллипса при нажатой CTRL будет нарисована правильная окружность.

Обратите внимание, что прямоугольник в центре имеет значок х. Щелчок на данном значке и перетаскивание его мышью позволяет быстро перемещать объект.

Закругление углов

Когда прямоугольник является активным объектом, на панели атрибутов появляются четыре текстовых поля, в которых задается процент закругления, как показано на рисунке.

Процент задается по отношению к самой короткой стороне прямоугольника. Обратите внимание - вводимая величина не является радиусом угла. Справа от текстовых полей находится кнопка с изображением замка. Когда кнопка с замком нажата, изменение любого значения приводит к изменению всех четырех углов. В противном случае можно задать закругление для каждого угла по отдельности. После ввода процента закругления надо нажать клавишу ENTER, чтобы изменения вступили в силу. Если задать процент закругления равным 100, то самая короткая сторона будет полностью закруглена.

Закруглять углы можно в интерактивном режиме. Если подвести указатель инструмента "Прямоугольник" к одному из узлов прямоугольника, то курсор изменится и примет вид жирной стрелки с перекрестием внизу. В этом случае инструмент рисования действует подобно инструменту "Форма". Надо курсором указать на нужный узел, нажать левую кнопку мыши и перетащить указатель мыши в нужное место. После чего отпустить кнопку мыши.


Векторная графика: рисование эллипсов

Главная » Рисование эллипсов

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Рисование эллипсов

Рисование эллипсов
Построение секторов и дуг
Рисование эллипсов

Эллипс одна из самых полезных форм-примитивов.

При рисовании эллипса необходимо четко представлять себе, как определяется его размер. На самом деле рисуется не эллипс, а воображаемая прямоугольная область (габаритная рамка) в которую вписан эллипс.

Эллипс рисуется аналогично прямоугольнику:

1. На панели графики надо выбрать инструмент "Эллипс" (F7). После этого курсор примет вид маленького перекрестья. Справа внизу от перекрестья изображается небольшой эллипс.

2. Щелкните левой кнопкой мыши в точке расположения одного из углов будущего прямоугольника в который будет вписан эллипс, и, удерживая левую кнопку мыши, протяните мышь по диагонали к противоположному углу прямоугольника.

3. Отпустите кнопку мыши. Эллипс готов!

При этом на панели атрибутов (аналогично рисованию прямоугольника) выводятся значения ширины и высоты эллипса, а также координат его центра.

Удержание клавиши CTRL во время рисования эллипса позволяет рисовать правильную окружность. Одновременное нажатие CTRL и SHIFT позволяет рисовать правильную окружность от центра. Следует помнить, что отпускать кнопку мыши нужно раньше, чем клавишу-модификатор.

Нарисованный эллипс можно перемещать, щелкнув на значке х в центре фигуры и перетащив указатель мыши в нужное место.

Построение секторов и дуг

Сектор или дугу можно построить щелкнув на соответствующей кнопке панели атрибутов, изображенной ниже.

Каждый эллипс имеет один узел (маленький квадратик на эллипсе). Если эллипс рисовался от верхнего угла воображаемого прямоугольника к нижнему, то узел располагается в верхней точке эллипса. Если эллипс рисовался от нижнего угла к верхнему - то узел располагается внизу. Чтобы создать дугу, выделите узел инструментом "Форма" и перетащите его в направлении от центра эллипса. Чтобы создать сектор - перетащите узел внутрь эллипса.

Если при перетаскивании узла удерживать клавишу CTRL, то угловой размер дуги или сектора изменяется кратно величине приращения угла, которая задана в окне диалога "Параметры". По умолчанию это 15°.

Если выделить сектор или дугу, на панели атрибутов отображается начальный и конечный углы, тип объекта и рисования. Чтобы новое значение вступило в силу, надо нажать ENTER.

Попробуйте при помощи секторов, дуг и эллипса, самостоятельно построить веселую рожицу, изображенную ниже.


Векторная графика: рисование многоугольников

Главная » Рисование многоугольников

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Рисование многоугольников

Рисование многоугольников
Модификация многоугольников
Рисование многоугольников

Начнем с рисования простейшего многоугольника.

На панели графики надо выбрать инструмент "Полигон". При этом курсор принимает вид перекрестия с многоугольником. Теперь надо перетащить указатель мыши, удерживая левую кнопку. При этом получается пятисторонний многоугольник. Удерживание CTRL, SHIFT позволяет рисовать правильный многоугольник от центра.

После того, как базовый многоугольник нарисован, можно заняться его модификацией. Начнем с изменения числа сторон. Это легко сделать с помощью панели атрибутов. Надо всего лишь ввести необходимое число сторон и нажать ENTER. Если нужна звезда - щелкните на соответствующей кнопке. Следует отметить, что при этом линии, соединяющие вершины звезды, пересекают внутреннюю область фигуры. Если нужно построить звезду со свободной внутренней областью, надо использовать несколько иной метод рисования, но об этом немного позже.

Левее кнопок "Полигон/Звезда" на панели атрибутов находится ползунок, управляющий величиной заострения углов при вершинах звезды. Если у нарисованной звезды всего пять лучей, этот ползунок будет недоступен. Он становится доступным если число лучей звезды больше или равно семи. Для звезды с семью лучами можно установить уровень заострения углов равным 1 или 2. По мере роста числа вершин увеличивается и допустимое число уровней заострения углов при вершинах, т.к. на самом деле этот параметр представляет собой просто количество точек-вершин, которые пропускаются между соединяемыми вершинами звезды. Чем выше уровень заострения, тем более остроконечной будет звезда.

Модификация многоугольников

По настоящему интересные возможности данного инструмента проявляются в процессе редактирования многоугольников при помощи инструмента "Форма".

Нарисованный многоугольник имеет по одному узлу в точках вершин и по одному - в серединах сторон. Таким образом, типовой пятисторонний многоугольник имеет десять узлов. Узлы вершин и узлы сторон при редактировании формы многоугольника ведут себя синхронно, так что при перемещении одного из них все узлы такого же типа переместятся подобным образом.

Не меняя выбранного инструмента "Полигон", щелкните на одном из узлов ранее нарисованного многоугольника. Перетащите узел к центру многоугольника и обратите внимание на то, что остальные узлы перемещаются при этом совершенно аналогично. Теперь перетащите узел по часовой стрелке - остальные узлы в вершинах поведут себя схожим образом. В процессе перемещения узлов виден контур объекта-оригинала. Этот контур всего лишь упрощает визуальный контроль преобразования и не воспроизводится после того, как преобразование закончено. Однако не стоит злоупотреблять множеством сторон многоугольника, т.к. при печати могут возникнуть определенные проблемы.


Векторная графика: рисование спиралей, диаграммной сетки

Главная » Рисование спиралей

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Рисование спиралей

Рисование спиралей
Рисование диаграммной сетки
Рисование спиралей

Кнопка инструмента "Спираль" является средней из трех кнопок, находящихся на раскрывающейся панели "Объект". После выбора инструмента "Спираль" курсор приобретает вид перекрестия со спиралью.

Перед тем как приступить к рисованию спирали, надо задать нужные значения параметров на панели атрибутов, показанной ниже.

Спирали имеют эллиптическую форму, так что процесс их рисования аналогичен построению эллипсов. В ходе рисования в строке состояния выводятся значения высоты и ширины спирали. Удерживание CTRL, SHIFT рисует правильную спираль от центра.

Рядом со счетчиком витков на панели атрибутов находятся две кнопки для определения типа спирали. По умолчанию выбрана симметричная спираль. Каждый виток симметричной спирали отстоит от предыдущего на одинаковое расстояние. Правая кнопка включает режим рисования логарифмической спирали, у которой каждый следующий виток все дальше отстоит от предыдущего. Степень нарастания шага спирали зависит от коэффициента расширения, значение которого определяется ползунком, расположенным справа от кнопки выбора логарифмической спирали. Используя инструмент "Форма" можно получать интересные графические эффекты, используя спираль в качестве базовой формы.

Рисование диаграммной сетки

Инструмент диаграммная сетка всего лишь строит сетку из заданного числа строк и столбцов. Доступ к этому инструменту обеспечивается правой крайней кнопкой панели "Объект". После этого курсор принимает вид перекрестия с сеткой внизу.

Перед созданием диаграммной сетки необходимо задать нужное число строк и столбцов.

После задания параметров диаграммной сетки надо протащить указатель мыши по экрану, как это делается при рисовании прямоугольника. Внутри прямоугольника при этом будет изображаться сетка из заданного числа строк и столбцов. Следует обратить внимание, что в строке состояния сообщается, что создана группа объектов. Таким образом, инструмент "Диаграммная сетка" является автоматизированным средством для рисования группы прямоугольников.


Векторная графика: рисование линий любых форм: инструмент Кривая

Главная » Инструмент Кривая

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Инструмент "Кривая"

На предыдущих занятиях мы рисовали различные графические объекты стандартной формы. Теперь рассмотрим как можно создавать объекты произвольной формы. И начнем с инструмента "Кривая".

Нажав клавишу F5, активизируйте левый крайний инструмент.

Инструмент "Кривая" похож на обычный карандаш. При перетаскивании курсора по экрану за ним остается линия. Во время рисования программа расставляет вдоль линии узлы с неравномерными интервалами. В большинстве случаев - чем меньше узлов, тем лучше. То, насколько точно кривая будет воспроизводить движение вашей руки, зависит от состояния ползунка "Сглаживание" на панели атрибутов. Ползунок принимает значения в интервале от 0 до 100 и по умолчанию находится в положении 100.

Прямые линии рисуются немного иначе, чем кривые. Вместо перетаскивания курсора надо щелкнуть кнопкой мыши в начальной точке, переместить курсор и щелкнуть снова, обозначая конец линии. Между двумя точками проводится отрезок прямой линии. Для того, чтобы нарисовать точно горизонтальную или вертикальную линию, надо во время рисования удерживать клавишу CTRL.

В процессе рисования можно переходить от режима изображения прямых линий к режиму кривых произвольной формы и обратно. Начните с рисования кривой, а когда надо будет нарисовать прямолинейный отрезок - нажмите клавишу TAB. Прямая линия закончится там, где вы отпустите левую кнопку мыши или еще раз нажмете TAB. Если во время рисования линии нажать и удерживать клавишу SHIFT, то, перетаскивая курсор вдоль нарисованной линии назад, вы будете стирать фрагменты линии между узлами.


Векторная графика: рисование линий любых форм: инструмент Кривая Безье

Главная » Инструмент Кривая Безье

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Инструмент "Кривая Безье"

На первый взгляд может показаться, что это сложный и непонятный инструмент. Однако, попрактиковавшись пару часов, вы поймете насколько это гибкий и полезный инструмент, обеспечивающий максимально возможную степень контроля над формой кривой в процессе рисования. Каждый щелчок кнопкой мыши при рисовании кривой с помощью данного инструмента создает узел, который соединяется плавной кривой с предыдущим узлом. Но если щелкнуть кнопкой мыши и протащить мышь, вы сможете воздействовать на форму кривой, входящей в данный узел. Регулируя положение направляющих точек, можно влиять на угол наклона и кривизну кривой в точке входа и выхода из узла. Чтобы сменить тип узла на точку перегиба, надо нажать клавишу С (латинский регистр). Закончив рисование, надо нажать клавишу пробела или выбрать другой инструмент.

Теперь, чтобы лучше понять, что это такое, давайте сделаем небольшой пример.

Выберите инструмент "Кривая Безье" и щелкните на странице, при этом будет создан узел.

Переместите курсор по диагонали вверх вправо, щелкните левой кнопкой мыши и, не отпуская кнопку, протащите указатель мыши вправо.

Переместите курсор по диагонали вправо вниз, нажмите и удерживайте в латинском регистре клавишу "С". Щелкните левой кнопкой мыши.

Переместите курсор по диагонали вверх вправо, щелкните левой кнопкой мыши и, не отпуская кнопку, протащите указатель мыши вправо.

Переместите курсор по диагонали вправо вниз и щелкните левой кнопкой мыши.

Подведите курсор к предыдущему узлу и когда он примет форму жирной стрелки, нажмите левую кнопку мыши и, удерживая ее, переместите узел вниз.

Подведите курсор к правой направляющей узла, захватите ее и переместите на 180 градусов относительно узла.

Нажмите пробел.

Вот такая замысловатая фигура у нас получилась всего за пару минут. Потренируйтесь с этим удивительным инструментом и попытайтесь нарисовать елочку, яблоко, автомашину.


Векторная графика: рисование линий любых форм: инструмент Живопись

Главная » Инструмент Живопись

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Инструмент "Живопись"

После выбора этого инструмента панель атрибутов приобретает вид, показанный ниже.

Первые пять кнопок позволяют выбрать тип пера. Возможные варианты - "Заготовка", "Кисть", "Пульверизатор", "Каллиграфическое перо", "С нажимом". При выборе типа пера панель атрибутов изменяется в соответствии со спецификой данного типа. Панель атрибутов на предыдущем рисунке появляется при выборе инструмента "Заготовка". Справа от кнопок расположено текстовое поле, определяющее максимальную толщину создаваемой линии или формы. Эта величина действует по-разному в зависимости от выбранного типа пера. Следующее текстовое поле определяет значение параметра "Наклон пера". Этот параметр используется только при выборе пера каллиграфического типа, во всех остальных режимах он недоступен и изображается тусклым тоном. В правой части панели находится раскрывающийся список разнообразных заготовок перьев.

По большому счету инструмент "Живопись" интуитивно понятен. Попробуйте сами освоить элементарные навыки владения этим инструментом.


Векторная графика: рисование линий любых форм: инструмент Размерная линия

Главная » Инструмент Размер

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Размерные линии

Размерные линии
Угловой размер
Выноски
Интерактивная соединительная линия
Размерные линии

При выборе этого инструмента на панели атрибутов появляется ряд кнопок со значками, соответствующими каждому из возможных типов размерных линий.

Назовем их слева-направо:

"Авторазмер", "Вертикальная размерная линия", "Горизонтальная…", "Наклонная…", "Выноска", "Угловой размер". В большинстве случаев размерные линии связываются с тем объектом, к которому они относятся. Для активации режима связывания используется команда "Макет"-"Привязать к объектам". По умолчанию режим привязки к объектам активизируется автоматически при выборе инструмента "Размерные линии", поэтому обычно к указанной команде меню обращаться более не требуется.

Чтобы целиком нарисовать вертикальную, горизонтальную или наклонную размерную линию, нужно три раза щелкнуть левой кнопкой мыши. Первый щелчок делается в точке начала размерной линии, второй - в ее конечной точке. Третий щелчок производится там, где необходимо поместить текст, указывающий значение размера.

Угловой размер

Основное отличие нанесения угловых размеров от линейных состоит в том, что эта операция выполняется не тремя, а четырьмя щелчками мышью. Первый щелчок выполняется в точке вершины угла, второй - в точке начала дугообразной линии углового размера, третий - в точке ее конца, а четвертый - там, где должен располагаться текст надписи на размерной линии.

Выноски

Выноски не являются размерными линиями. Выноски, как и линейные размерные линии, вставляются с помощью трех щелчков мышью. Первый щелчок выполняется вблизи точки, на которую должна указывать выноска. Этот конец выноски часто снабжается стрелкой. Второй щелчок необходимо сделать в стороне от объекта, в точке, где наклонная линия выноски должна приобрести излом, образовав горизонтальную полку для надписи. Если полка не нужна, то второй щелчок надо выполнять как двойной. Третий щелчок в районе конца линии выноски вызовет появление текстового курсора, позволяющего ввести текст выносной надписи. Линия и текст выноски автоматически связываются с поясняемым объектом, так что при перемещении последнего они перемещаются вместе с ним.

Интерактивная соединительная линия

Этот инструмент крайний правый на панели "Кривая". Это довольно простой инструмент. Он рисует линии, соединяющие два объекта, а нарисованные линии динамически обновляются при перемещении объектов. Линии могут состоять только из горизонтальных и вертикальных отрезков. Чтобы воспользоваться данным инструментом, надо щелкнуть на узле одного объекта и перетащить курсор к узлу другого объекта.


Векторная графика: Фигурный текст

Главная » Фигурный текст

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Фигурный текст

Фигурный текст используется в тех случаях, когда требуется создать короткую надпись с применением специальных эффектов.

Чтобы создать блок фигурного текста, надо выбрать инструмент "Текст" (F8). После этого щелкните левой кнопкой мыши в любом месте окна документа и приступайте к вводу символов с клавиатуры.

Блок фигурного текста обладает теми же свойствами, что и другие графические объекты. Его можно растянуть, зеркально отразить, повернуть и т.д. Чтобы непосредственно отредактировать форму отдельных символов, необходимо предварительно преобразовать текст в набор кривых. Программа также позволяет разъединять, а затем вновь соединять блоки фигурного текста. Давайте проведем небольшой эксперимент.

Напишите слово "Текст".

Выберите команду "Компоновать"-"Разбить художественный текст на части". При этом в менеджере объектов появится пять новых объектов (по числу букв в слове). Т.е. каждая буква представлена отдельный объектом и к ней можно применять различные модификации.

Выделите букву "Т" и выберите команду "Компоновать"-"Преобразовать в кривую". Выберите инструмент "Форма".

В менеджере объектов вместо художественного текста появилась кривая. На самой букве "Т" появились узлы, воздействуя на которые можно модифицировать саму букву или объект. "Поиздевайтесь" над буквой, перемещая узлы в разные стороны. На панели атрибутов можно добавлять новые узлы или удалять ненужные (подробно инструмент "Форма" будет рассматриваться позже).

Чтобы отредактировать текст прямо на рисунке, щелкните кнопкой мыши в пределах текстового блока при выбранном инструменте "Текст" - в тексте появится вертикальный отрезок, обозначающий точку вставки символов. Текст можно редактировать в отдельном окне диалога, выбрав команду "Текст" - "Редактировать текст".

Изменить атрибуты текста можно в окне диалога "Форматирование текста", который вызывается командой "Текст"-"Форматировать текст". Имея навыки работы с текстовым редактором Word, никаких сложностей с изменением атрибутов у вас возникнуть не должно.


Векторная графика: Простой текст

Главная » Простой текст

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Простой текст

Простой текст
Размещение простого текста в связанных рамках
Простой текст

Простой текст применяется для размещения на рисунках текстовых блоков, состоящих из нескольких абзацев, колонок или кадров. Простой текст предназначен для работы с большими текстовыми блоками, к нему могут применяться только эффекты огибающей, тени и прозрачности.

Т.к. в программе существует лишь один инструмент ввода текста, для обозначения режима ввода простого текста необходимо нарисовать рамку блока простого текста.

Щелкните левой кнопкой мыши и протащите курсор по диагонали прямоугольной области, в которой будет располагаться блок простого текста. Как только рамка кадра появится на экране, можно начинать вводить сам текст.

Во время работы с блоком простого текста окаймляющая его рамка снабжается маркерами. Однако при изменении размеров рамки символы заключенного в нее текста сохраняют прежний размер. Меняются только размеры области, в пределы которой вписаны строки текста. Если требуется изменить не только размер текстового кадра, но и размер символов текста, удерживайте при растягивании или сжатии рамки клавишу ALT.

Размещение простого текста в связанных рамках

Из-за того, что блок простого текста может иметь значительный размер, он часто занимает более одной страницы документа или размещается в нескольких кадрах в пределах одной страницы. В этих случаях можно обеспечить автоматическое "перетекание" текста в следующий кадр или на следующую страницу. Когда вводимый текст достигнет нижней границы кадра, маркер в середине нижней границы кадра примет вид прямоугольника с изображенной внутри него стрелкой, направленной вниз. Щелкните на этом маркере и переместитесь в то место рисунка, где должен появиться кадр с продолжением текста. Если вы хотите, чтобы кадр нового абзаца был создан автоматически, просто щелкните кнопкой мыши. Размер автоматически создаваемого кадра совпадает с размером страницы. Есть и другой способ: щелкните кнопкой мыши и протащите курсор по диагонали, нарисовав вручную рамку кадра требуемого размера. Как только кадр будет создан, текст, не поместившийся в первом кадре, автоматически появится во втором, после чего можно продолжить ввод. Если и в этом кадре весь текст не уместится, по его заполнении маркер в середине нижней границы рамки кадра снова примет вид прямоугольника со стрелкой, направленной вниз. Если выделить первый кадр, то вы увидите, что такой же вид имеет маркер в середине нижней границы его рамки. Это говорит о том, что текст в данном кадре имеет продолжение. Когда кадры связаны, между ними изображается соединительная линия, иллюстрирующая связь. Эта линия носит чисто вспомогательный характер и не выводится на печать.


Векторная графика: выделение объектов

Главная » Выделение объектов

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Выделение объектов

Выделение объектов с помощью мыши
Выделение скрытых объектов
Выделение рамкой
Перебор выделенных объектов
Использование меню

Инструмент "Выбор" ничего не создает, однако является одним из самых необходимых инструментов панели графики. Он применяется при выделении, перемещении, масштабировании, повороте и наклоне объектов. Все эти операции могут выполняться многими различными способами.

Прежде чем начинать работать с объектом, его необходимо выделить. Выделение объектов может выполняться четырьмя различными способами.

Выделение объектов с помощью мыши

Это простейший способ выделения объекта. Достаточно щелкнуть левой кнопкой мыши на объекте. Даже если объект не имеет цветовой заливки, для его выделения достаточно щелкнуть внутри контура объекта. Когда объект выделен, вокруг него появляется габаритный прямоугольник, обозначаемый восемью маркерами по углам и серединам сторон. Четыре маркера по серединам сторон являются маркерами растяжения, а четыре по углам - маркерами масштабирования.

Если не хотите, чтобы щелчок внутри объекта без цветовой заливки приводил к его выделению, щелкните на соответствующей кнопке панели атрибутов, показанной ниже.

Когда объект выделен, на панели атрибутов появляется справочная информация о его параметрах - высоте, ширине и координатах центральной точки. При активном инструменте "Форма" в строке состояния выводится количество узлов объекта.

Чтобы выделить сразу несколько объектов, нажмите и удерживайте клавишу SHIFT при щелчке на каждом объекте, добавляемом к выделенному набору. Если обнаружится, что выделены лишние объекты, просто щелкните при нажатой клавише SHIFT на том объекте, который необходимо исключить из выделенного набора.

Иногда может потребоваться выделить объект, входящий в состав группы. В этом случае надо сначала выделить всю группу объектов, а затем выделить объект в составе группы, щелкнув на нем кнопкой мыши при нажатой клавише CTRL. В этом случае маркеры, окружающие выделенный объект из состава группы, будут иметь вид кружочков.

Выделение скрытых объектов

Можно выделять объекты, скрытые под другими объектами. Для этого надо щелкнуть (при нажатой клавише ALT) на том месте, где располагается скрытый объект. После щелчка появляются маркеры объекта и значок в "Х", обозначающий точку центра объекта. Если щелкать кнопкой мыши с нажатыми клавишами ALT+SHIFT, вновь выделяемые объекты будут добавляться к уже выделенному набору. Можно также выделять скрытые объекты, входящие в состав группы, если в момент щелчка удерживать клавиши ALT+CTRL.

Выделение рамкой

Выделение объектов щелчками удобно в случаях, когда число выделяемых объектов мало. Однако часто возникает потребность выделить множество объектов, тесно примыкающих друг к другу. В этом случае удобно воспользоваться способом выделения объектов при помощи рамки.

Выделение объектов с помощью рамки подобно рисованию прямоугольника. По мере рисования (при выбранном инструменте "Выбор") на экране появляется пунктирная рамка голубого цвета. Когда все объекты окажутся охвачены рамкой, отпустите кнопку мыши.

Выделяющую рамку можно использовать и для снятия выделения с объектов. При этом надо удерживать клавишу SHIFT.

Перебор выделенных объектов

Еще одним способом выделения объектов является использование клавиши TAB. При каждом нажатии это клавиши выделяется объект, очередной по порядку расположения объектов в стеке (о нем мы поговорим позже). При нажатой комбинации SHIFT+TAB перебор объектов осуществляется в обратном порядке.

Использование меню

Для выделения всех объектов можно воспользоваться командой меню "Правка"-"Выделить все"-"Объекты". Чтобы отменить выделение всех объектов, нажмите клавишу ESC.


Векторная графика: операции с объектами

Главная » Операции с объектами

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Операции с объектами

Перемещение объектов
Относительное перемещение
Абсолютное размещение

После выделения с объектами выполняются различные операции - например, перемещение, масштабирование, поворот, наклон и т.д.

Перемещение объектов

Чтобы переместить выделенный объект в какое-то другое место рисунка, просто передвиньте его. Щелкнуть на выделенном объекте или группе объектов кнопкой мыши и перетащить на новое место - это все, что требуется для перемещения объекта. В процессе перетаскивания выделенного объекта на экране изображается его контур, показывающий текущее положение перемещаемого объекта. Контур может быть либо голубого цвета, либо с цветовой заливкой. Нажимая на клавишу TAB, можно переключаться между различным отображением контура.

В первом случае, когда отображается контур без заливки, можно видеть объекты, оказывающиеся под перемещаемым объектом, и не требует перерисовки экрана. Следовательно, данный метод отображения работает быстро.

Второй вариант обеспечивает наиболее высокое качество отображения, но при его использовании не видны объекты, закрываемые перемещаемым объектом, и данный метод требует более длительного времени на прорисовку экрана. Однако, на современных компьютерах, имеющих высокую производительность, задержка почти не видна.

Для того, чтобы создать дубликат объекта, надо нажать клавишу "+" на цифровой части клавиатуры. Но сделать это надо обязательно до того, как будет отпущена левая кнопка мыши.

Можно перемещать объекты, используя вместо левой правую кнопку мыши. При этом после освобождения правой кнопки на экране появится контекстное меню, в котором надо будет выбрать режим "Копировать" или "Переместить".

Если объект надо расположить прецизионно точно, то надо воспользоваться средствами панели атрибутов. Если на рисунке есть выделенный объект, а инструмент "Выбор" активен, то на левом краю панели атрибутов будут отображаться координаты центра объекта.

Если изменить эти значения, то после нажатия клавиши ENTER выделенный объект автоматически переместится в заданную позицию. Для перехода на панели атрибутов от одного текстового поля к другому можно пользоваться клавишей TAB или просто щелкнуть на нужном поле кнопкой мыши. После числа можно ввести аббревиатуру единиц измерения, что позволит работать с любыми допустимыми единицами независимо от настройки экранных линеек. Кроме того, можно вводить математические выражения.

Относительное перемещение

Часто возникает необходимость сместить объект на заданное расстояние в конкретном направлении. В этом случае удобно определять новые координаты объекта относительно его текущего положения.

Выберите команду "Компоновать"-"Преобразовать"-"Позиция" (ALT+F7). В докере справа появится новое окно "Трансформация".

В этом окне можно ввести любую требуемую величину относительного перемещения объекта. В середине окна имеется флажок "Относ позиции". Когда он установлен, все величины, задаваемые в счетчиках "Г" (горизонталь) и "В" (вертикаль), будут восприниматься как смещения объекта относительно его текущей позиции, координаты которой обозначаются как (0,0). Чтобы выполнить перемещение надо щелкнуть на кнопке "Принять" в нижней части окна или нажать ENTER. Чтобы разместить в указанном положении копию объекта, щелкните на кнопке "Применить дубликат".

Абсолютное размещение

Страница "Положение" докера "Трансформация" также позволяет указать абсолютные координаты одной из девяти фиксированных точек выделенного объекта. Этими фиксированными точками являются четыре угловых маркера габаритного прямоугольника выделенного объекта, четыре маркера по серединам сторон габаритного прямоугольника и центр.

Когда работа ведется при снятом флажке "Относ позиции", выбор той или иной позиции переключателя в решетке фиксированных точек не приведет к немедленному перемещению объекта, но вызовет отображение в соответствующих счетчиках текущих значений вертикальной и горизонтальной координат выбранной точки объекта. Весь процесс позиционирования сводится к тому, чтобы указать точные значения абсолютных координат положения той фиксированной точки объекта, которая указана на координатной схеме. Это просто, если объект прямоугольной формы. Сложность возникает при работе с объектом сложной формы (например эллипс). В этом случае, например при выборе верхнего левого угла решетки, в точку с заданными координатами будет помещен левый верхний угловой маркер габаритного прямоугольника эллипса.

Для более быстрого понимания механизма работы абсолютного перемещения объекта, поэкспериментируйте различные режимы перемещения с объектами разнообразной формы. Думаю, через полчаса вы полностью овладеете этой несложной "наукой".


Векторная графика: изменение размеров объектов

Главная » Изменение размеров объектов

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Изменение размеров объектов

Блокировка объектов
Изменение размеров объектов
Точное задание размеров Масштабирование объектов
Зеркальные отображения объектов
Повороты объектов
Наклоны объектов
Блокировка объектов

Чтобы заблокировать объект, надо его сначала выделить, а затем выбрать команду "Компоновать"-"Заблокировать объект". Можно также щелкнуть на объекте правой кнопкой мыши и выбрать команду "Блокировать" в контекстном меню. Заблокировав объект, вы заметите, что квадратные маркеры его габаритного прямоугольника приняли вид миниатюрных замков.

Когда объект заблокирован, его нельзя переместить, преобразовать, применить к нему заливку или обводку. Чтобы разблокировать объект, сначала его следует выделить, а затем - выбрать в меню команду "Компоновать"-"Разблокировать объект" или из контекстного меню.

Изменение размеров объектов

Для изменения размера выделенного объекта надо установить указатель мыши на один из маркеров, расположенных по периметру габаритного прямоугольника, и перетащить его в направлении увеличения или уменьшения размера объекта. Если перетаскивать угловой маркер, масштабируемый объект сохраняет свои пропорции. Если же перетаскивать маркер в середине одной из сторон, то объект будет растягиваться или сжиматься только в одном направлении и его пропорции будут искажены.

Точное задание размеров

Для точного задания размеров выделенных объектов быстрее всего воспользоваться элементами управления, расположенными на панели атрибутов.

Введите требуемые значения размеров в текстовые поля и нажмите клавишу ENTER. Если требуется сохранить пропорции объекта при изменении его размеров, воспользуйтесь кнопкой с изображением замка, находящейся на панели атрибутов. Когда эта кнопка находится в отжатом состоянии, пропорции объекта не сохраняются. Аналогичные средства существуют в пристыковываемом окне "Трансформация".

Масштабирование объектов

Одним из вариантов изменения размеров объекта является масштабирование, при котором новый размер указывается в процентах по отношению к текущему. Для этой цели можно воспользоваться элементами панели атрибутов, показанными на рисунке выше.

Вместо точных значений размеров объекта в данном случае указывается процент изменения масштаба по каждой из осей координат. Таким образом, если по каждой из осей вводится значение 50%, то объект вдвое уменьшится, а если 200% - вдвое увеличится. И вновь кнопка со значком в виде замка, расположенная следом за полями ввода значений масштаба, может быть использована для блокировки исходных пропорций объекта. Аналогичную операцию можно выполнить при помощи пристыковываемого окна "Трансформация".

Зеркальные отображения объектов

Обычно преобразование зеркального отражения требует, чтобы размеры объекта были сохранены. Однако часто данное преобразование применяется для создания отражения или имитации тени, размеры которых отличаются от объекта-оригинала. В этих случаях можно построить зеркальное отражение с помощью мыши. Для построения зеркального отражения относительно вертикальной (горизонтальной) оси просто установите курсор на один из боковых (но не угловых) маркеров выделенного объекта и перетащите маркер через внутреннее пространство объекта на его противоположную сторону. Когда отраженный объект приобретет требуемый размер, отпустите кнопку мыши.

Как и при других преобразованиях, щелчок правой кнопкой мыши или нажатие клавиши "+" в процессе перетаскивания приводит к тому, что в качестве отражения создается дубликат объекта. Чтобы размеры зеркального отражения совпадали с размерами исходного объекта, в процессе перетаскивания маркера следует удерживать клавишу CTRL.

Ввод отрицательных величин в полях масштаба также приведет к построению зеркального отражения объекта.

Повороты объектов

Чтобы вручную повернуть или наклонить объект, следует еще раз щелкнуть на выделенном объекте или, если объект не выделен, два раза щелкнуть на нем левой кнопкой мыши. После второго щелчка угловые маркеры выделенного объекта превращаются в маркеры поворота, а боковые - в маркеры наклона. В центре вращения объекта появляется значок в виде канцелярской кнопки.

Начните перетаскивать любой из маркеров поворота - объект станет поворачиваться вокруг точки центра вращения. При этом в строке состояния будет отображаться точная величина угла поворота. Как только вы отпустите кнопку мыши, объект будет перерисован с поворотом на заданный угол.

По умолчанию объект поворачивается вокруг своего истинного центра, обозначенного "канцелярской кнопкой", но центр вращения можно переместить в любое место как внутри габаритного прямоугольника объекта, так и за его пределами. Просто щелкните на значке центра и перетащите его в нужное место. Поворот объекта можно выполнить при помощи панели атрибутов. Просто введите требуемое значение угла поворота в соответствующее текстовое поле панели и нажмите ENTER. Следует помнить о том, что сразу же после поворота значение угла на панели атрибутов обнуляется, так что после серии поворотов невозможно будет уточнить, на какой угол в целом произведен поворот.

Для поворота объекта также можно воспользоваться пристыковываемым окном "Трансформация".

Наклоны объектов

Наклон объекта в отличие от поворота означает искажение его геометрической формы. Одни из сторон объекта остается неподвижной, а другая, противоположная ей, - сдвигается по горизонтали или вертикали. При использовании мыши просто захватите один из маркеров наклона и перетащите его в нужном направлении. Для наклона по вертикали используются маркеры на вертикальных сторонах габаритного прямоугольника, а для наклона по горизонтали - один из маркеров на его горизонтальных сторонах. При выполнении наклона величина угла отображается в строке состояния.

Для поворота объекта также можно воспользоваться пристыковываемым окном "Трансформация".


Векторная графика: Инструменты произвольных преобразований

Главная » Инструменты произвольных преобразований

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Инструменты произвольных преобразований

Инструменты произвольных преобразований
Поворот на свободный угол
Отражение под свободным углом
Свободное масштабирование
Свободный скос
Панель инструментов "Преобразования"
Отмена преобразований
Инструменты произвольных преобразований

Если щелкнуть на кнопке инструмента "Свободное преобразование", находящейся на панели инструмента "Форма", то панель атрибутов примет вид, показанный ниже.

Слева - направо:
- Поворот на свободный угол;
- Отражение под свободным углом;
- Свободное масштабирование;
- Свободный скос.

Чтобы воспользоваться любым из этих инструментов, следует щелкнуть на рабочем поле окна документа и начать перетаскивать курсор. В процессе перетаскивания демонстрируется предварительный результат в виде контура преобразованного объекта. Точка, где был произведен щелчок в окне документа, становится фиксированным центром, относительно которого и производится преобразование.

Поворот на свободный угол

При использовании этого инструмента первый щелчок кнопкой мыши определяет на рисунке точку центра вращения объекта. В процессе перетаскивания курсора в окне документа изображается пунктирная линия, позволяющая отследить угол поворота, а также контур поворачиваемого объекта. Как только кнопка мыши будет отпущена, преобразование завершится.

Отражение под свободным углом

Первый щелчок кнопкой мыши задает точку, через которую будет проходить ось отражения объекта. Если эта точка будет находиться на некотором расстоянии от объекта, то отражение появится на вдвое большем расстоянии от оригинала в направлении перетаскивания курсора.

Свободное масштабирование

Первый щелчок кнопкой мыши устанавливает точку, относительно которой будет производиться изменение масштаба объекта. По мере перетаскивания курсора масштаб и размещение преобразуемого объекта будут меняться в зависимости от положения центра преобразования по отношению к оригиналу и направления перетаскивания. По умолчанию данное преобразование не является пропорциональным, так что форма объекта будет искажаться. Чтобы сохранить исходные пропорции объекта, в ходе преобразования следует удерживать клавишу CTRL.

Свободный скос

Первый щелчок устанавливает фиксированную точку преобразования наклона. По мере перетаскивания курсора объект наклоняется одновременно и по оси Х, и по оси Y. В этом данный инструмент существенно отличается от традиционного, который наклоняет объекты только относительно одной из сторон габаритного прямоугольника. Если в процессе перетаскивания удерживать CTRL, то наклон будет выполняться только вдоль одной из осей объекта.

Панель инструментов "Преобразования"

Назначение элементов слева - направо:
- Центр вращения;
- Угол наклона;
- Применить к копии;
- Относительно объекта

Текстовые поля "Центр вращения" позволяют точно задать позицию центра вращения преобразуемого объекта. Это исключает необходимость вручную перетаскивать точку центра объекта. Вместо интерактивного перемещения маркеров наклона объекта можно ввести точные значения углов наклона по каждой из осей координат.

Если щелкнуть на кнопке "Применить к дубликату", то любые преобразования будут применяться к копии объекта, а оригинал останется неизменным.

Последняя кнопка "Относительно объекта" позволяет установить, будут ли задаваемые на панели числовые параметры отсчитываться относительно страницы документа или относительно объекта. Когда кнопка не нажата, все значения отсчитываются относительно страницы документа, и это соответствует традиционному режиму работы панели атрибутов. Если кнопка отжата, все числовые параметры отсчитываются относительно объекта.

Отмена преобразований

Если преобразований было немного, то можно воспользоваться командой "Правка"-"Отменить" (CTRL+Z). Но эта команда не спасает, если после завершения преобразований объекта было внесено множество изменений. В этом случае надо воспользоваться командой "Компоновать"-"Очистить преобразования". Эта команда придаст исходный вид преобразованному объекту, даже если рисунок был сохранен, закрыт и заново открыт. Если после отмены преобразований выбрать команду "Правка"-"Отменить", объект снова примет полностью преобразованный вид.


Векторная графика: Инструмент Форма

Главная » Инструмент Форма

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Инструмент "Форма"

Общие сведения об узлах
Прямые
Кривые

Это наиболее часто используемый инструмент CorelDraw. Он применяется для правки произвольных кривых, эллипсов, многоугольников, звезд, символов, строк текста, растровой графики и т.д.

Показанная на рисунке ниже раскрывающаяся панель инструмента "Форма" содержит четыре инструмента: "Форма", "Лезвие", "Ластик", "Свободное преобразование". Последний инструмент рассматривался на предыдущем уроке.

Общие сведения об узлах

Узлы составляют основу векторных графических конструкций. Каждый узел - это не более чем точка на плоскости, имеющая пару координат (x,y). Давайте разберемся зачем нужны узлы, а затем закрепим теорию на практике.

Как же создаются графические объекты в CorelDraw? Для создания объектов используются приемы векторной геометрии. Все нарисованные линии векторной графики описываются координатами узлов и математическими уравнениями соединяющих их отрезков кривых. Когда векторный рисунок увеличивается, коэффициенты уравнений просто подстраиваются под новый размер, и поэтому потери качества не происходит.

Ранее мы уже сталкивались с кривыми Безье. Рассмотрим эти кривые поподробнее.

Идея принадлежит французскому математику Пьеру Безье. Он открыл, что любой сегмент кривой можно описать в виде совокупности фиксированной точки (x,y) и двух контрольных точек (x1,y1) и (x2,y2). Связь между этими точками продемонстрирована на рисунке.

Фиксированная точка называется узлом. Две контрольные точки называются направляющими точками Безье. Некоторые узлы имеют лишь одну направляющую точку, поскольку они соединяют прямую линию с кривой. Для расширения возможностей желательно иметь две направляющие точки. Для этого надо преобразовать прямую линию в кривую. Хотя на плоскости можно расположить и одну-единственную точку, ни один узел векторной графики не может существовать сам по себе. Когда к первому узлу добавляется второй, образуется сегмент. Первый узел всегда изображается несколько большего размера, чем остальные, а когда он выделен, то в строке состояния появляется сообщение, что этот узел - первый.
Прямые
Линейный сегмент представляет собой отрезок прямой линии между двумя узлами. То, что сегмент является линейным, определяется не только тем, что узлы соединены прямой линией, но и тем, что эта линия не может быть искривлена. На конце линейного сегмента находится узел, называемый линейным узлом. Такой узел не может иметь направляющей точки Безье со стороны линейного сегмента. Всякая векторная линия может включать в себя как прямолинейные, так и криволинейные сегменты, так что узлы - это точки, отделяющие сегменты друг от друга.
Кривые
Криволинейный сегмент может быть представлен и прямой линией, но, в отличие от прямолинейного сегмента, узел на его конце снабжается направляющими точками Безье, позволяющими изменять форму кривой.
Узел представляет собой всего лишь точку на плоскости, да и каждая из направляющих точек Безье - не более чем точка, характеризуемая парой координат. Когда узел кривой выделен, можно видеть как сам узел, так и две направляющие точки, соединенные пунктирной линией. Эта линия состоит из касательных к двум участкам кривой - участку, входящему в узел, и участку, выходящему из узла. Помните о том, что наличие двух направляющих точек допускает различные углы входа кривой в узел и ее выхода из узла.


Векторная графика: Пять типов узлов

Главная » Пять типов узлов

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Пять типов узлов

Точки перегиба
Сглаженные узлы
Симметричные узлы
Выделение узлов
Перемещение узлов

В CorelDraw существует пять типов узлов: точка перегиба, сглаженный, симметричный, линейный перегиб, линейный сглаженный. Поведение направляющих точек Безье на входе в узел и выходе из него зависит от типа узла.

Направляющие точки узлов можно перемещать ближе или дальше от узла, а также вращать относительно него. Приближение направляющей точки к узлу делает сегмент кривой, входящей в узел, более "натянутым", а удаление - более искривленным.

Точки перегиба

Точки перегиба используются на концах кривых, а также в тех случаях, когда кривая должна иметь излом в узловой точке. Чтобы регулировать форму кривой на входе и выходе узла, перемещайте направляющие точки ближе к узлу или дальше от него. Направляющие точки узлов данного типа можно вращать относительно узла независимо друг от друга. Ниже приведены некоторые примеры точек перегиба.

Сглаженные узлы

Сглаженные узлы не могут использоваться в точке стыка двух линейных сегментов; в этих случаях требуется точка перегиба. Можно использовать сглаженный узел для соединения прямолинейного и криволинейного сегментов, но это может привести к странным результатам. Чаще всего сглаженные узлы применяются там, где требуется получить кривую с плавным изгибом.

Направляющие точки узла данного типа всегда остаются на одной прямой, то есть углы наклона кривой при входе в узел и на выходе из него не могут различаться. Это означает, что вращение направляющей точки с одной стороны узла автоматически приведет к повороту направляющей точки с другой стороны на тот же угол. В то же время можно перемещать направляющие точки ближе к узлу и дальше от него независимо друг от друга.

Симметричные узлы

Симметричные узлы также не могут использоваться на стыке двух линейных сегментов, где образуется излом линии. Узлы данного типа могут разделять только симметричные криволинейные сегменты, т.к. их направляющие точки всегда находятся на одной прямой и на равном расстоянии от узла. Перемещение одной из направляющих точек вызывает центрально-симметричное зеркальное перемещение второй точки. Симметричные узлы хороши там, где требуется соединить два симметричных сегмента кривой. Следует сказать, что данный тип узлов используется не часто.

Клавиша С преобразует выделенный узел из сглаженного в точку перегиба и наоборот. Клавиша S осуществляет переключение между сглаженным и симметричным узлом.

Выделение узлов

В первую очередь надо выбрать инструмент "Форма" (F10).

Каждый узел может быть выделен простым щелчком на нем. Если при этом удерживать клавишу SHIFT, то можно одновременно выделить несколько узлов или отменить выделение некоторых из ранее выделенных узлов. Узлы можно выделять и при помощи выделяющей рамки. Если при рисовании рамки удерживать клавишу SHIFT, то произойдет обращение выделения всех узлов, попавших в рамку. При удерживании клавиши CTRL рамка принимает форму квадрата. Клавиша ALT позволяет обвести выделяемые узлы контуром произвольной формы. Нажатие клавиши HOME перемещает выделение на первый узел кривой, а клавиши END - на последний. Если кривая замкнутая, то первый и последний узлы совпадают. Нажатие TAB перемещает выделение к следующему узлу кривой. Все узлы можно выделить двойным щелчком на инструменте "Форма".

При выделении всех узлов на кривой узлы линейных сегментов изображаются без заливки, а криволинейных - со сплошной заливкой.

Перемещение узлов

После того, как узел выделен, его можно просто перетащить в нужное место рисунка. Если выделено несколько узлов, то все они будут перемещаться одинаково. Можно ограничить перемещение узлов только вертикальным или только горизонтальным направлением, если во время их перетаскивания удерживать клавишу CTRL.

Если не удается захватить направляющую точку Безье, из-за того, что она совпадает с маркером самого узла, просто нажмите и удерживайте клавишу SHIFT во время перетаскивания направляющей точки в сторону от узла.


Векторная графика: Средства редактирования узлов

Главная » Средства редактирования узлов

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Средства редактирования узлов ч.1

Добавление и удаление узлов
Разъединение кривой и объединение узлов

Закрепим теоретические сведения об узлах на практике. Все средства правки узлов находятся в двух местах: в контекстном меню и на панели атрибутов. Щелчок правой кнопкой мыши на любом узле при активном инструменте "Форма" вызывает появление контекстного меню.

При выбранном инструменте "Форма" все команды контекстного меню отображаются на панели атрибутов.

Команды правки узлов слева-направо и сверху-вниз:
- Добавить узлы;
- Удалить узлы;
- Объединить два узла;
- Разъединить кривую;
- Преобразовать кривую в линию;
- Преобразовать линию в кривую;
- Точка перегиба;
- Сглаженный узел;
- Симметричный узел;
- Изменить направление кривой;
- Замкнуть кривую;
- Извлечь фрагмент;
- Автозамыкание кривой;
- Масштаб и растяжение узлов;
- Поворот и перекос узлов;
- Выровнять узлы;
- Режим гибкого сдвига;
- Выделить все узлы;
- Сглаженность кривой.

В процессе редактирования кривых часто выясняется, что для придания кривой требуемой формы необходимы дополнительные узлы. Чтобы точно разместить новый узел, щелкните кнопкой мыши в том месте кривой, где этот узел должен появиться. В точке щелчка появится черный кружок. Теперь щелкните на кнопке панели атрибутов "Добавить узлы" со значком "+" или нажмите клавишу "+" на цифровой части клавиатуры, и в том месте, где находился кружок, появится новый узел кривой. Можно выбрать инструмент "Форма" и дважды щелкнуть в той точке кривой, где вы хотели бы поместить новый узел.

Можно также выделить один из существующих узлов, а затем щелкнуть на кнопке со значком "+". В результате новый узел будет создан точно в середине сегмента кривой, предшествующего выделенному узлу. Заметьте, что после появления нового узла оказываются выделенными оба - и новый, и старый.

Следовательно, при повторном щелчке на кнопке "+" на кривой появятся два новых узла в серединах сегментов, предшествующих выделенным узлам, и теперь уже выделенными окажутся четыре узла. Таким образом, последовательно щелкая на кнопке со значком "+", можно добавить к кривой множество новых узлов.

Аналогичным образом производится и удаление узлов. Выделите узел или узлы, которые требуется удалить, и щелкните на кнопке со значком - или просто нажмите клавишу DEL. Можно дважды щелкните на любом уз узлов, установив на нем курсор инструмента "Форма", и узел будет удален.

Разъединение кривой и объединение узлов

Выделите любой узел и щелкните на кнопке "Разъединить кривую" панели атрибутов. При этом вместо одного будут созданы два узла, один поверх другого, а кривая будет разбита на две ветви. Переместите любой из этих узлов в сторону, и вы увидите, что они более не соединены между собой. Если кривая до этой операции была замкнута и имела цветовую заливку, то теперь она становится разомкнутой, и цветовая заливка удаляется. Тем не менее, после разъединения кривая не перестанет быть единой.

Давайте вместе проделаем небольшой пример. Нарисуйте окружность. Выберите команду "Компоновать"-"Преобразовать в кривую".

Возьмите инструмент "Форма" и щелкните правой кнопкой мыши на левом узле окружности. В контекстном меню выберите команду "Поломать на части".

Установите курсор на левом узле и, нажав левую кнопку мыши, сдвиньте узел в сторону.

Проделайте аналогичные действия с правым узлом.

Несмотря на то, что у нас получилось две кривые, тем не менее это один объект, о чем свидетельствуют маркеры, окружающие его.

Теперь проделаем обратную операцию. Используя клавишу SHIFT, выделите левые узлы на верхней и нижней кривой и из контекстного меню выберите команду "Соединить два узла".

Результат операции показан на рисунке ниже. Новый узел, объединяющий две ветви кривой, появляется точно посередине между теми точками, где располагались объединяемые узлы. Поэтому имеет смысл предварительно перемещать оба объединяемых узла в ту часть рисунка, где должен появиться новый узел.


Векторная графика: Средства редактирования узлов

Главная » Средства редактирования узлов

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Средства редактирования узлов ч.2

Растяжение и вращение узлов
Изменение направления кривой
Замыкание открытых контуров
Отделение ветвей
Выравнивание узлов
Гибкий сдвиг узлов
Растяжение и вращение узлов

Ранее мы узнали как можно растягивать и поворачивать объект в целом. То же самое можно проделать и с конкретными выделенными узлами. Команды растяжения и поворота узлов становятся доступными лишь после выделения двух или более узлов кривой.

Нарисуйте окружность и преобразуйте ее в кривую (см. предыдущее занятие). Выберите инструмент "Форма" и выделите с помощью рамки все четыре узла кривой и дважды нажмите клавишу "+" на цифровой части клавиатуры, чтобы число узлов увеличилось до 16.

Выделите каждый второй узел, используя клавишу SHIFT. Щелкните на кнопке "Растяжение и масштаб узлов" на панели атрибутов. Вы увидите габаритный прямоугольник, состоящий из восьми маркеров и окружающий весь объект совершенно аналогично тому, как если бы был выделен сам этот объекта, а не его узлы.

Удерживая клавишу SHIFT, переместите один из угловых маркеров в направлении центра окружности приблизительно на две трети расстояния до центра.

Щелкните на кнопке "Поворот и перекос узлов" на панели атрибутов. Вокруг объекта появятся маркеры поворота и перекоса. Удерживая клавишу CTRL, поверните объект на 90°.

Если проделать все эти операции на объекте с заливкой, то все будет выглядеть гораздо симпатичнее.

Все те возможности, которые вы изучили в разделе о растяжении и вращении объектов, применимы также и при работе с узлами.

Изменение направления кривой

Если нажать кнопку "Изменить направление кривой" на панели атрибутов, вы не увидите никаких внешних изменений. Зачем это нужно? Такая возможность может пригодиться при вписывании текста в замкнутую кривую, объединении кривых или использовании инструментов группы "Художественные средства". Работа этих инструментов зависит от направления кривой.

Замыкание открытых контуров

Назначение этой команды понятно из ее названия. Надо выделить оба концевых узла разомкнутой кривой и щелкнуть на кнопке "Замкнуть кривую" панели атрибутов. В результате между двумя концевыми узлами создается прямолинейный сегмент. Кнопка становится доступной лишь после того, как будут выделены два узла на концах разомкнутой кривой. Выделение только одного из узлов не обеспечивает доступа к данной кнопке.

Другой способ добиться того же результата состоит в том, чтобы щелкнуть на кнопке "Автозамыкание кривой". Эта кнопка становится доступной даже если выделен один из концевых узлов кривой.

Отделение ветвей

Для кривых, состоящих из нескольких ветвей, существует ряд способов преобразования любой ветви в независимую кривую. Традиционный вариант - команда "Компоновать"-"Разъединить". Однако, если кривая имеет более двух ветвей, возникает проблема. Например, вам хочется отделить всего одну ветвь, а данная команда разъединяет всю кривую на совокупность обособленных ветвей.

Для решения подобной проблемы можно просто выделить один из узлов отделяемой кривой и щелкнуть на кнопке "Извлечь фрагмент" панели атрибутов. В результате от кривой отделяется только выделенная ветвь, а все остальные остаются в составе кривой.

Выравнивание узлов

Когда на кривой выделено несколько узлов, появляется возможность выровнять их один относительно другого. Щелчок на кнопке "Выровнять узлы" ведет к появлению окна диалога "Выравнивание узлов".

Узлы можно выровнять как по вертикали, так и по горизонтали. Можно выровнять узлы одновременно и по горизонтали, и по вертикали. Такой вариант приводит к тому, что выделенные узлы оказываются расположенными один поверх другого, а сама кривая может приобрести довольно странный вид, т.к. направляющие точки узлов при этом не выравниваются. В таком случае имеет смысл установить флажок "Настройка контрольной точки" и выровнять направляющие точки, чтобы кривая оставалась гладкой.

Гибкий сдвиг узлов

Обычно при одновременном перемещении двух или более узлов кривой все они сдвигаются на одинаковые расстояния. Когда активен режим гибкого сдвига узлов, то расстояния, на которые будут сдвигаться выделенные узлы кривой при перемещении одного из них, окажутся обратно пропорциональными удалению от перемещаемого узла. Это удаление измеряется не по кратчайшему расстоянию, а вдоль кривой.

Нарисуйте спираль, обеспечив выравнивание ее изображения за счет удержания клавиши CTRL. Выделите все витки спирали.

Щелкните на кнопке "Гибкий сдвиг узлов". Щелкните на верхнем узле наружного витка спирали и перетащите его вверх.

Для закрепления навыков работы с узлами, поэкспериментируйте самостоятельно с инструментом "Форма".


Векторная графика: разрезание и стирание объектов

Главная » Разрезание и стирание объектов

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Разрезание и стирание объектов

Инструмент Лезвие
Инструмент Ластик
Инструмент Лезвие

По принципу действия этот инструмент напоминает кнопку "Разъединить кривую" за исключением того, что перед использованием инструмента "Лезвие" не требуется выделять узел кривой. В каком бы месте кривой вы ни щелкнули кнопкой мыши при выбранном инструменте "Лезвие", в этой точке создается узел, а кривая разрывается. Если кривая замкнута, то для преобразования ее в два отдельных объекта может потребоваться два разреза: первый превращает замкнутую кривую в разомкнутую, а второй - разбивает кривую на две несвязанные части. По умолчанию каждая из частей контура автоматически замыкается сразу же после выполнения второго разреза.

Чтобы изменить настройки по умолчанию, надо выбрать инструмент "Лезвие" при отсутствии выделенных объектов. Кнопки панели атрибутов позволяют сохранить разрезанные части объекта в качестве ветвей единой кривой (крайняя левая кнопка) и отменить автоматическое замыкание полученных частей.

Потренируемся на практическом примере.
1. Нарисуйте эллипс и раскрасьте его в любой цвет (для этого надо, после того как эллипс нарисован, щелкнуть левой кнопкой мыши на любом из цветов палитры, находящейся у правого края окна программы).
2. Выберите инструмент "Лезвие" и поместите курсор над контуром яйца с левой стороны. Курсор-лезвие при этом повернется, указывая на готовность к разрезу.
3. Перетащите курсор (удерживая левую кнопку мыши) поперек яйца по зигзаобразной траектории, пока не достигнете противоположного края. Обратите внимание на то, что по достижении края объекта курсор опять поворачивается.
4. Прежде чем отпустить левую кнопку мыши, нажмите клавишу ТАВ. Одна из половинок яйца исчезнет. Еще нажмите ТАВ, теперь исчезнет вторая половинка, а первая появится. Еще раз нажмите ТАВ, и яйцо снова возникнет на рисунке, но будет состоять из двух половинок.

Инструмент Ластик

После выбора этого инструмента на панели атрибутов появляются три дополнительных элемента, имеющих отношение к стиранию.

Первый параметр управляет толщиной ластика.

Другим элементом, управляющим работой ластика, является кнопка "Сократить число узлов после стирания". Нажатие этой кнопки - один из способов автоматизировать выполнение команды "Сократить число узлов".

Третий элемент устанавливает форму ластика (круг/квадрат).

Для использования инструмента "Ластик" надо выделить объект. Выберите инструмент "Ластик" и, удерживая левую кнопку мыши, начинайте стирать объект. По мере перемещения мыши стираемые части изображения будут исчезать с экрана. После отпускания кнопки мыши произойдет фактическое удаление стираемой области объекта и она удаляется из состава объекта.


Векторная графика: Цветовые модели

Главная » цветовые модели

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Цветовые модели

Разностные модели
Аддитивные модели
Модели воспроизведения цвета

Прежде чем использовать какой-либо из доступных методов цветовых заливок, необходимо решить будете ли вы выбирать цвета из палитры или воспользуетесь одной из цветовых моделей. Чтобы не ошибиться в принятии столь важного решения, рассмотрим, чем отличаются различные цветовые модели и палитры (в дополнение к излагаемому материалу советую просмотреть тему "Цветовые модели" растровой ветки сайта). Цветовые модели основаны или на сложении, или на вычитании основных цветов. Модели обоих типов содержат цвета, рассчитываемые по математическим формулам.

Можно провести аналогию с художником, который для получения нужного цвета, смешивает базовые краски на палитре. Таким образом он создает миллионы различных цветов. Цветовую модель можно рассматривать как аналог смешивания цветов в палитре художника. В каждой модели представление цветовых оттенков слегка отличается от других, но все они, подобно палитре художника, обеспечивают возможность выбора нужного цвета среди миллионов различных цветов.

Разностные модели

В разностных цветовых моделях для создания различных оттенков цвета используются чернила. Чем больше красящего пигмента содержится в чернилах, тем темнее их цвет, а чем темнее цвет чернил, тем меньше света отражается от бумаги, на которую наносятся эти чернила.

Разностные модели воспроизведения цвета применяются при многослойной печати с использованием прозрачных чернил голубого (Cyan), пурпурного (Magenta), желтого (Yellow) и черного (Black) цветов (CMYK модель). Нанесение таких чернил в несколько слоев позволяет получать миллионы различных оттенков.

Плашечные цвета также являются цветами разностной модели, но они создаются непрозрачными чернилами. Чернила для плашечной печати не смешиваются друг с другом, вместо этого используется множество чернил различных оттенков. При плашечной печати для каждого из оттенков цвета из состава распечатываемого изображения требуется свое собственное цветоделенное клише, или фотоформа.

При многослойной печати для воспроизведения всего диапазона оттенков цвета требуются всего четыре клише. Некоторые принтеры используют только цветовые компоненты CMY. На таких принтерах для воспроизведения черного цвета используется смешивание 100% каждого из трех основных цветов. Черный цвет, синтезируемый таким способом, на самом деле не получается столь чистым, как при четырехцветной печати с использованием черных чернил.

Аддитивные модели

К аддитивным цветовым моделям относятся модели RGB, HSB, HLS, Lab, YIQ.

В аддитивных моделях, основанных на сложении цветов, для воспроизведения оттенков используются цветные световые лучи. Все оттенки цвета получаются за счет сложения в разных пропорциях трех основных цветов: красного, зеленого и синего(Red, Green, Blue - RGB). Монитор компьютера воспроизводит все цвета спектра именно на основе сложения трех перечисленных цветов. Чем выше интенсивность цвета, тем он ближе к чистому тону, а чем меньше, тем ближе он к черному цвету. Если сложить все три основных цвета с максимальной интенсивностью, равной 255, получится чисто белый цвет. И наоборот, если просуммировать три цвета нулевой интенсивности, получится чисто черный цвет.

Модель, основанная на использовании понятий цветового тона, контрастности и яркости (Hue, Saturation, Brightness - HSB), является другим способом представления основных цветов. Эта модель соответствует наиболее естественному представлению цвета с точки зрения восприятия его человеческим глазом. Понятие "цветовой тон" определяет собственно цвет, "контрастность" характеризует насыщенность цвета, а величиной "яркость" оценивается степень белизны цвета.

Наиболее полный диапазон оттенков имеет цветовая модель Lab. К тому же, она является аппаратно-независимой, т.е. теоретически обеспечивает более предсказуемые результаты по сравнению с любой другой моделью. Аппаратная независимость означает, что цвета отображаются в рамках этой модели без какой-либо привязки к свойствам конкретного монитора.

Модели воспроизведения цвета
Цветовая модель | Базовые цвета модели | Область применения
CMY | Голубой (Cyan), пурпурный (Magenta), желтый (Yellow) | Четырехцветная многослойная печать
CMYK | Голубой (Cyan), пурпурный (Magenta), желтый (Yellow), черный (Blaсk) | Четырехцветная многослойная печать
RGB | Красный (Red), зеленый (Green), синий (Blue) | Экранные презентации, Вэб-графика, слайды
HSB | Цветовой тон (Hue), контрастность (Saturation), яркость (Brightness) | Экранные презентации, Вэб-графика, слайды
HLS | Цветовой тон (Hue), интенсивность (Lightness), контрастность (Saturation) | Экранные презентации, Вэб-графика, слайды
Lab | Яркость (L) и отношения интенсивностей зеленого к красному (a) и синего к желтому (b) оттенков | Четырехцветная многослойная печать
YIQ | Яркость (Y) и хроматические компоненты (I,Q) цветов (Американский телевизионный стандарт NTSC) | Цветное телевидение
Grayscale | 256 градаций серого тона | Черно-белая печать

«предыдущая | СorelDraw | следующая»


Векторная графика: Цветовые палитры

Главная » цветовые палитры

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Цветовые палитры

Цветовые палитры
Стандартная палитра
Цветовые палитры

Электронная цветовая палитра подобна палитре художника за исключением того, что вмещает гораздо больше готовых цветов, чем может разместить на своей палитре художник. Электронная палитра состоит из множества цветовых ячеек, и каждая из них представляет отдельный стандартный цвет. Разнообразные цветовые палитры CorelDraw содержат различные наборы цветов, относящихся к моделям цветовоспроизведения CMYK, RGB или к цветам плашечной печати. Таким образом, основное различие между цветовой моделью и цветовой палитрой состоит в том, что модель позволяет создать любой требуемый цвет, а палитра позволяет выбирать любой цвет из готовой совокупности стандартных цветов.

Цветовые палитры включают отдельные оттенки цвета, которые либо получаются путем смешивания цветов той или иной цветовой модели, либо предоставляются частным поставщиком. Лучшим примером цветовых палитр, поставляемых в частном порядке, являются палитры цветов плашечной и многослойной печати PANTONE. По умолчанию у правого края экрана размещается палитра состоящая из цветов модели CMYK. Для того чтобы заменить эту палитру на другую, выберите команду меню "Окно"-"Цветовая палитра". В появившемся подменю щелкните на строке одного из типов палитр. При каждом последующем запуске CorelDraw выбранная таким образом палитра будет появляться у правого края экрана, обеспечивая быстрый доступ к нужном набору цветов.

Цвета плашечной печати чаще всего применяются в тех случаях, когда требуется использовать конкретный специфический оттенок, указанный заказчиком, или когда графический проект содержит мало оттенков цвета - скажем, один или два. Цвет плашечной печати создается заранее подготовленными чернилами определенного оттенка, и всякий раз при печати данного цвета необходимо использовать именно эти чернила. Можно провести аналогию с магазином строительных материалов, где по каталогу подбираются образцы краски под конкретный оттенок обоев. Реально используемый цвет рассчитывается по формуле и теоретически остается постоянным при каждом последующем смешивании.

Цвета многослойной печати больше напоминают акварель. Это прозрачные краски, оттенок которых зависит от типа растворителя, количества нанесенной краски и т.д.

Для раскрашивания рисунка цветами плашечной печати следует пользоваться сборником, включающим образцы всех цветовых оттенков определенной палитры. В этом случае для начала нужно отыскать в сборнике образцов подходящий оттенок цвета. Каждому оттенку присвоено имя и номер. Выбрав нужный оттенок, достаточно найти этот цвет по его имени или номеру в палитре окна диалога "Однородная заливка" при выбранной вкладке "Фиксированная палитра".

Стандартная палитра

Стандартная палитра цветов по умолчанию размещается у правого края экрана и содержит 89 оттенков цвета модели CMYK, 10 оттенков серого цвета и белый цвет - всего 100 цветовых образцов. Цвета принятой по умолчанию палитры основываются на модели CMYK, так как в большинстве случаев печать результатов работы производится именно на базе такой модели. Однако важно понимать, что при выполнении многослойной печати рисунка совершенно не обязательно ограничиваться цветами этой палитры. Можно применять любую из доступных моделей воспроизведения цвета и цветовых палитр, а затем все так же распечатать результат с применением CMYK-цветов. Это возможно благодаря тому, что CorelDraw интерпретирует все цвета рисунка, кроме цветов плашечной печати, в виде оттенков модели CMYK. Для того, чтобы цвета плашечной печати тоже можно вывести как CMYK-цвета - следует установить флажок "Преобразовать Плашечные цвета в CMYK" на вкладке "Цветоделение" окна диалога "Печать".

Но, все же, несмотря на вышесказанное (если графический проект разрабатывается для последующей печати), для получения оптимальных результатов лучше начинать сразу с использования цветов модели или палитры CMYK.


Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая


Векторная графика: однородная заливка

Главная » однородная заливка

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Однородная заливка

Чтобы заполнить объект однородным цветом, выделите его и выберите нужный цвет в палитре, расположенной в правой части окна программы.

Заполнение контура сплошным цветом называется однородной заливкой. Цвета для такой заливки можно создавать с помощью цветовых моделей или выбирать из цветовых палитр.

Окно диалога "Однородная заливка" открывает доступ к различным цветовым моделям и палитрам. Именно из этих палитр выбираются цвета для заполнения объектов.

По умолчанию для заливки всех графических объектов принят режим "Без заливки", а для текстовых объектов - цвет Black. Эти значения являются рекомендуемыми. Если же они оказываются измененными, то для восстановления исходных значений надо выполнить следующие действия.

1. Убедитесь, что на рисунке отсутствуют выделенные объекты. Затем щелкните на кнопке "Удалить заливку" на панели инструментов "Заливка". Эта кнопка имеет значок в виде буквы Х.
2. На экране появится вспомогательное окно настройки с заголовком "Однородная заливка". Установите в нем флажок "Графика" и не устанавливайте остальные флажки.

3. Нажмите ОК.
4. Щелкните на кнопке "Однородная заливка" - самой левой кнопке на панели инструмента "Заливка".
5. Когда снова появится окно "Однородная заливка" сбросьте флажок "Графика" и установите флажки
"Художественный текст" и "Абзацный текст". 6. Нажмите ОК.
7. После этого появится окно диалога "Однородная заливка".
8. Выберите цветовую модель CMYK.
9. Для первых трех компонентов установите нулевые значения, а для K введите 100.
10. Нажмите ОК.


Векторная графика: использование пипетки

Главная » использование пипетки

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Использование пипетки

Пипетка позволяет скопировать атрибуты заливки и контура одного векторного объекта и применить их к другим объектам на странице. На раскрывающейся панели инструмента "Пипетка" также находится инструмент "Заполнитель", используемый для переноса атрибутов заливки или контура на другие объекты после того, как инструмент "Пипетка" был использован для получения атрибутов заливки или контура другого объекта.

Следует сказать, что инструмент "Пипетка" позволяет брать образцы цветов не только с векторных объектов, но и с растровых изображений.

Попрактикуемся:
1. Нарисуйте эллипс. Заполните его красным цветом.
2. Нарисуйте на странице прямоугольник. Заполните его желтым цветом.
3. Выберите инструмент "Пипетка".
4. Щелкните на заливке красного эллипса.
5. На панели инструмента "Пипетка" выберите инструмент "Заполнитель".
6. Щелкните на желтом прямоугольнике. Прямоугольник закрасится красным цветом.

Существует ускоренный способ копирования цвета с одного объекта и применения его к другому. Если после взятия образца щелкнуть на объекте инструментом "Пипетка" при нажатой клавише SHIFT, произойдет автоматическое переключение на инструмент "Заполнитель".


Векторная графика: градиентные заливки

Главная » градиентная заливка

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Градиентная заливка ч.1

Интерактивная заливка
Градиентная заливка
Линейная заливка
Имитация металлических поверхностей
Интерактивная заливка

Самым удобным средством для применения заливок к объектам является инструмент "Интерактивная заливка". На рисунке внизу изображена панель графики с выбранным инструментом "Интерактивная заливка".

Доступно всего пять типов заливок (слева направо):

Однородная заливка

Градиентная заливка

Заливка узором

Заливка текстурой

Заливки PostScript

В зависимости от выбранного типа заливки на панели атрибутов появляются элементы для выполнения различных действий, соответствующих выбранному типу. Рассмотрим все типы заливок, начиная слева-направо.

Однородная заливка была рассмотрена на предыдущем уроке.

Градиентная заливка

В градиентных заливках один цвет плавно переходит в другой. Вы можете управлять углом, под которым осуществляются цветовые переходы, а также видом возникающего узора. Существуют четыре типа градиентных заливок: линейные, радиальные, конические, квадратные. Любой из этих типов может быть создан с помощью инструмента "Интерактивная заливка".

Линейная заливка

Нарисуйте прямоугольник.

Выберите инструмент "Интерактивная заливка".

Щелкните и протащите курсор в пределах прямоугольника. По умолчанию будет создана линейная градиентная заливка.

Линейная градиентная заливка - это исходный тип заливки, применяемый по умолчанию. Обратите внимание на пунктирную линию со стрелкой, указывающую направление плавного перехода цветов заливки. На обоих концах пунктирной линии находятся маленькие квадратики, цвета которых соответствуют начальному и конечному цветам заливки. Эти квадратики можно перемещать с помощью инструмента интерактивной заливки, регулируя тем самым угол перехода цветов. В центре пунктирной линии расположен ползунок, управляющий положением средней точки перехода цветов. Перетаскивая его с помощью мыши, можно изменять положение средней точки цветового перехода. Так, по умолчанию переход осуществляется от черного цвета к белому. В середине перехода будет располагаться черный цвет 50% насыщенности. Перетащив ползунок вдоль пунктирной линии градиента, вы измените положение точки, в которой цвет имеет 50% насыщенность. Когда вы работаете не с черным и белым, а с другими цветами, точка середины линии градиента соответствует цвету, состоящему из равных долей граничных цветов. Ползунок на линии градиента появляется только в том случае, если в градиентной заливке участвует не более двух цветов.

Используя только что созданную заливку, щелкните на левом квадратике и перетащите его вверх и внутрь прямоугольника. Затем щелкните на правом квадратике и перетащите его вниз и внутрь прямоугольника. Теперь переход цветов осуществляется по диагонали от левого верхнего к правому нижнему углу прямоугольника.

Щелкните на образце синего цвета в стандартной палитре, расположенной у правой части окна программы, и, не отпуская кнопку мыши, перетащите образец цвета на левый верхний квадратик заливки и отпустите кнопку мыши.

Щелкните на образце желтого цвета и перетащите его на пунктирную линию. Проделайте то же самое с красным цветом.

Теперь удалите все дополнительные цвета, помещенные на линию заливки, щелкая на квадратиках цветовых образцов правой кнопкой мыши.

Имитация металлических поверхностей

Научившись создавать простейшие линейные градиентные заливки, давайте посмотрим, как воспользоваться ими для имитации металлической поверхности.

Введите нм странице слово "МЕТАЛЛ" и создайте контурное подобие текста, как показано на рисунке.

После контурной обводки текста выберите команду "Компоновать"-"Преобразовать эскиз в объект", чтобы отделить текст от только что созданной контурной фигуры. Выделите текст и сместите его вниз от контурной фигуры.

Выделите исходный текстовый объект. Выберите инструмент "Интерактивная заливка" и протащите курсор слева направо, чтобы создать горизонтальную линейную заливку. Начинайте перетаскивание в начале слова и завершите его в конце. Измените начальный и конечный цвета, перетащив на начальный и конечный квадратики 80% черный цвет из палитры. Добавьте дополнительные оттенки серого цвета, перетаскивая их из палитры и сбрасывая на пунктирную линию. Чередуйте 20% и 80% черный цвет.

Выберите инструмент "Выбор" и снова выделите текстовый объект с заливкой. Щелкните правой кнопкой мыши и перетаскивайте курсор до тех пор, пока он не окажется над верхним (контурным) объектом. Курсор примет вид кружка с перекрестием. Когда это произойдет, отпустите кнопку мыши. Из появившегося контекстного меню выберите пункт "Копировать заливку". Снова выберите инструмент "Интерактивная заливка". Щелкните на верхнем объекте - на нем появится пунктирная линия с квадратиками. Переместите левый крайний квадратик в середину верхнего края объекта, а правый - в середину нижнего.

Совместите оба объекта.

На следующем занятии познакомимся с созданием радиальных, конических и квадратных заливок.


Векторная графика: градиентные заливки

Главная » градиентная заливка

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Градиентная заливка ч.2

Радиальная заливка
Коническая заливка
Квадратная заливка
Радиальные заливки

Нарисуйте на странице круг с помощью инструмента "Эллипс".

Щелкните на кнопке инструмента "Интерактивная заливка", а затем щелкните кнопкой мыши в пределах круга и протащите курсор. Круг заполнится линейной градиентной заливкой с плавным изменением цвета слева направо.

При выбранном инструменте интерактивной заливки щелкните на кнопке "Радиальная заливка" панели атрибутов.

Круг должен стать похожим на приведенный ниже рисунок.

Обратите внимание на то, что, поскольку в построении заливки участвуют только два цвета, на линии градиента присутствует ползунок смещения средней точки.

Щелкните на пунктирной линии интерактивной заливки и перетащите ее в левую верхнюю четверть круга. Щелкнуть нужно именно на линии, поскольку мы должны сохранить взаимное расположение начальной и конечной точек градиента. Перетащите ползунок немного ближе к белому квадратику, чтобы нижняя часть круга стала более темной. Щелкните на правом квадратике черного цвета и перетащите его в нижнюю правую четверть круга.

При выбранном инструменте интерактивной заливки щелкните на образце синего цвета в палитре у правого края экрана и перетащите его на страницу рисунка, поместив поверх пунктирной линии интерактивной заливки. Ваш круг должен теперь выглядеть как шар.

Коническая заливка

Нарисуйте на странице круг с помощью инструмента "Эллипс".

Щелкните на кнопке инструмента "Интерактивная заливка", а затем щелкните кнопкой мыши в пределах круга и протащите курсор. Круг заполнится черно-белой линейной градиентной заливкой. При выбранном инструменте интерактивной заливки щелкните на кнопке "Коническая заливка" панели атрибутов.

Щелкните на вершине конуса (центральный квадратик) и перетащите его в верхнюю часть круга. Перетащите ползунок смещения средней точки до середины вправо. Обратите внимание: более светлые цвета сконцентрировались в правой части, придав конусу более правдоподобный вид.

Теперь, используя уже полученные знания, постройте следующий рисунок.

Квадратные заливки

Последней разновидностью градиентных заливок являются квадратные заливки.

Щелкните на кнопке инструмента "Прямоугольник" панели графики и нарисуйте квадрат. Поверните квадрат на 45 градусов.

Выберите инструмент "Интерактивная заливка", щелкните кнопкой мыши в пределах контура квадрата и протащите курсор. Как и в предыдущих упражнениях, квадрат заполнится линейной градиентной заливкой. При выбранном инструменте интерактивной заливки щелкните на кнопке "Квадратная заливка" панели атрибутов.

Теперь, используя уже полученные знания, постройте следующий рисунок.

Следует сказать, квадратные заливки применяются довольно редко, одно из возможных применений показано ниже.

Квадрат был продублирован несколько раз и копии размещены рядом друг с другом. Такой узор может пригодиться при создании плиток мозаичного узора.


Векторная графика: узорная заливка

Главная » узорная заливка

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Узорные заливки

С помощью панели атрибутов можно применить узорные заливки трех типов: двухцветные, многоцветные и растровые. Узорные заливки применяются для создания мозаичных фонов или для повышения реализма. Стандартные заливки состоят из относительно небольших квадратных плиток, которые складываются в правильную мозаику без искажений. Изменяя размеры и поворачивая эти плитки в интерактивном режиме, можно создавать совершенно новые изображения, значительно отличающиеся от исходных.

Двухцветная узорная заливка

Нарисуйте на странице прямоугольник.

Выделите нарисованный объект и щелкните на кнопке инструмента "Интерактивная заливка" панели графики. Выберите в списке "Тип заливки" на панели атрибутов строку "Узорная заливка". Щелкните на кнопке "2 цветный". Щелкните на кнопке со стрелкой, направленной вниз, раскрывающегося списка "Выбор начальной заливки" и выберите узор в виде кирпичной кладки. Выберите в качестве основного цвета белый цвет, в качестве фона - красный.

Теперь прямоугольник принял следующий вид.

На изображении присутствуют четыре маркера модификации:
- верхний левый маркер - вертикальное растяжение и наклон;
- верхний правый маркер - горизонтальное растяжение и наклон;
- нижний правый маркер - поворот;
- нижний левый маркер - перемещение.

Попрактикуйтесь в перемещении маркеров рамки, чтобы прочувствовать возможности интерактивного изменения узора заливки.

Заливка объектов многоцветным узором производится точно так же, как и заливка двухцветным узором - с использованием инструмента "Интерактивная заливка", но за одним исключением. В этом случае отсутствуют кнопки "Основной цвет" и "Фоновый цвет", поскольку многоцветные узоры - это векторные изображения, в состав которых входит более двух цветов.

Заливка объектов точечным узором производится так же, как и заливка многоцветным узором.


Векторная графика: текстурная заливка

Главная » текстурная заливка

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Текстурные заливки

Текстурные заливки представляют собой особый вид растровых изображений, называемых фрактальными изображениями. В комплект программы входит более 100 образцов текстур, и каждый из них еще может быть модифицирован так, что приобретет совершенно отличный от исходного вид. Каждый образец текстуры может иметь миллионы разновидностей.

Нарисуйте прямоугольник. Выберите инструмент "Интерактивная заливка" и щелкните на кнопке раскрытия списка "Тип заливки" на панели атрибутов. Выберите в списке строку "Текстурная заливка". Прямоугольник заполнится текстурной заливкой.

Щелкните на панели атрибутов на кнопке со стрелкой, направленной вниз, чтобы раскрыть список библиотек текстурных узоров.

Щелкните на кнопке "Другие", чтобы вызвать окно диалога "Текстурная заливка".

В левом верхнем углу окна диалога находится раскрывающийся список "Библиотека текстур". Библиотека "Стили" содержит оригиналы образцов различных текстур, а библиотека "Образцы" - варианты этих оригиналов.

Окно диалога содержит множество элементов управления с разнообразными параметрами текстур, с помощью которых можно изменять свойства выбранной текстуры. Среди них есть один общий для всех текстур параметр - Номер текстуры, который обозначает идентификационный номер текстуры. В счетчике этого параметра можно указать любое число от 1 до 32767. Смена номера ведет к небольшому изменению картины текстуры. Чтобы увидеть результат внесенных изменений, следует щелкнуть на кнопке "Просмотр".

Обратите внимание на кнопки блокировки с изображением маленьких замочков справа от полей каждого из параметров. По умолчанию заблокированы все параметры, кроме номера текстуры. В результате щелчок на кнопке "Просмотр" под окном предварительного просмотра текстур ведет к изменению номера текстуры случайным образом, оставляя значения других параметров постоянными. Это очень удобно, когда нужно просмотреть варианты внешнего вида одного и того же образца текстуры вручную. Просто щелкайте раз за разом на кнопке предварительного просмотра, и номер будет автоматически меняться. Если щелкнуть на кнопке блокировки любого из параметров, он будет разблокирован. После этого каждый щелчок на кнопке предварительного просмотра будет вести к случайному изменению разблокированных параметров наряду с номером текстуры. Противоположным вариантом является фиксация номера текстуры и разблокирование всех остальных параметров. При этом идентификационный номер текстуры останется постоянным, но зато будут случайным образом меняться все остальные параметры.


Векторная графика: Заливки PostScript

Главная » Заливки PostScript

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Заливки PostScript

Это разновидность узорных заливок, в которых используется язык определения страниц PostScript. Другими словами, это векторные заливки, заполняющие объект без искажений и "швов".

Нарисуйте прямоугольник. Выберите инструмент "Интерактивная заливка" и щелкните на кнопке раскрытия списка "Тип заливки" панели атрибутов. Выберите в списке строку "Заливка PostScript". Прямоугольник заполнится установленной по умолчанию заливкой PostScript. Щелкните на кнопке со стрелкой рядом с раскрывающимся списком "Текстуры заливок PostScript" и выберите из списка нужную вам заливку.

Щелчок на кнопке "Изменить" панели атрибутов вызывает окно диалога "Текстура PostScript".

Прокрутите список, чтобы быстро просмотреть перечень всех заливок. Если вы хотите посмотреть, как выглядит та или иная заливка, установите флажок "Просмотр" в окне диалога. Кроме того, в окне диалога имеется набор параметров, с которыми можно поэкспериментировать для изменения вида заливок PostScript. Используйте кнопку "Обновить" под окном предварительного просмотра, чтобы увидеть результаты любых изменений в полях параметров.


Векторная графика: сетчатая заливка

Главная » сетчатая заливка

Стартовое окно

Щелкните чтобы открыть/закрыть подменю Рисование примитивов

прямоугольники

эллипсы

многоугольники

спирали

Щелкните чтобы открыть/закрыть подменю Рисование линий

инструмент "Кривая"

"Кривая Безье"

"Живопись"

"Размер"

Щелкните чтобы открыть/закрыть подменю Текст

фигурный текст

простой текст

Щелкните чтобы открыть/закрыть подменю Работа с объектами

выделение

операции с объектами

изменение размеров

произвольные преобразования

Щелкните чтобы открыть/закрыть подменю Форма объектов

инструмент "Форма"

пять типов узлов

редактирование узлов ч.1

редактирование узлов ч.2

разрезание и стирание

Щелкните чтобы открыть/закрыть подменю Цвет

цветовые модели

цветовые палитры

выбор палитры

Щелкните чтобы открыть/закрыть подменю Заливки

однородная

пипетка

градиентная ч.1

градиентная ч.2

узорная

текстурная

PostScript

сетчатая

«предыдущая | СorelDraw | следующая»

Интерактивная сетчатая заливка

Этот уникальный инструмент позволяет в интерактивном режиме заполнять объекты цветами, переходящими друг в друга. Инструмент расположен на панели инструмента "Интерактивная заливка" панели графики.

При выделении объекта инструментом "Интерактивная заливка" создается сетка, состоящая из трех горизонтальных и трех вертикальных линий. Сетка отображается в виде пунктирных красных линий.

Нарисуйте окружность. Не снимая выделения с окружности, выберите инструмент "Сетчатая заливка". Щелкните в палитре на синем цвете, перетащите его на страницу и сбросьте в среднюю нижнюю ячейку сетки. Тем самым начинаем создавать иллюзию тени на шаре.

Продолжайте перетаскивать синий цвет и сбрасывать его либо на отдельных ячейках, либо на узлах сетки. Перетащите белый цвет с палитры на левый верхний узел сетки, чтобы создать блик на шаре.

Поэкспериментируйте с этим удивительным инструментом, и вы поймете каких удивительных вещей можно добиваться, используя сетчатую заливку.