Уроки по Adobe Photoshop CS

Написать автору Уроки по Adobe Photoshop

Тема 1. Кодирование рисунков
  1. Цифровые изображения
  2. Растровое и векторное кодирование
  3. Модели цвета
Тема 2. Знакомство с Adobe Photoshop
  1. Введение
  2. Начало работы
  3. Свойства изображения
  4. Обозреватель файлов
Тема 3. Ввод изображений
  1. Сканирование
  2. Цифровые фотоаппараты
  3. Кадрирование
  4. Предварительная обработка
Тема 4. Коррекция изображений
  1. Гистограмма и уровни
  2. Контраст и яркость
  3. Кривые
  4. Свет и тени
  5. Коррекция отдельных участков
  6. Коррекция цвета
Тема 5. Ретушь фотографий
  1. Введение
  2. Отмена действий
  3. Увеличение резкости
  4. Пятна, царапины и трещины
  5. Красные глаза
Тема 6. Выделение областей
  1. Введение
  2. Простейшие приемы выделения
  3. Лассо
  4. Волшебная палочка
  5. Что можно делать с выделенной областью?
Тема 7. Инструменты рисования
  1. Выбор цвета
  2. Карандаш и Кисть
  3. Ластик
  4. Заливка
  5. Другие инструменты
  6. Создание рисунка
  7. Раскрашивание черно-белых фотографий
Тема 8. Многослойные документы
  1. Введение
  2. Палитра Слои
  3. Практическая работа
  4. Копирование слоев
  5. Работа с буфером обмена
  6. Корректирующие слои
Тема 9. Текст
  1. Ввод текста
  2. Параметры
  3. Изменение формы текста
  4. Эффекты
Тема 10. Маски и каналы
  1. Введение
  2. Быстрая маска
  3. Редактирование маски
  4. Использование каналов
  5. Маски слоя
Тема 11. Фильтры
  1. Введение
  2. Коррекция изображений
  3. Художественные фильтры
  4. Специальные фильтры
Тема 12. Иллюстрации для Интернета
  1. Введение
  2. Рисунки с палитрой (GIF, PNG)
  3. Рисунки JPEG
  4. Изображения с прозрачными областями
  5. Изображения из фрагментов
Тема 13. Анимация в Image Ready
  1. Введение
  2. Анимация по слоям
  3. Ручная настройка кадров
  4. Промежуточные кадры
  5. Реакция на события мыши
Тема 14. Векторная графика в Photoshop
  1. Введение
  2. Инструмент Перо
  3. Редактирование контуров
  4. Выделение объекта на фоне
  5. Текст вдоль контура
  6. Обтравочный контур
  7. Фигуры

Условные обозначения

В такую рамку заключаются практические задания, которые надо выполнять на компьютере.

Этим знаком обозначаются важные практические приемы, которые осваиваются как бы между прочим, в ходе выполнения практической работы по другой теме.

© 2005 К. Поляков


Уроки по Adobe Photoshop CS: кодирование рисунков

Тема 1. Кодирование рисунков

  1. Цифровые изображения
  2. Растровое и векторное кодирование
  3. Модели цвета

1. Цифровые изображения

Цифровое изображение — это модель реального изображения, закодированная в виде последовательности чисел.

На рисунке изображен жизненный цикл цифрового изображения.

При вводе изображения со сканера оно преобразуется в цифровую форму — оцифровывается. Цифровой фотоаппарат хранит отснятые кадры не на фотопленке, а на карте памяти сразу в цифровом виде. Он передает уже оцифрованные изображения в компьютер по специальному кабелю. Фрейм-граббер — это устройство для захвата отдельных кадров телевизионной передачи.

Конечная цель цифровой обработки изображений — это его вывод на монитор или печатающее устройство. Как мы увидим дальше, каждое устройство вывода предъявляет свои требования к изображению, поэтому для правильной обработки надо знать, где мы будем его просматривать.

к началу К началу страницы

2. Растровое и векторное кодирование

Для того, чтобы обрабатывать рисунок с помощью компьютера, необходимо закодировать его в таком формате, который компьютер может понять, то есть, в виде последовательности нулей и единиц. Например, можно представить графическую информацию в виде чисел, а затем записать эти числа в двоичной системе счисления.

Существуют два метода кодирования рисунков — растровое и векторное кодирование. Нельзя сказать, какое из них лучше — все определяется типом изображения.

Растровое кодирование

При растровом кодировании рисунок разбивается на одинаковые элементы — пиксели (от слова pixel — picture element, элемент рисунка). Чаще всего пиксели имеют квадратную форму. Для каждого пикселя в памяти хранится его цвет. Такой способ применяется при хранении фотографий и других размытых изображений, в которых нет четких границ правильной формы.

Поскольку мы считаем, что каждый пиксель ровно залит одним цветом, при растровом кодировании есть потеря информации

Чем мельче пикселы, тем точнее мы сможем закодировать рисунок, тем меньше будут искажения при его печати через компьютер. С другой стороны, увеличивая число пикселей, мы увеличиваем и объем файла на диске.

Достоинства:

  • можно кодировать любые изображения;
  • лучше всего подходит для кодирования и обработки фотографий.

Недостатки:

  • есть потеря информации
  • при увеличении или уменьшении рисунки искажаются
  • рисунки занимают много места в памяти

Важнейшая характеристика рисунка — разрешение, то есть, число пикселей на одном дюйме изображения (по ширине или высоте). В документации используется обозначение ppi — pixels per inch (пикселей на дюйм). Чем больше разрешение, тем больше места занимает рисунок в памяти и тем лучше его качество.

Пусть рисунок имеет размер 5 см на 3 см. Тогда при разрешении 300 ppi он должен иметь ширину

W = 5 × 300 / 2,54 = 590 пикселей

и высоту

H = 3 × 300 / 2,54 = 354 пикселя

Здесь учтено, что 1 дюйм равен 2,54 см.

Для того, чтобы определить нужное разрешение, надо решить, как — с помощью какого устройства — мы будем смотреть этот рисунок. Каждое устройство вывода графической информации имеет свое разрешение, которое обычно измеряется в точках на дюйм и обозначается dpi — dots per inch (точек на дюйм).

Если рисунок предназначен только для просмотра на экране компьютера, достаточно использовать разрешение 72-100 ppi, потому что стандартное разрешение монитора — 96 dpi, лучшего качества получить невозможно. Эти рисунки имеют одинаковый размер, но различное разрешение:

Для печати на принтере или в типографии требуется более высокое разрешение. Cовременные струйные и лазерные принтеры печатают с разрешением от 300 до 1200 dpi, а фотонаборные аппараты в типографии — до 2400 dpi.

Векторное кодирование

При векторном кодировании весь рисунок представлен как набор геометрических фигур — отрезков, прямоугольников, кривых линий, окружностей, дуг и т.п. Для каждой из них задаются координаты на рисунке, размеры, цвет и стиль контура и заливки. Поэтому при изменении размеров такой рисунок не искажается, а просто увеличивается или уменьшается. Векторное кодирование применяют для хранения схем, чертежей, карт, планов.

Достоинства:

  • нет потери информации
  • при увеличении или уменьшении рисунки не искажаются
  • рисунки занимают немного места в памяти

Недостатки:

  • очень сложно (и не нужно) кодировать так изображения без четких границ объектов
  • не подходит для кодирования и обработки фотографий.

к началу К началу страницы

3. Модели цвета

Восприятие цвета человеком субъективно. Практически невозможно пересказать другому свое ощущение цвета — это надо видеть. Однако в полиграфии требуются объективные способы описания и обработки цвета.

Сложность состоит в том, что не все цвета, которые воспринимает человеческий глаз, могут быть показаны на мониторе. Кроме того, не все цвета, которые можно показать на мониторе, могут быть напечатаны на бумаге. На рисунке (автор — Alexander Sperl) схематично показаны эти области в цветовой палитре.

Поэтому для кодирования цвета используют несколько разных способов (моделей), причем выбор модели зависит от того, будем мы смотреть рисунок на мониторе компьютера или собираемся его печатать.

Модель RGB

Существуют приборы, устройства и живые существа, которые излучают свет — мониторы, киноаппараты, телевизоры, светлячки. Основными цветами считаются красный (R — red), зеленый (G — green) и синий (B — blue).

цвет = R (красный) + G (зеленый) + B (синий)

При смешении двух основных цветов результат становится светлее: красный и зеленый дают желтый, зеленый и синий — голубой, синий и красный — пурпурный. Если смешать все три цвета максимальной яркости, получается белый. Такие цвета называют аддитивными, то есть для получения нужного цвета они складываются.

Пиксел на экране монитора строится как сочетание трех маленьких лучей основных цветов. Поэтому для работы с изображением, которое будет выводиться только на экран монитора, используют модель RGB.

Модель CMYK

При печати получается изображение, которое не излучает свет, а наоборот, отражает какие-то лучи, то есть преобразуют белый свет, "вычитая" из него определенные цвета. Эти цвета называются субтрактивными (дословно — "вычитательными"). Их тоже три, они получаются после вычитания из белого основных цветов. При вычитании красного получается голубой (C — cyan), при вычитании зеленого — пурпурный (M — magenta), а при вычитании синего — желтый (Y — yellow).

Таким образом, нулевые значения цветов в такой модели должны давать белый цвет, а максимальные — черный. Однако реальные краски, которые используются при печати, далеко не идеальны, и смешение трех красок не дают чистый черный цвет (получается нечто грязно-коричневое). Поэтому в эту цветовую модель добавили еще и черный цвет (K — black).

цвет = C (голубой) + M (пурпурный) + Y (желтый) + K (черный)

Модель HSB

Если объединить модели RGB и CMYK, получится цветовой круг, в котором каждый цвет расположен напротив дополняющего его ("комплементарного") цвета и, при этом, между цветами, из которых он получен. Чтобы усилить какой-то цвет, достаточно ослабить дополняющий его цвет.

Положение цвета в цветовом круге характеризуется цветовым тоном или оттенком (H — hue), от 0 до 360 градусов.

Второй параметр — насыщенность (S — saturation) — определяет чистоту цвета от 0% (серый цвет) до 100% (насыщенный цвет). С уменьшением насыщенности цвет становится блеклым, размытым (это равносильно добавлению в цвет белой краски).

Третий параметр — яркость (B — brightness) — определяет освещенность или количество света. Уменьшение яркости цвета означает его зачернение (то есть добавление в цвет черной краски). При нулевой яркости (0%) мы не можем видеть никаких цветов, поэтому любой цвет вопринимается как черный. Абсолютную яркость (100%) имеет только белый цвет.

В общем случае, любой цвет можно представить как цветовой тон, смешанный с белой и черной (то есть с серой) краской в разных пропорциях.

Такая модель получила название HSB. Эта модель неплохо отражает восприятие цвета человеком — оттенок связан с длиной волны, насыщенность — с интенсивностью, а яркость — с количеством света. Тем не менее, при выводе на экран монитора надо преобразовать цвет в модель RGB, а при печати — в модель CMYK.

цвет = H (оттенок) + S (насыщенность) + B (яркость)

Модель Lab

Цветовая модель L*a*b была создана Международной комиссией по освещению (CIE) как универсальная и не зависящая от конкретного устройства (монитора, принтера). В ней любой цвет определяется светлотой L (от 0 до 100) и двумя цветовыми параметрами a и b, каждый из которых меняется в интервале от -128 до 127. Эта модель используется как промежуточная ступень при преобразовании цвета из одной модели в другую. Она позволяет закодировать такие цвета, которые невозможно ни отобразить на экране, ни напечатать.

цвет = L (светлота) + a + b

Оглавление В начало Вперед Знакомство с Photoshop


Уроки по Adobe Photoshop CS: знакомство с Photoshop

Тема 2. Знакомство с Adobe Photoshop

  1. Введение
  2. Начало работы
  3. Свойства изображения
  4. Обозреватель файлов

1. Введение

Что это такое?

Adobe Photoshop фирмы Adobe — это самая известная программа для обработки изображений на компьютере. Как следует из названия, она предназначена главным образом для редактирования фотографий, полученных со сканера или цифрового фотоаппарата. Кроме того, она позволяет также и создавать реалистичные рисунки "с нуля", но эти возможности — второстепенные.

Существует множество версий программы Photoshop. Самая последняя — Photoshop CS (Creative Suite — набор для творчества), которую мы и будем изучать. К сожалению, не существует официальной русской версии программы, а существующие переводы иногда искажают смысл команд и пунктов меню до неузнаваемости. Поэтому специалисты рекомендуют использовать только английскую версию.

Форматы файлов

Программа Photoshop умеет читать и сохранять изображения практически во всех широко известных компьютерных форматах: BMP, GIF, JPEG, PNG, TIFF и многих других. Однако ее "родной" формат — PSD, только в этом формате можно полностью сохранить все специальные эффекты, примененные к рисунку. Поэтому чаще всего изображения при обработке хранят в формате PSD, а окончательные версии преобразуют в нужный формат.

к началу К началу страницы

2. Начало работы

Запуск

Для запуска программы используется стандартный способ: Пуск — Программы — Adobe Photoshop CS.

Работа с файлами

Photoshop поддерживает все стандартные операции с файлами, которые можно найти в меню Файл:

Новый | Ctrl+N | Создать новый файл
Открыть | Ctrl+O | Загрузить файл с диска
Сохранить | Ctrl+S | Сохранить файл на диске
Сохранить как... | Shift+Ctrl+S | Сохранить файл с другим именем, в другом формате или с другом месте
Закрыть | Ctrl+W | Закрыть файл

Команда Файл — Открыть последний позволяет быстро открыть один из последних рабочих файлов.

Используя команду Файл — Открыть, загрузите файл PRACTICE/2/bird.psd.

Рабочая область

Photoshop позволяет одновременно работать с несколькими файлами, для каждого из них открывается внутренннее окно. Его можно свернуть, оставить в среднем состоянии или развернуть на всю рабочую область.

Размеры файла для выбранного рисунка можно увидеть в строке состояний внизу. Они измеряются в килобайтах (К) или мегабайтах (М). Первое число обозначает размер готового изображения, второе — размер файла с информацией о слоях. Для файлов в формате PSD, содержащих несколько слоев, второе число больше первого. Если числа равны, изображение состоит из одного слоя.

Определите размеры файла для загруженного рисунка.

Инструменты для работы выбираются из палитры инструментов, свойства выбранного инструмента изменяются на панели, расположенной сразу под верхним меню.

При работе часто используются дополнительные окна. На рисунке открыто окно Слои. Клавиша F7 (или меню Окно — Слои) позволяет открывать и закрывать это окно.

Определите, сколько слоев содержит рисунок.

к началу К началу страницы

3. Свойства изображения

Цветовой режим

Для того, чтобы определить цветовой режим загруженного изображения, надо выбрать пункт меню Изображение — Режим и посмотреть, какой пункт верхнего списка отмечен галочкой. Photoshop поддерживает несколько режимов

  • Битовый формат (Bitmap) — двуцветное черно-белое изображение
  • Градации серого (Grayscale) — изображение в 256 оттенках серого
  • Дуплекс (Duotone) — изображение, в котором смешиваются два цвета (плюс белый)
  • Индексированные цвета (Indexed) — изображение с палитрой (от 2 до 256 цветов)
  • RGB — полноцветное изображение, цвет в формате RGB
  • CMYK — полноцветное изображение, цвет в формате CMYK
  • Lab — полноцветное изображение, цвет в формате Lab
Это же меню можно использовать для преобразования из одного формата в другой. Однако при этом часть информации может быть потеряна. Например, при преобразовании цветного рисунка в черно-белый теряется информация о цвете. Если же переводить полноцветное изображение в индексированный режим, цвета пикселей будут искажены, так как палитра может содержать от 2 до 256 цветов.

Определите цветовой режим для загруженного изображения.

Масштаб

Часто требуется увеличить часть изображения, например, для того, чтобы точнее выделить какой-то объект. Кроме того, Photoshop позволяет редактировать и большие рисунки, которые не помещаются на экране — их надо уменьшать, для того, чтобы просмотреть полность. В обоих случаях надо установить правильный масштаб — увеличение. Масштаб 100% обозначает, что 1 пиксель рисунка соответствует 1 пикселю на экране. Если масштаб меньше 100% — рисунок уменьшается, если больше — увеличивается (до 1600%).

Когда программа загружает файл, масштаб выбирается автоматически так, чтобы весь рисунок поместился на экране. Масштаб указываться в заголовке окна изображения и в левом нижнем углу в строке состояния.

Существует несколько способов изменения масштаба:

  • Ввести с клавиатуры нужный масштаб в строке состояния.
  • Использовать сочетания клавиш и соответствующие пункты меню Вид:
    Ctrl++ | Увеличить масштаб.
    Ctrl+— | Уменьшить масштаб.
    Ctrl+0 | Показать во весь экран.
    Alt+Ctrl+0 | Масштаб 100%.
    Сочетания Alt+Ctrl++ и Alt+Ctrl+— позволяют не только увеличивать и уменьшать размеры рисунка, но и "подгонять" под них размеры окна.
  • Включить инструмент Увеличение [image] на панели инструментов (Zoom, включается при нажатии клавиши Z). После щелчка по рисунку он увеличивается, при нажатой клавише Alt — уменьшается. Этим инструментом можно также обвести на рисунке прямоугольник, который надо увеличить. Если отметить флажок Изменить размеры окна до подходящих на панели свойств инструмента, будет меняться не только масштаб, но и размеры окна.

Если рисунок не помещается в окно, для сдвига видимой области можно использовать линейки прокрутки или инструмент Рука [image] (Hand, включается при нажатии клавиши H), который позволяет "схватить" и перетащить рисунок в окне. Инструмент Рука можно временно включать, не выключая активный инструмент — для этого надо удерживать клавишу пробел.

Удобно также использовать окно навигатора (Окно — Навигатор). В нем выводится уменьшенное изображение, красная рамка (ее можно перетаскивать мышкой) показывает видимую часть. Движок внизу служит для изменения масштаба.

Проверьте все описанные приемы изменения масштаба на загруженном файле.

Размеры и разрешение

Чтобы определить размеры рисунка, надо вызвать окно Изображение — Размер изображения. Оно показывает размеры в пикселях и в сантиметрах, а также разрешение рисунка.

Определите размеры загруженного рисунка в сантиметрах и его разрешение.

Для того, чтобы узнать размеры рисунка при печати, надо щелкнуть в той части строки состояния, где показаны размеры файла.

Посмотрите, какое место будет занимать рисунок при печати..

Можно изменить разрешение рисунка двумя способами:

  1. Сохранить размер в пикселях, изменяя размер в сантиметрах (при этом рисунок не искажается, потерь информации нет).
  2. Сохранить размер в сантиметрах, изменяя размер в пикселях (при этом рисунок искажается, поскольку при увеличении разрешения добавляются новые пиксели, а при уменьшении некоторые пиксели удаляются).

Откройте окно Изображение — Размер изображения. Снимите флажок Интерполяция (это означает, что размеры в пикселях не меняются) и установите разрешение 300 точек на дюйм. Посмотрите, как будет теперь выглядеть рисунок при печати. Затем отмените эту операцию, нажав на Ctrl+Z.

Откройте окно Изображение — Размер изображения. Повторите те же операции с установленным флажком Интерполяция (это означает, что размеры в сантиметрах не меняются). Почему изображение стало размытым?

к началу К началу страницы

4. Обозреватель файлов

В Photoshop есть очень удобный встроенный обозреватель файлов, похожий на Проводник Windows. Чтобы его вызвать, надо выбрать пункт меню Файл — Пролистать... (комбинация клавиш Alt+Ctrl+O) или щелкнуть по кнопке [image] в правой части панели свойств инструментов.

В левой части окна расположены дерево папок, область просмотра и область свойств выделенного файла, в правой части — файлы в выбранной папке, для рисунков показаны их уменьшенные изображения (иконки).

Двойной щелчок на файле позволяет быстро открыть его в Photoshop. Кроме того, в обозревателе можно повернуть рисунок на 90 или 180 градусов, переименовать и удалить его. Для этого используется контекстное меню (оно появляется при щелчке правой кнопкой мыши на файле), команды верхнего меню или кнопки [image] (повернуть на 90 градусов влево), [image] (повернуть на 90 градусов вправо) и [image] (удалить файл).

Откройте окно обозревателя и перейдите в папку PRACTICE/2. Определите размеры и разрешение для файла fish.jpg и откройте его в Photoshop.

Преобразуйте изображение к черно-белому (полутоновому) режиму, выбрав команду Изображение — Режим — Градации серого. Cохраните результат в формате PSD (Файл — Сохранить как...).

 |  | Оглавление |
Кодирование рисунков | Назад | В начало | Вперед | Ввод изображений


Уроки по Adobe Photoshop CS: ввод изображений

Тема 3. Ввод изображений

  1. Сканирование
  2. Цифровые фотоаппараты
  3. Кадрирование
  4. Предварительная обработка

1. Сканирование

Что это такое?

Сканированием называют кодирование изображения в компьютерном формате с помощью специального устройства ввода — сканера. Иногда используют выражение оцифровка рисунка, то есть, перевод в цифровую форму.

При сканировании рисунок разбивается на пиксели в соответствии с установленным разрешением, для каждого пикселя определяется его цвет, раскладывается на составляющие R (красный), G (зеленый) и B (синий), и записывается в память компьютера.

Для сканирования надо использовать специальную программу, которая поставляется со сканером. Она позволяет определить область рисунка (прямоугольник) и режимы (параметры) сканирования. Среди параметров наиболее важны два — тип изображения и разрешение сканирования.

Типы изображений

Сканеры позволяют вводить изображения трех типов
  1. черно-белые рисунки (Line Art), содержащие только два цвета, например, страницы книги
  2. рисунки в оттенках серого цвета (Grayscale, от белого до черного)
  3. цветные рисунки (Color)

Конечно, можно вводить все изображения как цветные, но при этом увеличивается объем получаемого файла:

  1. черно-белые рисунки — 1 бит на пиксель (2 цвета)
  2. рисунки в оттенках серого цвета — 8 бит на пиксель (256 оттенков серого)
  3. цветные рисунки — 24 бита на пиксель (модель RGB: по 8 бит на канал, всего 16777216 цветов)
Таким образом, цветной рисунок того же размера занимает (при том же разрешении) в 24 больше места в памяти, чем черно-белый.

Если изображение надо будет потом обрабатывать (например, ретушировать фотографию), рекомендуют всегда вводить его как цветное, а затем переводить в нужный формат окончательный вариант. Это позволяет улучшить качество рисунка.

Разрешение

Качество изображения и размер файла напрямую определяются установленным разрешением сканирования. Нужное разрешение зависит от цели сканирования. Если изображение предназначено для последующей обработки, рекомендуется сканировать его с наибольшим возможным разрешением и обрабатывать в этом режиме, а затем окончательный вариант сохранять с нужным разрешением. Можно привести некоторые рекомендации по выбору разрешения сканирования:
  1. для текста с математическими формулами — не менее 200 ppi
  2. для текста, предназначенного для распознавания с помощью специальных программ — не менее 300 ppi
  3. для рисунков — 300—600 ppi

Предельное разрешение сканера определяется его техническими характеристиками. Обычно сканеры имеют различное разрешение по длине и ширине. Для современных моделей разрешение меняется от 1200 ppi до 4800 ppi.

к началу К началу страницы

2. Цифровые фотоаппараты

Что это такое?

Цифровые аппараты сразу записывают изображение в цифровой форме — в виде точечного рисунка. В отличие от обычных фотоаппаратов, свет падает не на фотопленку, а на электронную матрицу, состоящую из отдельных элементов. Каждый элемент преобразует попавший на него свет в формат RGB, информация со всех элементов составляет растровый рисунок. Цифровые фотографии могут храниться в так называемом "сыром" формате (RAW), то есть, хранится точно та информация, которая поступила с датчиков матрицы. Но чаще всего используют форматы JPEG или TIFF — в них используется сжатие изображения и файлы занимают значительно меньше места на флэш-карте. Photoshop умеет обрабатывать файлы во всех этих форматах, включая RAW.

Для передачи отснятых изображений на компьютер надо подключить его с помощью специального кабеля к порту USB. После этого в Проводнике Windows можно обращаться к карте памяти фотоаппарата как к обычному диску: копировать и удалять файлы.

Разрешение

При съемке желательно использовать наибольшее разрешение, при котором может работать аппарат. Это позволит получать более качественные изображения и облегчит их обработку в Photoshop.

Для экономии места на карте памяти часто при съемке уменьшают разрешение, но это может значительно ухудшить качество рисунка, особенно после обработки.

к началу К началу страницы

3. Кадрирование

Что это такое?

Кадрирование — это "обрезка" рисунка. Слово кадрирование пришло из фотографии, где оно применяется для компоновки кадра.

Кадрирование необходимо в двух случаях:

  • при сканировании часто захватывается не только сам рисунок, но и посторонние элементы, которые надо удалить (например, неровные края фотографии)
  • художественное кадрирование состоит в том, чтобы обрезать изображение для увеличения выразительности и для того, чтобы подчеркнуть основную мысль фотохудожника

Инструмент "Рамка"

Для обрезки рисунка используют инструмент Рамка [image] на панели инструментов (Crop, включается при нажатии клавиши C). Надо выделить прямоугольник, ограничивающий нужный кадр. Все, что не попало в область выделения (и не войдет в кадр), затеняется.

Размеры прямоугольника можно менять, используя маркеры в углах и на сторонах. Если вывести указатель мыши за границы выделенной области, можно вращать прямоугольник выделения. Это нужно, если края фотографии не параллельны краям области сканирования.

При нажатии на клавишу Enter рисунок будет обрезан по границе прямоугольника, для отмены надо нажать Esc.

Откройте окно обозревателя и перейдите в папку PRACTICE/3. Загрузите файл cat.png. Используя кадрирование, обрежьте изображение, как показано на рисунке. Полученный файл сохраните с расширением PSD.

Автоматическое кадрирование

В современных версиях программы Photoshop существует удобное средство автоматического кадрирования. Программа умеет распознавать границы фотографий и вырезать их из файла, полученного со сканера. Важно, что эта команда работает даже в том случае, если было отсканировано сразу несколько изображений — при этом создается несколько новых изображений.

Для использования автоматического кадрирования надо загрузить нужный файл и выбрать пункт меню Файл — Автоматизация — Кадрировать и выпрямить фотографию.

Загрузите файл multicrop.jpg из папки PRACTICE/3 и примените автоматическое кадрирование. Сохраните полученные рисунки в формате PSD с разными именами.

В нижней части меню Окно находится список все открытых документов. Его удобно использовать, когда нужное изображение оказалось закрыто другим.

Перейдите в окно рисунка с изображением дома. Включите флажок Просмотр — Показать цвета вне CMYK.

Теперь все цвета, которые на входят в диапазое цветовой модели CMYK, выделены серым цветом. Их невозможно точно напечатать, хотя можно показать на мониторе.

к началу К началу страницы

4. Предварительная обработка

Преобразование формата

Файлы, полученные со сканера, сохраняются на диске в одном из растровых форматов, чащен всего в форматах BMP, JPG или PNG. Для обработки в Photoshop рекомендуется сразу перевести их в его "родной" формат PSD, в котором поддерживаются все возможности программы, в том числе многослойные изображения и специальные эффекты для слоев. Когда редактирование будет закончено, рисунок сохраняется в нужном формате с помощью команды Файл — Сохранить как...

Особенно осторожно надо относиться к формату JPEG. Дело в том, что в нем используется сжатие с потерями, то есть, при сохранении некоторые детали изображения (малозаметные на первый взгляд) теряются. Когда файл сохраняется в этом формате, программа с помощью специального окна запрашивает, с каким качеством следует сохранить файл.

Качество 12 | Качество 6 | Качество 0

Качество определяется целым числом от 0 до 12 (см. рисунок). Число 12 означает, что рисунок сохраняется с наивысшим качеством, при снижении качества изображение становится более размытым. Эти искажения называют артефактами формата JPEG. Самое неприятное, что при каждом сохранении в формате JPG происходит потеря качества рисунка.

Искажения перспективы

При съемке на современные фотоаппараты часто возникают так называемые перспективные искажения — линии, которые должны быть вертикальными (например, стены зданий), на снимке становятся наклонными.

Загрузите файл column.jpg из папки PRACTICE/3 и найдите искажения перспективы.

Для исправления этих искажений надо выделить все изображение — нажать на клавиши Ctrl+A или выбрать пункт меню Выделение — Все. Удобнее увеличить размеры окна так, чтобы оно было несколько больше рисунка.

После этого надо выбрать пункт Редактирование — Трансформирование — Перспектива. Вокруг рисунка появляется рамка с маркерами, которые можно перетаскивать мышкой для исправления перспективы. Для изменения длин сторон рамки надо перетащить угловые маркеры, а для перемещения — маркерых на серединах сторон.

Исправьте перспективные искажения на фотографии так, чтобы колонна и стены зданий были вертикальными.

С помощью команд группы Трансформирование можно развернуть рисунок на любой угол, наклонить его, построить зеркальное отражение относительно вертикальной или горизонтальной оси и т.п. Команда Редактирование — Свободное трансформирование позволяет произвольно перемещать маркеры рамки при нажатой клавише Ctrl и таким образом устранять многие типы искажений.

 |  | Оглавление |
Знакомство с Photoshop | Назад | В начало | Вперед | Коррекция изображений


Уроки по Adobe Photoshop CS: коррекция изображений

Тема 4. Коррекция изображений

  1. Гистограмма и уровни
  2. Контраст и яркость
  3. Кривые
  4. Свет и тени
  5. Коррекция отдельных участков
  6. Коррекция цвета

1. Гистограмма и уровни

Что такое гистограмма?

Очень полезную информацию для оценки изображения дает гистограмма — график специального вида, который показывает распределение пикселов по яркости, от белого к черному. Вертикальные линии показывают количество пикселей, имеющих одинаковую яркость, от самых темных (слева) до самых светлых (справа).

Откройте окно обозревателя и перейдите в папку PRACTICE/4. Загрузите файл blossom.jpg и вызовите окно с гистограммой (Окно — Гистограмма).

Гистограмма этого изображения показывает, что практически все пиксели темные, гистограмма смещена влево, это темное малоконтрастное изображение.

Откройте файл snowy.jpg.

Здесь гистограмма смещена вправо — это светлое малоконтрастное изображение.

Откройте файл fruit.jpg.

Гистограмма с пиком в центре означает, что основная масса пикселей имеет среднюю яркость. Это значит, что рисунок недостаточно контрастен.

Откройте файл zimzv.jpg.

А это — контрастное изображение, гистограмма имеет пики в темной и светлой областях и низкую плотность пикселов в средних тонах.

Откройте файл mersedes.jpg.

Это — сбалансированное изображение, оно достаточно контрастно, пикселы распределяются по яркости более или менее равномерно.

Однако у этого снимка есть один недостаток, о котором мы уже говорили на прошлом уроке.

Исправьте перспективные искажения и сохраните файл с другим именем.

Автоматическая коррекция уровней

Как мы уже видели, желательно, чтобы гистограмма содержала полный диапазон — от темных до светлых тонов. В Photoshop есть возможность автоматической коррекции уровней: Изображение — Коррекция — Автоматическая тоновая коррекция (Shift+Ctrl+L). При этом программа сама изменяет яркость и контрастность изображения так, чтобы улучшить гистограмму.

Примените автоматическую коррекцию уровней ко всем открытым файлам и посмотрите, как меняется гистограмма. Сохраните исправленные файлы с новыми именами (blossom1.psd и т.д.).

Ручная коррекция уровней

Если автоматичесая коррекция дает плохой результат, можно корректировать уровни вручную: Изображение — Коррекция — Уровни (Ctrl+L).

Сделайте активным окно файла blossom.jpg и вызовите окно Уровни. Расположите его так, чтобы одновременно видеть и окно с гистограммой — там мы увидим все изменения.

В поле Входные уровни регулировка выполняется тремя движками — черным (предельный темный тон), серым (средние тона) и белым (самый светлый тон). Если сдвигать черный движок вправо, всем пикселям, расположенным слева от него, присваивается самый темный тон. Белый движок "обрезает" гистограмму справа — все пиксели справа от него становятся предельно яркими. Обычно можно отбросить таким образом "хвосты" в левой и правой частях гистограммы, если в них попадает небольшое количество пикселов, при этом качество изображения улучшается. Перемещая серый движок, можно затемнять или осветлять средние тона. Не забывайте установить флажок Предварительный просмотр — это позволяет сразу видеть, как будет изменяться изображение.

Установите движки примерно так, как показано на рисунке. Посмотрите, как меняется гистограмма при перемещении черного, белого и серого движков. Выберите лучший вариант и сохраните с именем blossom2.psd.

Мы редактировали сразу общую яркость (канал RGB). Обычно лучшие результаты получаются, если корректировать отдельно каждый из каналов: красный (R), зеленый (G) и синий (B). Для этого надо выбрать в списке Каналы нужную составляющую и выполнить коррекцию с помощью трех движков. Затем переходим к следующему каналу и т.д.

Загрузите снова исходный файл blossom.jpg и откройте окно Уровни. Выполните коррекцию отдельно для красного, зеленого и синего каналов, сохраните результат в файле blossom3.psd. Сравните, что получилось при разных способах коррекции уровней.

к началу К началу страницы

2. Контраст и яркость

Откройте файл bright.jpg и оцените это изображение. Какая корректировка требуется?

Настройка многих приборов, имеющих экран (телевизоров, мониторов), выполняется двумя регуляторами, которые изменяют яркость и контраст изображения. В Photoshop также есть возможность менять эти характеристики рисунка.

Автоконтраст

Автоматическая настройка контраста выполняется с помощью пункта меню Изображение — Коррекция — Автоконтраст (Alt+Shift+Ctrl+L).

Примените эту команду к открытому файлу. Улучшилось ли изображение? Отмените действие (Ctrl+Z).

Ручная коррекция

Для ручной коррекции надо вызвать окно Изображение — Коррекция — Яркость/Контраст, которое содержит два движка-регулятора.

Измените яркость и контраст для открытого файла и сохраните его с новым именем.

к началу К началу страницы

3. Кривые

Откройте файл floral.jpg и оцените это изображение по гистограмме. Какая корректировка требуется?

Это изображение в целом очень темное, но светлые тона хорошо проработаны, их не надо менять. Однако надо осветлить темные и средние тона. Такую сложную корректировку удобно выполнять с помощью кривых (меню Изображение — Коррекция — Кривые, клавиши Ctrl+M).

На горизонтальной оси откладывается яркость до преобразования, на вертикальной — после преобразования. В начале кривая представляет собой диагональ квадрата — яркости пикселей не изменяются. Щелчком мыши можно установить точки на кривой, которые затем перетаскиваются в нужное положение. Для удаления ненужной точки надо вытащить ее за пределы графика.

Удобно сразу наблюдать вносимые изменения на гистограмме, для этого надо расположить окна так, чтобы видеть окно Гистограмма.

Если кривая в каком-то месте идет выше диагонали, эти тона осветляются, если ниже — затемняются. Крутой наклон кривой говорит о повышении контраста, пологая кривая соответствует уменьшению контраста. Например, кривая, показанная на рисунке, вносит следующие изменения:

  • яркость и контраст светлых тонов оставлен без изменений, для этого на кривой установлена правая контрольная точка на диагонали;
  • яркость темных и средних тонов увеличена (кривая выше диагонали);
  • контраст темных тонов увеличен (наклон кривой больше, чем наклон диагонали);
  • контраст средних тонов уменьшен (наклон кривой меньше, чем наклон диагонали).

Так же, как и для уровней, коррекцию кривых можно делать отдельно для каждого цветового канала (красного, зеленого и синего).

Выполните корректировку кривых для загруженного изображения и посмотрите, как изменение кривой влияет на гистограмму. Сохраните результат в новом файле.

При восстановлении отсканированных старых фотографий часто требуется затемнить темные тона, осветлить светлые и повысить контраст средних тонов. Попробуйте нарисовать, как должна выглядеть в этом случае кривая коррекции.

Откройте файл oldphoto.jpg и оцените это изображение по гистограмме. Скорректируйте его с помощью кривых и сохраните результат в формате PSD. При построении кривой наблюдайте за изменением гистограммы.

к началу К началу страницы

4. Свет и тени

Откройте файл island.jpg и оцените гистограмму этого изображения (Окно — Гистограмма). Сохраните файл в формате PSD.

Это фотография низкого качества, так как съемка выполнялась при очень неудачном освещении. На снимке есть очень светлые и очень темные области. Изображение имеет повышенный контраст, это видно по гистограмме. В таких случаях полезно использовать команду Света и тени (Shadow/Hilight), которая позволяет отдельно регулировать светлые и темные области, а также контраст изображения.

Выберите пункт меню Изображение — Коррекция — Свет и тени.

Автоматически устанавливаются режимы корректировки для случая съемки против света или со вспышкой. Иногда использование ручной настройки позволяет улучшить результат.

Включите флажок Показать больше настроек и попробуйте улучшить качество изображения, используя доступные регулировки.

к началу К началу страницы

5. Коррекция отдельных участков

Все предыдущие способы позволяли изменить яркость и контраст всего изображения целиком. Однако иногда требуется исправить только отдельные участки изображения, не затрагивая оставшуюся часть. Для этой цели используются три инструмента, которые связаны с одной кнопкой в палитре инструментов и клавишей O:
  • Осветлитель (Dodge) [image] осветляет области, через которые проходит кисть
  • Затемнитель (Burn) [image] затеняет области
  • Губка (Sponge) [image] позволяет увеличивать или уменьшать насыщенность цвета
Эти инструменты используются для выделения важных объектов, повышения или понижения контраста в некоторых частях рисунка, а также для того, чтобы добавить свет или тень, направляя внимание зрителя к нужному объекту.

Мы будем использовать инструменты Осветлитель и Затемнитель. Они служат для повышения или понижения контрастности отдельных деталей. В отличие от команды Яркость/Контрастность, их можно настроить так, чтобы воздействовать только на светлые, темные или средние тона. Для этого в выпадающем списке Диапазон на панели свойств инструмента надо выбрать нужный вариант. Например, для того, чтобы повысить контраст, надо осветлить светлые тона и затемнить темные.

Второй важный параметр — Экспозиция — определяет силу воздействия инструмента на изображение. Профессионалы рекомендуют работать с экспозицией не более 10%, так чтобы вносимые изменения были плавными и результат выглядел естественно.

Для осветления или затемнения используется кисть. Ее основные параметры — диаметр (в пикселях) и жесткость (от 0 до 100%) устанавливаются в специальном окне, которое появляется при нажатии на кнопку [image]. Обычно выбирают мягкую кисть с жесткостью меньше 50%.

Если перевести курсор на поле рисунка, он принимает форму окружности, которая обозначает границы зоны действия инструмента. Для быстрого изменения диаметра во время работы удобно использоват клавиши [ (уменьшить) и ] (увеличить).

Откройте файл flowers.jpg и оцените это изображение. Какая корректировка требуется?

Это малоконтрастный рисунок, большую часть составляют средние тона. Для повышения контраста надо осветлить светлые тона и затемнить темные.

Оригинал | Результат

Включите инструмент Осветлитель в режиме Света с экспозицией 5% и обработайте светлые области (лепестки цветов).

Включите инструмент Затемнитель в режиме Тени с экспозицией 5% и обработайте темные области вокруг цветка. Сохраните результат в формате PSD.

Надо отметить, что инструменты Осветлитель и Затемнитель лучше подходят для редактирования черно-белых (полутоновых) изображений. При коррекции цветных изображений Осветлитель (при чрезмерном использовании) "вымывает" светлые цвета, делая их белыми. Напротив, Затемнитель может приводить к серым пятнам на изображении.

к началу К началу страницы

6. Коррекция цвета

Откройте файл brdhouse.jpg и оцените это изображение. Какая корректировка требуется?

Вариации

Простейший способ изменить цвет — вызвать окно Изображение — Коррекция — Варианты, которое позволяет добавить основные цвета моделей RGB (красный, зеленый, синий) и CMYK (голубой, пурпурный, желтый), а также сделать рисунок светлее или темнее.
Остается только щелкнуть мышкой на том варианте, который лучше, чем текущий. Можно улучшать изображение последовательно, например, добавить желтого цвета, затем сделать светлее и несколько раз добавить красного.

Переключатель в правой части окна позволяет выбрать для коррекции темные тона (Shadows), средние (Midtones) или светлые (Highlights), а также насыщенность (Saturation).

Движок ниже позволяет регулировать степень изменений от тонкой настройки (Fine) до грубой (Coarse).

Выполните коррекцию цвета загруженного изображения и сохраните его с другим именем.

Автоматическая коррекция

Автоматическая настройка цветов выполняется с помощью пункта меню Изображение — Коррекция — Автоматическая цветовая коррекция (Shift+Ctrl+B).

Примените эту команду к открытому файлу. Улучшилось ли изображение? Сохраните его с другим именем.

Ручная коррекция

Для ручной коррекции надо вызвать окно Изображение — Коррекция — Цветовой баланс (Ctrl+B). В этом окне три движка, регулирующие баланс между голубым и красным, фиолетовым и зеленым, желтым и синим. Эти пары цветов находятся напротив друг друга на цветовом круге в модели HSB.

Откройте исходный файл brdhouse.jpg. и исправьте для него цветовой баланс (надо уменьшить красную, фиолетовую и синюю составляющие так, чтобы кора дерева стала коричневой и исчез фиолетовый отлив). Сохраните результат с другим именем.

Оригинал | Результат

 |  | Оглавление |
Коррекция изображений | Назад | В начало | Вперед | Ретушь фотографий


Уроки по Adobe Photoshop CS: ретушь фотографий

Тема 5. Ретушь фотографий

  1. Введение
  2. Отмена действий
  3. Увеличение резкости
  4. Пятна, царапины и трещины
  5. Красные глаза

1. Введение

Что такое ретушь?

Ретушью называют устранение дефектов фотографий — пятен, царапин, трещин, вуали, дефектов съемки и обработки, эффекта "красных глаз".

При обработке портретов людей часто применяют косметическую ретушь — устранение дефектов (морщин, родимых пятен, складок кожи) и придание особой выразительности важным частям лица (глазам, бровям, губам). Этот процесс напоминает работу художника-визажиста или гримера.

При восстановлении старых фотографий говорят также о реставрации, когда надо восстановить первоначальный вид изображения, внося как можно меньше изменений.

Для устранения художественных дефектов применяют композиционную ретушь — кадрирование, удаление лишних элементов, добавление элементов, изменение фона, регулировку освещения.

Ретушь, которой раньше занимались фотографы — сложное и утомительно занятие. Компьютерная ретушь обладает очень большими возможностями и абсолютно безопасна для оригинального изображения.

Типы дефектов

Обычно выделяют технические дефекты (царапины, пятна, отслоение эмульсии) и художественные (неправильная композиция, освещенность, неудачный фон).

Кроме того, дефекты можно разделить на глобальные (низкий контраст, нерезкость, цветовые искажения, зернистость) и локальные (трещины, царапины, пятна, "красные глаза"). Обычно рекомендуется сначала устранить глобальные дефекты, при этом часто исчезают и некоторые локальные. Есть и исключение из правила — не надо повышать резкость изображения до ликвидации царапин и пятен.

к началу К началу страницы

2. Отмена действий

Ретушь выполняется методом проб и ошибок, поэтому очень важно уметь отменять сделанные изменения. Для этого в Photoshop существует несколько приемов.

Отмена последних операций

При нажатии на клавиши Ctrl+Z отменяется последнее изменение. Повторное нажатие Ctrl+Z снова выполняет отмененное действие.

При каждом нажатии на Alt+Ctrl+Z выполняется один шаг назад (так можно отменить несколько последовательных шагов), а при каждом нажатии на Shift+Ctrl+Z — один шаг вперед (если действия были отменены ранее). Все эти команды расположены в верхнем меню в группе Редактирование.

Восстановление из файла

В любой момент можно восстановить изображение до последней сохраненной на диске версии. Для этого надо нажать клавишу F12 или выбрать пункт меню Файл — Восстановить.

Палитра История

С помощью пункта меню Окно — История можно вызвать палитру История, где перечислены выполненные операции. Щелчок на какой-либо строке позволяет отменить сразу все операции до выделенной.

Кнопка [image] вызывает меню палитры, с помощью которого можно, например,

  • создать новый "снимок" — запомнить текущее состояние рисунка
  • удалить последние записи (включая выделенную)
  • создать новый документ с изображением, соответствующим выделенной строчке
  • очистить палитру История
  • настроить режимы палитры (например, можно включить нелинейный режим, то есть, разрешить отмену только некоторых операций из середины списка, а не всех последних).

к началу К началу страницы

3. Увеличение резкости

Откройте окно обозревателя и перейдите в папку PRACTICE/5. Загрузите файл mayak.jpg.

Это изображение размыто, ему не хватает резкости.

Фильтры Photoshop

Для повышения резкости в Photoshop используются специальные алгоритмы обработки, которые называются фильтрами. Программа содержит большое количество разноообразных фильтров и позволяет подключать нестандартные фильтры (разработанные не фирмой Adobe). Для повышения резкости применяют фильтры группы Резкость (Фильтр — Резкость), среди которых три полностью автоматические, а один — настраиваемый.

Автоматические фильтры

В группе Резкость существует три автоматических фильтра:
  • Фильтр Резкость (Sharpen) делает изображение немного четче, усиливает разницу в цвете между пикселями.
  • Фильтр Резкость+ (Sharpen More) — более сильный вариант первого фильтра.
  • Фильтр Резкость на краях (Sharpen Edges) "ищет" в изображении области резкого перепада цвета (границы объектов) и увеличивает там контраст, для остального изображения сохраняется размытость.

Примените каждый из фильтров к открытому изображению. Если эффект покажется очень слабым, можно применить фильтр несколько раз, нажимая клавиши Ctrl+F. При многократном применении фильтра появятся сильные искажения. Для восстановления исходного изображения используйте клавишу F12. Сохраните результаты применения трех фильтров в разных файлах в формате PSD и сравните их.

Настраиваемые фильтры

Фильтр Контурная резкость имеет три параметра:
  • Количество (Amount) (рекомендуется выбирать 150-200%)
  • Радиус (Radius) (рекомендуемый диапазон 1-4)
  • Порог (Threshold)
Этот фильтр исследует пиксели внутри области заданного радиуса. Если разность тона соседних пикселей больше установленного порога, она увеличивается на заданное значение.

При увеличении радиуса появляется свечение границ. Порог 0 означает, что в операции участвуют все пиксели, при пороге 255 изображение не меняется.

В Photoshop существует еще один фильтр с параметрами — Смарт-обострение. Он позволяет выбрать алгоритм обработки и отдельно корректировать резкость теней, полутонов и светлых областей.

Примените фильтр Контурная резкость к открытому изображению и сравните результат с предыдущими вариантами.

Резкость отдельных элементов

Откройте файл shmel.jpg.

Оригинал | Результат
В этом снимке аппарат был неправильно сфокусирован — основное внимание должно быть привлечено к цветку с сидящим на нем шмелем, но он получился нерезким, размытым. С другой стороны, второстепенный задний план получился резким и отвлекает внимание. Частично эти недостатки можно скомпенсировать с помощью двух инструментов, связанных с одной кнопкой в панели инструментов и клавиешй R: Размытие и [image] Резкость.

Принцип действия этих инструментов очень похож: они действуют там, где проходит (при нажатой левой кнопке мыши) кисть заданного размера.

Кисть имеет два основных параметра — диаметр и твердость. Они выбираются в окне, которое появляется при щелчке по кнопке [image]. Твердость определяет, насколько резкая будет граница у "мазка". При твердости 100% граница будет предельно четкой, а при твердости 0% — размытой. Если перевести мышь в область рисунка, курсор приобретает форму кисти выбранного размера. Для быстрого регулирования размера кисти удобно использовать клавиши [ (уменьшить) и ] (увеличить).

Инструменты имеют еще два параметра (они настравиваются в панели свойств инструмента):

  • Режим — способ наложения новых пикселей на изображение; чаще всего используются режимы Нормальный, Замена темным и Замена светлым
  • Интенсивность — определяет силу действия инструмента, рекомендуют устанавливать этот параметр не более 20%, чтобы не получить слишком сильный эффект.
Если отмечен флажок Сэмплировать все слои, на результат оказывают влияние все слои документа, если он сброшен — только активный слой.

Включите инструмент Резкость [image], в палитре свойств инструмента выберите диаметр кисти около 30 пикселей, жесткость 0% интенсивность 10%, режим Замена темным. Мазками аккуратно увеличьте резкость шмеля. Затем установите режим Замена светлым и увеличьте резкость цветка.

Включите инструмент Размытие [image], установите диаметр кисти около 30 пикселей, жесткость 0%, интенсивность около 50%, режим Нормальный. Размойте изображение вокруг цветка. Сохраните результат с расширением PSD.

к началу К началу страницы

4. Пятна, царапины и трещины

Откройте файл portrait.jpg. Если нужно, выполните коррекцию уровней.

Теперь мы запомним состояние рисунка, сделав его "снимок".

Перейдите в палитру История (Окно — История) и щелкните по кнопке [image] в нижней части палитры.

Вместо этого можно было также щелкнуть мышкой по кнопке [image] в правом верхнем углу палитры и в появившемся контекстном меню выбрать пункт Новый снимок. Дайте снимку имя Снимок 1 (по умолчанию).

Палитра История делится на две части. В верхней хранятся так называемые снимки изображения. Первый снимок создается автоматически при открытии файла, остальные — по команде пользователя. В любой момент можно вернуться в состояние, соответствующее снимку, если щелкнуть мышью на нужной строке.

Нижняя часть палитры хранит некоторое число последних операций, которые можно отменить (по умолчанию — 20 операций, это количество изменяется в окне Редактирование — Установки).

Оригинал | Результат

Это изображение имеет многочисленные дефекты, которые желательно удалить. Для этого в Photoshop используется два принципиальных подхода:

  • размытие изображения с помощью фильтра Шум — Пыль и царапины так, чтобы удалить мелкие дефекты (при этом теряется резкость)
  • копирование фрагмента из другой (неповрежденной) части изображения с такой же структурой с помощью инструментов Штамп, Лечащая кисть и Вставка

Фильтр Пыль и царапины

Фильтр Пыль и царапины (Dust & Scratches) удаляет мелкие дефекты, которые выделяются на фоне соседних пикселов. Он имеет два параметра:
  • Радиус (Radius) — определяет радиус действия фильтра, больший радиус дает большее размытие;
  • Граница (Threshold) — минимальная разность яркостей пикселей, при которой выделяющийся элемент удаляется.

Примените фильтр Пыль и царапины к загруженному изображению. Выберите параметры фильтра так, чтобы все мелкие дефекты были удалены (не обращайте внимание на сильное размытие!).

Очевидно, что в таком виде качество фотографии стало еще хуже, чем раньше.

Создайте новый снимок в палитре История и назовите его Снимок 2. Перейдите к Снимку 1, щелкнув по нему в палитре слои.

Мы снова вернулись к изображению с мелкими дефектами, однако размытое изображение сохранилось в виде снимка. Теперь мы будем копировать только те части со Снимка 2, которые закроют дефекты, поэтому резкость остального изображения не уменьшится. Для этой цели используется инструмент Архивная кисть (History Brush, клавиша Y) [image].

Параметры кисти выбираются так же, как и при использовании инструментов Размытие и Резкость. Свойство Непрозрачность (от 0% до 100%) позволяет ослабить действие кисти.

Включите инструмент Архивная кисть [image], в палитре свойств инструмента выберите диаметр около 30 пикселей, жесткость 0%, непрозрачность 100%. В палитре История щелкните в квадратике слева от Снимка 2, так чтобы в нем появился значок [image]. Это означает, что Архивная кисть будет копировать пиксели с этого снимка.

Чтобы не повредить изображение, будем использовать режимы Замена темным и Замена светлым. В первом их них заменяются только те пиксели, которые светлее существующих, во втором — только более темные.

В палитре свойств инструмента установите режим Замена темным и щелчками мыши удалите все мелкие светлые пятна. Затем включите режим Замена светлым и удалите все темные пятна. Сохраните результат.

Далее мы будем использовать другие инструменты для того, чтобы убрать крупные дефекты.

Инструмент Штамп

Инструмент Штамп [image] (Clone Stamp, клавиша S) служит для копирования одной части изображения на другую. Черный треугольник в левом нижнем углу обозначает, что за этой кнопкой скрывается несколько инструментов. Если навести курсор мыши на эту кнопку и удерживать нажатой левую кнопку мыши, появляется список этих инструментов. В данном случае в эту группу входит еще один инструмент — Узорный штамп (Pattern Stamp), который редко используется.

После включения инструмента Штамп надо установить его параметры на панели параметров выбранного инструмента (под верхним меню). Действие инструмента состоит в том, что изображение-образец наносится на другую часть рисунка кистью. Поэтому надо определить свойства этой кисти (диаметр и жесткость) и способ наложения нового изображения на старое, который определяется в полях Режим и Непрозрачность. Среди многочисленных режимов для инструмента Штамп наиболее важны три:

  • Норма (Normal) — новое изображение всегда перекрывает старое.
  • Темнее (Darken) — новое изображение перекрывает старое там, где старое светлее.
  • Светлее (Lighten) — новое изображение перекрывает старое там, где старое темнее.

Сначала надо отметить точку-образец: при нажатой клавише Alt щелкнуть мышью в нужной точке (курсор мыши принимает форму перекрестья).

Теперь можно подвести мышь к той области, куда мы хотим скопировать образец, и перемещать мышь при нажатой левой кнопке, как бы рисуя кистью.

Если флажок Выравнивание (Align) на панели свойств не отмечен, при каждом новом щелчке мышью будет применяться тот же образец. Если этот флажок отмечен, место образца будет смещаться соответственно перемещению мыши от первой рабочей точки.

При нажатии левой кнопки мыши крестик показывает, откуда берется образец для копирования.

Используя инструмент Штамп копий, удалите дефекты загруженного изображения. Сохраните результат в формате PSD.

Инструменты Лечащая кисть

Инструмент Лечащая кисть [image] (Healing Brush, клавиша J) и Специальная лечащая кисть [image] (Spot Healing Brush) работают подобно штампу, но дополнительно корректируют результат так, чтобы "попасть в тон и цвет". Для этого используется информация о цвете пикселей вокруг области действия инструмента.

Инструмент Специальная лечащая кисть предназначен для заделки небольших точечных пятен, которые можно закрыть за один раз. Он не имеет настроек и работает автоматически. При устранении более крупных дефектов вблизи контрастных объектов может получиться совершенно неожиданный результат.

С одной стороны, эти инструменты более "умные", чем штамп. Однако они хорошо работают только для мелких дефектов на достаточно однородном фоне. Если надо удалить большой дефект на контрастном фоне, сначала используют штамп (чтобы окружающие пиксели не влияли на наложение), а затем подправляют результат инструментом Лечащая кисть.

Откройте файл girl.jpg. Используя инструменты Штамп копий и Лечащая кисть, удалите дефекты изображения. Сохраните результат в формате PSD.

Оригинал | Результат

Инструмент Заплатка

Инструмент Заплатка [image] (Patch, клавиша J) входит в ту же группу инструментов, что и Лечащая кисть. Если на этой кнопке сейчас изображение Лечащей кисти, надо "нажать" на кнопку и выбрать в списке инструмент Вставка. Можно сделать по-другому: нажать клавишу J, удерживая Shift, при этом будет рабочий инструмент на этой кнопке меняется.

Принцип работы инструмента состоит в том, что мы ставим "заплатку" на место дефекта. Материал для этой заплатки вырезается из другой части изображения, близкой по цвету. Как и при использовании Лечащей кисти, при копировании цвет и тон "заплатки" подгоняется так, чтобы она не выделялась из окружающего материала.

Когда инструмент Заплатка включен, надо выбрать на панели свойств один из двух режимов — Источник или Приемник.

В режиме Источник надо при нажатой левой кнопке мыши обвести дефектное место и перетащить выделенную часть в то место, откуда берется заплатка.

В режиме Приемник надо делать наоборот — обвести заплатку и перетащить ее мышкой на место дефекта.

Откройте файл fruit.jpg. Используя инструмент Заплатка, удалите наклейку на левом ящике снизу. Для "заплатки" возьмите материал правого ящика. Сохраните результат в формате PSD.

Оригинал | Результат

Попроуйте таким же образом удалить наклейку справа на верхней полке. Какие проблемы вы заметили? Что делать?

к началу К началу страницы

5. Красные глаза

Фотолюбители знакомы с так называемым "эффектом красных глаз" при съемке со вспышкой в помещении. Свет фотовспышки освещает глазное дно, которое у человека имеет красный цвет. Этот цвет и фиксирует фотоаппарат. Опытные фотографы знают методы, позволяющие избавиться от "красных глаз" при съемке, однако, если фотография уже имеет этот дефект, его легко исправить с помощью Photoshop.

Инструмент Красные глаза

В версии Photoshop CS2 появился новый инструмент Красные глаза [image] (Red Eye Tool, клавиша J, на то же кнопке, где Лечащая кисть). Его использование очень просто — надо только щелкнуть мышью в района зрачка, дальше все будет сделано автоматически.

Откройте файл redeye.jpg и удалите эффект красных глаз с помощью этого инструмента. Сохраните результат в формате PSD.

Оригинал | Результат

Инструмент Замена цвета

Инструмент Замена цвета [image] (Color Replacement, клавиша J) появился в версии Photoshop CS. Он находится в той же группе (на той же кнопке), что и инструменты Лечащая кисть и Вставка. Этот инструмент заменяет цвет изображения на другой выбранный цвет, сохраняя яркость пикселов.

Выбрав инструмент Замена цвета, надо установить размер кисти так, чтобы ее диаметр был несколько меньше, чем диаметр глаза. Для подбора размеров удобно использовать клавиши [ (увеличить) и ] (уменьшить). В отличие от инструмента Красные глаза, здесь можно подобрать нужный цвет глаз, то есть он обладает большими возможностями, но требует аккуратного применения.

Сначала надо выбрать цвет, которым мы хотим заменить красный. В Photoshop рабочий (основной) цвет показан в верхнем квадрате в нижней части палитры инструментов. Двойной щелчок по этому квадрату позволяет выбрать новый рабочий цвет.

Второй квадрат отображает цвет фона. Если щелкнуть на стрелке в правом верхнем углу (или нажать клавишу X), рабочий цвет и цвет фона поменяются местами. Если щелкнуть на двух маленьких квадратиках в левом нижнем углу (или нажать клавишу D), будут установлены цвета по умолчанию — черный рабочий цвет и белый фон.

Итак, выберите новый цвет глаз в качестве рабочего цвета. Теперь при нажатой левой кнопке мыши "закрашиваем" красную область нужным цветом. При этом яркость не должна меняться, то есть, светлые пиксели останутся светлыми, а темные — темными.

Снова откройте файл redeye.jpg и удалите эффект красных глаз с помощью инструмента Замена цвета. Сохраните результат в новом формата PSD. Сравните результат двух разных корректировок

 |  | Оглавление |
Коррекция изображений | Назад | В начало | Вперед | Выделение областей


Уроки по Adobe Photoshop CS: выделение областей

Тема 6. Выделение областей

  1. Введение
  2. Простейшие приемы выделения
  3. Лассо
  4. Волшебная палочка
  5. Что можно делать с выделенной областью?

1. Введение

Выделение областей в редакторе Photoshop применяется для того, чтобы
  • корректировать тон, цвет и т.п. не для всего изображения, а только в выделенной части
  • переместить или скопировать элементы рисунка
  • вырезать объект из фона
Кроме простейших инструментов (прямоугольное и овальное выделение) существуют более сложные — лассо и волшебная палочка. Каждый из них имеет свои параметры настройки.

Можно добавить новую область к уже выделенной и вырезать область из выделения. Выделенные области можно сохранять, загружать и комбинировать.

к началу К началу страницы

2. Простейшие приемы выделения

Создание нового изображения

Сначала мы будем знакомиться с выделением областей на примере пустого документа с белым фоном. Чтобы его создать, выберите пункт меню Файл — Создать или нажмите клавиши Ctrl+N. В появившемся окне можно задать
  • размеры рисунка (в пикселях или в сантиметрах),
  • режим (битовое изображение, черно-белое, цветное в формате RGB, CMYK или Lab)
  • разрешение в пикселях на дюйм
  • фон (белый, прозрачный или фоновый цвет, выбранный в палитре инструментов)
Если в буфере обмена есть изображение, программа по умолчанию программа выбирает размеры рисунка равными размерам этого изображения.

Создайте новое цветное изображение размером 10 на 10 сантиметров с разрешением 72 ppi и белым фоном.

Окно Информация

Окно Информация (Окно — Информация, клавиша F8) позволяет увидеть цвет под курсором, координаты курсора и размеры выделенной области.
По умолчанию выводятся координаты и размеры области в пикселях. В меню палитры (которое появляется при нажатии на кнопку [image]) есть пункт Настройки палитры, который позволяет, например, выводить эти данные в сантиметрах.

Инструмент Прямоугольная область

Кнопка [image] инструмента Прямоугольная область (Rectangular Marquee, клавиша M) находится в левом верхнем углу палитры инструментов. В панели свойств инструмента можно выбрать два параметра: растушевку границы и стиль выделения.

Существует три стиля выделения:

  • Нормальный — можно выделить любой прямоугольник без ограничений на длины сторон
  • Заданные пропорции — разрешается выделять прямоугольники с заданным соотношением сторон (оно определяется числами в полях Ширина и Высота, для квадрата они должны быть равными)
  • Заданный размер — размеры области указываются в полях Ширина и Высота в пикселях или сантиметрах

Растушевка (Feather) границы — новое для нас понятие. Дело в том, что любой пиксель может быть выделен только частично, например, на 80%. Если мы будем заливать эту область, для такого пикселя новый цвет на 80% складывается из цвета заливки и на оставшиеся 20% — из существующего цвета этого пикселя. Растушевка означает плавный переход от границы выделенной области к фоновому рисунку.

Выделение прямоугольной области выполняется также, как и во всех графических редакторах, например, в Paint. Если никакая область еще не выделена, при нажатой клавише Shift будет выделен квадрат, а при нажатой клавише Alt прямоугольник выделяется от центра, а не от угла.

Для того, чтобы залить выделенную область одним цветом, надо выбрать пункт меню Редактирование — Залить (клавиши Shift+F5). В качестве заливки можно выбрать основной цвет, цвет фона, белый, черный, 50% серый или любой другой цвет. Дополнительно можно установить непрозрачность краски от 0% (нет заливки, полностью прозрачна) до 100% (полностью непрозрачна).

Установите растушевку 0, выделите область примерно 80 на 80 пикселей и залейте ее черным цветом. Затем установите растушевку 10 пикселей, выделите такую же область и залейте ее. Почувствуйте разницу.

Для удаления пикселов внутри области выделения надо нажать клавишу Delete. Если изображение имеет непрозрачный фон, эти пиксели заливаются фоновым цветом.

Выделите весь рисунок (Ctrl+A) и очистите его.

Инструмент Овальная область

Инструмент Овальная область [image] находится в той же группе инструментов, что и Прямоугольная область (клавиша М).

Выделение овальной области выполняется также, как в Paint. Если никакая область еще не выделена, при нажатой клавише Shift будет выделен круг, а при нажатой клавише Alt овал выделяется от центра, а не от угла.

Кроме уже известных параметров (стиль и растушевка) у эллипса есть еще один — Сглаживание (Anti-aliasing, в некоторых версиях русских переводится как Не грубо). Поскольку рисунок состоит из отдельных точек, после заливки края эллипса выглядят как ступеньки лесенки. Если при выделении использовалось сглаживание, будут добавлены соседние пиксели, которые обеспечивают плавный переход и иллюзию непрерывной границы.

Изучим еще одну операцию — обводку контура. Для этого надо выбрать пункт меню Редактирование — Выполнить обводку (Edit — Stroke). Программа позволяет задать ширину обводки контура, ее расположение (внутри, по центру или снаружи контура), непрозрачность.

Установите растушевку 0 и снимите флажок Сглаживание. Выделите овальную область и обведите ее черным цветом. Затем установите флажок Сглаживание, выделите такую же область и снова обведите ее. Сравните два контура при сильном увеличении.

Используя выделение с растушевкой, очень легко сделать виньетку — плавный переход изображения в фон. Идея заключается в том, чтобы сначала выделить нужную область, затем сделать ее инверсию (то есть, сделать так, чтобы выделенные пиксели стали невыделенными и наоборот), и наконец удалить выделенную часть, которая заливается цветом фона (по умолчанию — белым).

Откройте Обозреватель файлов и перейдите в папку PRACTICE/6. Откройте файл marry.jpg.

Установите растушевку 20-30 пикселей и выделите овальной областью центральную часть снимка.

Выполните инверсию выделения, нажав клавиши Shift+Ctrl+I, и удалите выделенную область клавишей Delete. Сохраните результат в виде файла формата PSD.

Перемещение и копирование

Если область выделена и инструмент выделения остается активен, эту область мышкой можно перетащить за середину в нужное место, рисунок при этом не меняется.

Если же мы хотим переместить изображение, которое оказалось внутри области, надо включить инструмент Перемещение, щелкнув по кнопке [image] на панели инструментов или нажав на клавишу V. Теперь перетаскивание области приведет к перемещению изображения в новое место, а освободившиеся пиксели заливаются цветом фона.

Можно временно включить инструмент Перемещение, нажав на клавишу Ctrl и удерживая ее. При отпускании клавиши Ctrl снова включается выбранный ранее инструмент.

Если в режиме перемещения удерживать нажатой клавишу Alt, изображение будет скопировано, а не вырезано. На это указывает изменившаяся форма курсора (две стрелки).

В практической части мы будем собирать рисунок из составных частей.

Оригинал | Результат

Откройте Обозреватель файлов и перейдите в папку PRACTICE/6. Откройте файл start6.psd и cохраните его под именем work6.psd.

Выделите срез морковки инструментом Овальная область. Используя копирование, установите два "глаза" из моркови так, как сделано в файле end6.psd. Затем также скопируйте "зрачки" из черники. Для смягчения границ при наложении одного элемента на другой используйте растушевку 3 пикселя.

Выделите киви и установите его вместо рта.

к началу К началу страницы

3. Лассо

Основные инструменты

Для выделения сложных областей используют инструменты группы Лассо (клавиша L). Кнопка инструмента Лассо выглядит так: . Для выделения области надо просто обвести ее мышью. При использовании этого инструмента требуется твердая рука. В момент отпускания мыши кривая замыкается.

Обычно удобнее использовать второй инструмент этой группы — многоугольное лассо (Прямолинейное лассо) [image]. Щелчками левой кнопкой мыши надо последовательно отметить все узлы ломаной, ограничивающей область выделения. Если щелкнуть снова около первой точки, линия замыкается. Кроме того, двойной щелчок также замыкает ломаную.

Клавиша Alt позволяет переключаться между этими двумя инструментами. Например, если при выделении инструментом Лассо нажать клавишу Alt (не отпуская кнопку мыши), инструмент переходит в режим Прямолинейное лассо и наоборот.

Используя инструменты Лассо и Прямолинейное лассо выделите бантик и установите его на место. Не снимая выделения, выберите пункт меню Редактирование — Трансформирование — Масштаб и уменьшите высоту бантика.

Если при изменении масштаба удерживать клавишу Shift, пропорции рисунка не будут искажаться.

Магнитное лассо

Инструмент Магнитное лассо [image] также принадлежит к группе Лассо (клавиша L). Он предназначен для выделения объектов с достаточно четкими границами. Линия выделения как будто сама "прилипает" к этим границам.

Инструмент имеет три новых параметра:

  • Ширина — ширина полосы, в которой ищется граница;
  • Контраст от 1% до 100% — определяет, какой контраст имеет граница;
  • Частота от 1 до 100 — частота узлов линии, она определяет точность выделения границы.
Если нажать клавишу Caps Lock, курсор мыши меняет форму и показывает, в какой полосе ищется граница.

Если кривая пошла не туда, куда нужно, можно удалить неверно установленные последние узлы, нажимая на клавишу Delete или Backspace.

Используя инструмент Магнитное лассо, выделите "ухо" из грейпфрута и установите его на место. Не снимая выделения, выберите пункт меню Редактирование — Трансформирование — Масштаб и уменьшите ширину уха.

Скопируйте ухо на другую сторону головы. Не снимая выделения, выберите пункт меню Редактирование — Трансформирование — Отразить горизонтально. Затем поверните ухо на нужный угол с помощью команды Редактирование — Трансформирование — Вращение и установите его на место.

Используя изученные на прошлом уроке инструменты для ретуши, подправьте место, где уши соприкасаются с головой.

Выделите в прямоугольник все лицо и сдвиньте его вниз так, чтобы наверх поместился колпак, как на изображении end6.psd. Используя инструмент Магнитное лассо, выделите гриб-колпак и становите его на место.

к началу К началу страницы

4. Волшебная палочка

Инструмент Волшебная палочка [image] (Magic Wand, клавиша W) предназначен для выделения областей одного или близкого цвета. За базовый цвет выделения принимается цвет пикселя, на котором сделан щелчок мышкой.

Инструмент имеет несколько параметров:

  • Допуск (Tolerance, в некоторых переводах — Обратная чувствительность) от 0 до 255 показывает, какое отклонение от базового цвета допустимо, чтобы пиксель был выделен. При значении допуска 0 выделяется область, залитая точно одним цветом. Если допуск равен 255, выделяются все пиксели (весь рисунок).
  • Сглаживание (Anti-aliasing, Не грубо) — показывает, есть ли сглаживание границы выделения.
  • Смежные пиксели (Contiguous, в некоторых переводах — Непрерывный) — флажок, показывающий, надо ли выделять области в других частях рисунка. Если он установлен, выделяется одна непрерывная область, если сброшен — выделяются все пиксели выбранного цвета во всем изображении.

Поэкспериментируйте с инструментом Волшебная палочка, изменяя его параметры.

Режимы выделения

В левой части палитры свойств инструмента расположены четыре переключателя [image], которые обозначают режим выделения:
  • — новая область, старое выделение отменяется;
  • — новая область добавляется к уже выделенной, для временного включения этого режима надо удерживать клавишу Shift;
  • — новая область вычитается из уже выделенной, для временного включения этого режима надо удерживать клавишу Alt;
  • — выделение строится как пересечение (общая часть) новой области и старой, для временного включения этого режима надо удерживать одновременно клавиши Shift и Alt.

Установите для инструмента Волшебная палочка чувствительность 50 и флажок Непрерывный. Выделите щелчком грушевидный помидор. Удерживая клавишу Shift, добавьте к выделенной области недостающие части, щелкая по ним мышью. Скопируйте этот объект вместо носа.

Для точного расположения выделенного объекта можно использовать клавиатурные стрелки. За одно нажатие он перемещается на 1 пиксель, а при нажатой клавише Shift — на 5 пикселей.

Таким же образом выделите цветок, скопируйте его на середину бантика и уменьшите до нужных размеров с помощью команды Редактирование — Трансформирование — Масштаб.

Выделите все горошины одновременно и скопируйте их на колпак. С помощью команды Редактирование — Трансформирование — Поворот установите нужный угол поворота и расположите горошины так, как на образце.

При выделении сложных фигур на ровном фоне можно использовать такой прием: сначала выделяем прямоугольник, в который входит объект, а затем "вырезаем" из него фон, щелкая волшебной палочкой при нажатой клавише Alt.

Используя этот метод, выделите пучок редиса и скопируйте его два раза вместо бровей. Чтобы размернуть вторую бровь, используйте команду Редактирование — Трансформирование — Отразить горизонтально.

Используя инструмент Кадрирование, оставьте только построенную голову, удалив оставшиеся части рисунка. Сохраните файл.

к началу К началу страницы

5. Что можно делать с выделенной областью?

Мы уже знаем, как можно
  • удалить выделенную часть изображения (клавиша Delete)
  • переместить область выделения, не изменяя изображение (перетащить мышкой, не выключая инструмент выделения)
  • переместить изображение (включить инструмент Перемещение [image] или удерживать клавишу Ctrl, а затем перетащить область за середину)
  • копировать изображение (делать то же самое, что и при перемещении, но дополнительно удерживать клавишу Alt)
  • трансформировать (менять форму) выделенной части (с помощью меню Редактирование — Трансформирование).
Кроме этого, в Photoshop есть следующие возможности
  • отменить выделение — выбрать пункт меню Выделение — Отменить выделение или нажать клавиши Ctrl+D;
  • скрыть выделение (оно будет действовать, но контур не будет виден) — нажать клавиши Ctrl+H; повторное нажатие Ctrl+H снова покажет выделенную область;
  • инвертировать выделение, то есть, сделать так, чтобы выделенная область стала невыделенной и наоборот — выбрать пункт меню Выделение — Инверсия;
  • выделить границу области заданной толщины — выбрать пункт меню Выделение — Модификация — Граница;
  • расширить или сжать область на заданное количество пикселей — выбрать пункт меню Выделение — Модификация — Расширить или Сжать;
  • сгладить границу — выбрать пункт меню Выделение — Модификация — Оптимизация (или, в некоторых переводах, Сглаживание);
  • растушевать на заданное число пикселей — выбрать пункт меню Выделение — Растушевка или нажать клавиши Alt+Ctrl+D;
  • расширить выделение (включить в него соседние пиксели в пределах допуска инструмента Волшебная палочка) — выбрать пункт меню Выделение — Смежные пиксели;
  • выделить подобные пикселы — включить в выделение все (не только соседние!) пиксели в пределах допуска инструмента Волшебная палочка) — выбрать пункт меню Выделение — Подобные оттенки.
  • сохранить выделение (Выделение — Сохранить выделенную область) — записать информацию о выделении в специальный канал — изображение в оттенках серого, в котором каждый пиксель имеет оттенок от 0 (черный, не выделен) до 255 (белый, выделен полностью);
  • загрузить выделение из канала (Выделение — Загрузить выделенную область), при этом можно определить, как взаимодействует это выделение с существующим: новая область может быть добавлена или вычтена из существующей, или построена как пересечение двух областей.

Откройте файл man.jpg и cохраните его с расширением PSD.

Включите инструмент Прямолинейное лассо и установите в панели свойств инструмента растушевку 0 пикселов. Выделите многоугольником голову мужчины.

Выберите команду Выделение — Преобразовать выделение и подправьте размеры и положение выделенной области. Для завершения операции нажмите клавишу Enter.

Выберите бежевый фон (например, R=246, G=207, B=152). Сделайте инверсию выделения, чтобы выделить область вокруг головы (Выделение — Инверсия или клавиши Shift+Ctrl+I). Затем удалите выделенные пикселы, нажав клавишу Delete.

Удаленная область заливается цветом фона, причем оставшаяся область имеет резкие угловатые границы.

Отмените удаление (клавиши Ctrl+Z). Примените команду Выделение — Модификация — Оптимизация с радиусом 50 пикселей и снова удалите выделенную область.

Теперь "окно" имеет плавный контур, но граница по-прежнему резкая.

Сохраните выделенную область с именем Край, применив команду Выделение — Сохранить выделенную область.

Снова отмените удаление. Примените команду Выделение — Растушевка (клавиши Alt+Ctrl+D) с радиусом 30 пикселей и снова удалите выделенную область.

Теперь получился эффект виньетки — плавный переход от рисунка к фону.

Отмените операцию и загрузите выделение с именем Края (пункт меню Выделение — Загрузить выделенную область). Залейте область коричневым цветом (клавиши Shift+F5).

Сделайте инверсию выделения (Shift+Ctrl+I) и примените команду Выделение — Модификация — Граница, установив ширину границы 20 пикселей.

Выберите цвет для рамки и залейте выделенную область.

 |  | Оглавление |
Ретушь фотографий | Назад | В начало | Вперед | Инструменты рисования


Уроки по Adobe Photoshop CS: инструменты рисования

Тема 7. Инструменты рисования

  1. Выбор цвета
  2. Карандаш и Кисть
  3. Ластик
  4. Заливка
  5. Другие инструменты
  6. Создание рисунка
  7. Раскрашивание черно-белых фотографий

1. Выбор цвета

Основные принципы

В Photoshop используется два цвета — основной и фоновый. Они устанавливаются с помощью специальной области в нижней части палитры инструментов. Основной цвет показан в верхнем квадрате, фоновый - в нижнем. Двойной щелчок по верхнему (нижнему) квадрату позволяет выбрать новый основной (фоновый) цвет. В отдельном окне Палитра цветов существуют следующие возможности:
  • выбрать нужный цвет, щелкнув мышкой в нужном месте палитры
  • ввести значение составляющих цвета в форматах RGB, CMYK, HSB или Lab
  • ввести RGB-код цвета в шестнадцатеричном виде
  • получать предупреждение о том, что цвет не входит в диапазон модели CMYK, то есть, не может быть напечатан (значок [image], щелкнув по нему можно выбрать ближайший цвет, входящий в модель CMYK)
  • получать предупреждение о том, что цвет не входит в безопасную Web-палитру, (значок [image], щелкнув по нему можно выбрать ближайший цвет, входящий в безопасную Web-палитру)

Если щелкнуть на стрелке в правом верхнем углу (или нажать клавишу X), рабочий цвет и цвет фона поменяются местами. Если щелкнуть на двух маленьких квадратиках в левом нижнем углу (или нажать клавишу D), будут установлены цвета по умолчанию — черный рабочий цвет и белый фон.

Пипетка

Если на изображении уже есть нужный цвет, можно выбрать его щелчком мыши, предварительно включив инструмент Пипетка [image] (Eyedropper, клавиша I). При этом будет изменен основной цвет, а если еще нажата клавиша Alt — фоновый цвет.

Инструмент Пипетка можно временно включить при работе любого инструмента, нажав клавишу Alt.

Образцы

Выбрать цвет можно также из палитры Образцы (Окно — Образцы).
При наведении на заполненную клетку курсор мыши приобретает вид пипетки, щелчком мыши выбирается новый основной цвет. Если удерживать клавишу Ctrl, выбранный цвет устанавливается как фоновый.

Щелчок мыши на образце при нажатой клавише Alt удаляет цвет из палитры.

Если нужно, в этой палитре можно запомнить выбранный основной цвет, например, для дальнейшего использования. Надо навести курсор на свободную ячейку и щелкнуть мышью. После этого будет предложено ввести название для этого цвета и он будет внесен в палитру.

Для управления палитрой Образцы используется меню, которое можно вывести на экран с помощью кнопки [image].

к началу К началу страницы

2. Карандаш и Кисть

Инструменты Карандаш [image] и Кисть [image] связаны с одной кнопкой и включаются при нажатии клавиши B. Карандаш, в отличие от кисти, всегда имеет твердость 100%, то есть, граница всегда резкая. Поэтому Карандаш удобно использовать для изменения отдельных пикселей рисунка.

Кнопка [image] позволяет выбрать диаметр инструмента, форму мазка и твердость (для кисти). Кроме того, у инструмента Кисть есть много дополнительных параметров, корые можно изменить, щелкнув на кнопке [image] в правой части панели свойств инструмента (рядом с кнопкой Обозревателя файлов). Мы будем использовать только один параметр — сделаем так, чтобы ширина мазка уменьшалась при проводке. Для этого надо вызвать окно параметров, щелкнув по кнопке [image], и выбрать в левой части раздел Динамика формы. В правой части в поле Управление выше движка Минимальный диаметр надо выбрать режим Переход (в некоторых переводах Затухание или Сглаживание) и ввести справа количество шагов, за которое диаметр кисти уменьшается от начального до установленного ниже (движком) минимального диаметра.

Параметр Нажим (Flow) определяет скорость вытекания краски из кисти от 0% (самый слабый поток) до 100% (максимум).

Размер кисти можно быстро уменьщить, нажимая на клавишу [, или увеличить с помощью клавиши ].

к началу К началу страницы

3. Ластик

Инструмент Ластик (Стиратель) [image] (Eraser, клавиша E) служит для стирания частей изображения. В палитре свойств инструмента можно выбрать одну из трех форм (режимов): кисть, карандаш или квадратный блок (как в редакторе Paint). Фактически ластик — это один из перечисленных инструментов, рисующий фоновым цветом. Если изображение имеет прозрачный фон, ластик делает пиксели прозрачными.

В эту же группу входят инструменты Фоновый ластик [image] (Background Eraser) и Волшебный ластик [image] (Magic Eraser). Они предназначены для создания изображений с прозрачными областями и пока мы не будем их рассматривать. Все стирающие инструменты связаны с одной кнопкой и клавишей E.

к началу К началу страницы

4. Заливка

Заливка

Инструмент Заливка [image] (Paint Bucket, клавиша G) предназначен для заливки замкнутых областей одного (или близкого) цвета другим цветом или узором. Инструмент имеет несколько параметров настройки.
  • Заливка имеет два значения: Передний план (заливка основным цветом) и Шаблон (заливка узором, который выбирается в поле справа [image]). Для того, чтобы добавить свой узор, надо нарисовать его, выделить прямоугольник и выбрать пункт меню Редактирование — Определить узор.
  • Непрозрачность определяет, насколько непрозрачной будет заливка (0% — нет заливки, 100% — заливка полностью перекрывает цвет изображения).
  • Параметры Допуск, Сглаживание, Смежные пиксели определяются так же, как и для инструмента Волшебная палочка (см. Тему 6). Фактически сначала нужная область выделяется, а затем заливается цветом или узором.

Градиент

Градиент [image] (Gradient, клавиша G) находится на той же кнопке, что и Заливка. Этот инструмент предназначен для заливки выделенной области (или всего рисунка, если ничего не выделено) градиентом. Так называется плавный переход между двумя или несколькими цветами. Инструмент Градиент имеет несколько параметров:
  • В окне [image] надо выбрать один из стандартных градиентов; по умолчанию устанавливается переход между основным цветом и цветом фона, мы будем использовать пока только его. Если щелкнуть не по стрелке выпадающего списка, а по самой линейке с переходом цветов, можно определить свой градиент в специальном окне.
  • Тип градиента определяется с помощью группы кнопок [image], которые обозначают (слева направо) линейный, радиальный (круговой), угловой, цилиндрический (отраженный) и ромбовидный градиенты.
  • Флажок Прозрачность надо отметить, если в градиенте есть прозрачные и полупрозрачные области (например, переход от основного цвета к полной прозрачности).

Создайте новый рисунок 300 на 300 с белым фоном и попробуйте применить все типы градиента.

к началу К началу страницы

5. Другие инструменты

Палец

Инструмент Палец [image] (Smudge, клавиша R) имитирует размазывание масляной краски пальцем, которое иногда используют художники. Параметры инструмента:
  • Режим определяет, на что влияет "размазывание". Чаще всего используются режимы Нормальный (имитирует размазывание краски), Замена темным и Замена светлым (затемняют или осветляют изображение).
  • Интенсивность от 0% до 100% характеризует силу воздействия инструмента.
  • Если отметить флажок Рисование пальцем, в изображение будет добавляться еще и основной цвет, как будто палец предварительно обмакнули в эту краску.

Штамп

Штамп использую для копирование части изображения. Подробнее об инструменте Штамп было рассказано ранее (см. Тему 5).

к началу К началу страницы

6. Создание рисунка

Основные контуры

Откройте Обозреватель файлов и перейдите в папку PRACTICE/7. Откройте файл end7.jpg. Примерно такой рисунок мы должны получить.

Создайте новый рисунок размером 300 на 400 пикселей с белым фоном и сохраните его в формате PSD.

Установите белый фоновый цвет и серый основной цвет и нарисуйте контур скалы с помощью инстрвмента Карандаш. Залейте внутреннюю часть контура с помощью инструмента Заливка. При необходимости подправьте контур скалы инструментом Ластик.

Выделите скалу инструментом Волшебная палочка и сохраните выделение в канале Скала.

Инструментом Карандаш при нажатой клавише Shift проведите горизонтальную линию, отделяющую небо и воду.

Сохраните области неба и воды в отдельных каналах, выделяя их инструментом Волшебная палочка. Дайте этм каналам имена Небо и Вода.

Раскраска

Загрузите выделение из канала Скала. Выберите темно-серый основной цвет и кистью (диаметром 10-20 пикселей) нанесите мазки на скалу. Затем включите инструмент Палец и в режиме Нормальный размажьте эти мазки, так, чтобы скала была похожа на образец. Для того, чтобы создать шероховатость поверхности скалы, примените фильтр Шум — Добавить шум.

Загрузите выделение из канала Небо и залейте область линейным градиентом от оранжевого к фиолетовому. Сделайте то же самое для воды, загрузив выделение из канала Вода.

Выделите скалу и отрегулируйте ее тон и цвет так, чтобы они соответствовали небу (используйте команды Яркость/Контрастность, Цветовой тон/Насыщенность из меню Изображение — Коррекция).

Постройте отражение скалы в воде. Для этого надо загрузить выделение из канала Скала, скопировать выделенную часть (перетащить вниз при нажатых клавишах Ctrl и Alt и перевернуть (Редактирование — Трансформирование — Отразить по вертикали).

Выделите воду и уменьшите яркость и контрастность этой области (Изображение — Коррекция — Яркость/Контрастность).

Детали

Выделите круг, обозначающий солнце, и залейте его радиальным градиентом от белого (в центре) к оранжевому.

Выберите белый основной цвет и включите инструмент Кисть. Установите диаметр кисти 16 пикселей и затухание мазка за 15 шагов. Проведите несколько белых лучей солнца в стороны и вверх от диска. Затем выделите область солнца с лучами и примените к выделенной области фильтр Размытие по Гауссу с радиусом около 5 пикселей.

Снова включите инструмент Кисть и нанесите мазками солнечную дорожку на воду. Затем выделите воду и примените фильтр Размытие в движении с дистанцией около 20 пикселей.

С помощью инструмента Карандаш толщиной 5-6 пикселей нарисуйте коричневый ствол дерева. Затем включите инструмент Кисть и нарисуйте мазками листву темно-зеленого цвета. Предварительно надо отключить уменьшение диаметра кисти при проводке.

к началу К началу страницы

7. Раскрашивание черно-белых фотографий

Откройте файл vysot.jpg.

Это кадр из фильма "Вертикаль" с участием актера, поэта и исполнителя Владимира Высоцкого. Наша задача — раскрасить эту фотографию.

Оригинал | Результат

Для этой цели используются два основных средства Photoshop:

  • инструменты рисования в режиме наложения Цветность (Color) не меняют яркость пикселей, поэтому этот режим удобно использовать для изменения цвета с помощью кисти, градиента и т.п.
  • тонирование выделенной области с помощью окна Цветовой тон/Насыщенность при включенном флажке Тонирование (Colorize); с помощью трех движков можно установить тон, насыщенность и яркость для выделенной области

Выберите цвет, похожий на цвет кожи (например, R=250, G=207, B=172). Включите инструмент Кисть и установите диаметр 30-40 пикселей и твердость 0% (кисть должна быть мягкой, с плавными переходами по краям), режим наложения Цветность и непрозрачность 75%. Закрасьте лицо и шею актера.

С помощью инструментов группы Лассо выделите спортивный костюм, исключив белый ободок воротника. Примените команду Изображение — Регулировки — Цветовой тон/Насыщенность (Hue/Saturation). В диалоговом окне включите флажок Тонирование и установите движки тона, насыщенности и яркости так, чтобы костюм приобрел естественный синий цвет.

Выделите палатку (слева и справа от головы). Для этого можно использовать различные лассо, добавляя нужные области при нажатой клавише Shift.

Установите основным цветом желто-зеленый цвет брезента, а фоновым — более светлый цвет с добавлением желтого. Включите инструмент Градиент [image], установите режим наложения Цветность и залейте выделенную область так, чтобы верхняя часть палатки была более светлой.

Выделите волосы и добавьте им коричневый оттенок любым способом.

Выделите части скалы выше палатки и справа от актера. С помощью окна Изображение — Коррекция — Кривые добейтесь, чтобы средние тона были проработаны (надо затемнить светлые тона и понизить контраст средних, подробнее см. Тему 4).

Инструментом Волшебная палочка с чувствительностью 30-40 единиц выделите область неба и залейте ее цветом неба (например, R=56, G=100, B=175).

Включите инструмент Палец [image], установите режим Нормальный, непрозрачность 50-60% и включите флажок Рисование пальцем. Выберите основной цвет — белый и нарисуйте облака на небе. Сохраните результат.

 |  | Оглавление |
Выделение областей | Назад | В начало | Вперед | Многослойные документы


Уроки по Adobe Photoshop CS: многослойные документы

Тема 8. Многослойные документы

  1. Введение
  2. Палитра Слои
  3. Практическая работа
  4. Копирование слоев
  5. Работа с буфером обмена
  6. Корректирующие слои

1. Введение

Изображение в Photoshop может включать несколько слоев. Во многих случаях это удобно, потому что позволяет разделить весь рисунок на независимые части, каждая из которых может редактироваться и перемещаться отдельно, не затрагивая другие. Рекомендуют также выполнять все сложные операции с копией слоя, чтобы потом в случае ошибки можно было легко вернуться к исходному изображению.

При создании рисунка он содержит особый непрозрачный слой — Задний план (или Фон, Background). Затем сверху можно добавлять новые слои (вначале они будут прозрачными), в каждом из которых может быть некоторое изображение. В изображениях с прозрачными областями фоновый слой отсутствует (его удаляют или преобразуют в обычный слой).

Слои накладываются друга на друга и мы видим рисунок на экране так, как если бы мы смотрели сверху на все слои. Через прозрачные области верхнего слоя видны нижние слои. Слои могут быть полупрозрачные (например, с непрозрачностью 30%), в этом случае через изображение проступает нижний слой.

Слои можно удалять, менять местами, объединять. Чаще всего все операции выполняются с одним слоем, который называется активным. Некоторые инструменты (например, Волшебная палочка или Штамп позволяют работать одновременно со всеми слоями. Для этого надо отметить флажок Использовать все слои в палитре свойств инструмента.

Каждый слой занимает дополнительное место в памяти, поэтому ненужный слои лучше удалять или объединять.

к началу К началу страницы

2. Палитра Слои

Для работы со слоями используют палитру Слои (Окно — Слои, клавиша F7).

Откройте Обозреватель файлов и перейдите в папку PRACTICE/8. Откройте файл start8.psd. Определите, сколько слоев в этом изображении. Сохраните его с именем work8.psd

Изображение глаза [image] слева от слоя говорит о том, что слой видимый. Щелкнув на этом значке, можно сделать его невидимым.

Сделайте невидимым фоновый слой. Прозрачные области оставшегося изображения залиты серой клеткой. Снова включите фоновый слой.

Значок "кисть" [image] обозначает активный слой, он выделяется синим цветом. Чтобы сделать активным другой слой, надо щелкнуть по его названию.

Сделайте активным слой Фигура. Включите инструмент Перемещение [image] и попробуйте переместить фигурку. Затем верните ее на место.

Слои можно связывать между собой. Для этого надо выделить нужные слои и щелкнуть по кнопке [image] в нижней части палитры Слои. Тогда при выделении какого-либо слоя для всех связанных с ним слоев справа от названия появляется знак [image]. Чтобы разорвать связь, надо выделить слой и щелкнуть по кнопке [image]. При использовании инструмента Перемещение связанные слои будут перемещаться вместе.

Сделайте активным слой Фигура и свяжите с ним слои Рубашка, Штаны и Жилетка. Попробуйте снова перемещать фигурку.

Для активного слоя в верхней части палитры можно установить режим наложения (стандартно — Нормальный) и непрозрачность. С помощью кнопок группы Блокировка можно защитить прозрачные пиксели слоя [image], закрашенные пиксели [image], заблокировать перемещение [image] или все перечисленное [image].

Сделайте активным слой Жилетка и попробуйте поменять его непрозрачность.

Слои можно менять местами, просто перетаскивая мышкой в палитре Слои.

Сделайте невидимым слой Жилетка и поменяйте местами слои Рубашка и Штаны.

Щелкнув по кнопке [image] в нижней части окна можно создать новый слой выше активного слоя. Чтобы скопировать слой, надо перетащить его на эту кнопку.

Для удаления активного слоя служит кнопка [image]. Можно также перетащить любой слой на эту кнопку, в этом случае он удаляется без дополнительного подтверждения.

Удалите слой Ботинок.

Кнопка [image] открывает меню палитры, которое содержит все доступные команды. Чтобы переименовать слой, надо выбрать команду Свойства слоя из меню палитры или из контекстного меню (щелкнув по слою правой кнопкой мыши). Второй способ перименования — выполнить двойной щелчок мышью по названию слоя и ввести новое имя прямо в палитре Слои.

Измените название слоя Штаны на Шорты.

к началу К началу страницы

3. Практическая работа

Фоновый слой можно преобразовать в обычный, если дважды щелкнуть по нему и ввести новое имя. После этого его можно перемещать, менять прозрачность и т.д. Можно также выбрать пункт верхнего меню Слой — Новый — Из заднего плана.

Преобразуйте фоновый слой в обычный и дайте ему имя Море.

Можно сделать и обратную операцию — преобразовать обычный слой в фоновый. Для этого надо выбрать пункт верхнего меню Слой — Новый — Преобразовать в задний план.

Преобразуйте слой Море обратно в фоновый слой.

Создайте выше фонового слоя новый слой Градиент и залейте его градиентом от светло-фиолетового цвета (сверху) к прозрачному. Для этого надо выбрать основной цвет — светло-фиолетовый, и градиент от основного цвета к прозрачному. В списке режмов наложения выберите вариант Замена темным вместо Нормальный. Теперь этот слой изменяет (затемняет) только те пиксели изображения, которые светлее, чем пиксели слоя Градиент.

Слои можно перетаскивать из одного документа в другой.

Откройте файл hats.psd. и расположите два окна с рисунками рядом. Выделите в палитре Слои слой Шляпы и перетащите его мышкой в окно рабочего документа. Закройте файл hats.psd.

Сделайте активным слой Шляпы. Выберите ту шляпу, которая соответствует тени (слой Тень), а остальные удалите инструментом Ластик, включив режим Блок.

Поместите слой Шляпы выше слоя Фигура и "поставьте" шляпу на место. Сохраните файл.

Изображение на активном слое можно редактировать любыми инструментами.

Сделаем так, чтобы правая нога человечка казалась погруженной в воду. Включите инструмент Ластик в режиме Кисть и установите в палитре свойств непрозрачность около 40%. Проведите несколько раз по правой ноге (для нас она будет слева!). Затем передвиньте тень так, чтобы она начиналась от того места, где нога входит в воду.

Откройте файл basket.psd. и перетащите слой с изображением корзины в окно рабочего документа. Поместите этот слой выше слоя Фигура и разместите корзину как на образце end8.psd.

Для того, чтобы выделить все непрозрачные пиксели на слое, надо щелкнуть по нему в палитре Слои при нажатой клавише Ctrl.

Чтобы корзина "висела" естественно, выделите ее и поверните, используйте пункт меню Редактирование — Трансформирование. Аккуратно удалите ластиком ту часть ручки корзины, которая должна быть за рукой.

Для того, чтобы объединить слой с предыдущим, надо нажать клавиши Ctrl+E. Комбинация Shift+Ctrl+E объединяет все видимые слои в один. Если выбрать пункт меню Слой — Выполнить сведение, все слои объединяются в один фоновый слой.

В строке состояния определите размеры рисунка со слоями и без них. Выполните сведение слоев и сохраните файл-результат.

к началу К началу страницы

4. Копирование слоев

В этом примере мы изучим некоторые приемы работы со слоями. Построим симметричный цветок из несимметричного.

Оригинал | Результат

Откройте файл flowers.jpg и сохраните его с расширением PSD.

Определите размеры рисунка в пикселях (Изображение — Размер изображения). Включите инструмент Прямоугольная область [image] и выделите ровно верхнюю половину рисунка. размеры выделенной части можно контролировать в окне Информация (Окно — Инфо, клавиша F8). Также можно установить режим Заданный размер в палитре свойств инструмента и ввести полную ширину и половину высоты в соответствующих полях.

Выделенную часть можно поместить на новый слой двумя способами:

  • скопировать на новый слой (Слой — Новый — Скопировать на новый слой, клавиши Ctrl+J)
  • вырезать на новый слой (Слой — Новый — Вырезать на новый слой, клавиши Shift+Ctrl+J)

Скопируйте выделенную часть на новый слой. Посмотрите, как изменилась палитра Слои (клавиша F7).

Скопируйте новый слой, перетащив его на кнпку [image] в палитре Слои.

Разверните копию вверх ногами. Для этого надо сделать активным самый веръхний слой, выделить все поле (Ctrl+A) и применить команду Редактирование — Трансформирование — Отразить по вертикали.

Если предварительно не выделить всю область рисунка, то отразится только непрозрачная часть и ее потом придется двигать на свое место инструментом Перемещение [image] (или при нажатой клавише Ctrl).

Объедините два верхних слоя, нажав клавиши Ctrl+E.

Таким образом, мы построили рисунок, симметричный относительно горизонтальной оси.

Используя аналогичные приемы, сделайте изображение симметричным также и относительно вертикальной оси. Сохраните результат.

к началу К началу страницы

5. Работа с буфером обмена

Откройте файлы nissan1.psd и nissan2.jpg.

Наша задача — добавить во второй снимок логотип фирмы Ниссан, взяв его с первого изображения.

Оригинал | Результат

Перейдите к изображению nissan1.psd. Включите инструмент Прямоугольная область [image] и выделите логотип.

В Photoshop можно использовать пять команд для работы с буфером обмена (все они находятся в меню Редактирование):

  • Вырезать (клавиши Ctrl+X) — удалить выделенную часть и занести ее в буфер обмена; это место заполняется фоновым цветом (для фонового слоя Задний план) или становится прозрачным (для остальных слоев)
  • Скопировать (клавиши Ctrl+C) занести в буфер обмена изображение с активного слоя, которое попало в выделенную область
  • Скопировать совмещенные данные (клавиши Shift+Ctrl+C) занести в буфер обмена совмещенное (сведенное) изображение со всех видимых слоев, которое попало в выделенную область
  • Вклеить (клавиши Ctrl+V) — вставить рисунок из буфера обмена в центр как отдельный слой
  • Вклеить в (клавиши Shift+Ctrl+V) вставить рисунок из буфера обмена в выделенную область как отдельный слой
В данном случае в палитре Слои видно, что логотип строится из трех связанных слоев, четвертый слой — фон. Чтобы избавиться от фона, временно отключим его и после этого скопируем в буфер обмена совмещенное изображение.

Вызовите на экран палитру Слои (клавиша F7). Отключите фоновый слой (Задний план), щелкнув по значку [image] слева от него.

Скопируйте в буфер обмена логотип, выбрав команду Редактирование — Скопировать совмещенные данные или нажав на клавиши Shift+Ctrl+C.

Перейдите к изображению nissan2.jpg и вставьте логотип из буфера обмена, нажав клавиши Ctrl+V или выбрав команду Редактирование — Вклеить. Используя инструмент Перемещение [image], передвиньте логотип в правый верхний угол.

Щелкнув по кнопке [image] в палитре Слои, добавьте для логотипа эффекты Тень и Глянец, установив параметры на ваш вкус. Сохраните результат в формате PSD.

к началу К началу страницы

6. Корректирующие слои

При коррекции изображений в Теме 4 мы применяли различные операции (корректировку уровней, кривых, яркости и т.п.) непосредственно к пикселям исходного изображения, которое подвергалось преобразованиям. Таким образом, исходная информация искажалась. Иногда это может быть нежелательно, потому что процесс необратим и начать коррекцию с исходного изображения снова не удастся.

Выход из этой ситуации состоит в том, чтобы применить специальный корректирующий слой. Такой слой не содержит изображения, но выполняет некоторую операцию с пикселями изображения под ним: изменяет уровни, кривые, яркость, контраст, цветовые оттенки. Преимущество состоит в том, что исходное изображение на нижнем слое не изменяется и всегда можно начать работу с оригинального рисунка, удалив корректирующие слои.

Для создания корректирующего слоя надо выбрать пункт меню Слой — Новый корректирующий слой или щелкнуть по кнопке [image] в нижней части палитры Слои. Всплывающее меню позволяет применить различные действия.

Откройте файл young.jpg. и сохраните его с расширением PSD.

Оригинал | Результат

В этом рисунке надо скорректировать уровни и цветовые оттенки, сохранив исходное изображение в виде слоя.

Создайте новый корректирующий слой, щелкнув по кнопке [image] в нижней части палитры Слои и выбрав из всплывающего меню вариант Уровни.

Создайте сверху еще один один корректирующий слой типа Цветовой тон/Насыщенность. Установите параметры так, чтобы кожа девочки имела естественный цвет.

Для того, чтобы изменить параметры корректирующего слоя, надо щелкнуть дважды на его иконке в палитре Слои.

Если сначала выделить некоторую область, а потом создать корректирующий слой, его действие будет ограничено этой областью. Со слоем будет связана маска слоя, закрыващая все остальные пиксели.

к началу К началу страницы

 |  | Оглавление |
Инструменты рисования | Назад | В начало | Вперед | Текст


Уроки по Adobe Photoshop CS: текст

Тема 9. Текст

  1. Ввод текста
  2. Параметры
  3. Изменение формы текста
  4. Эффекты

1. Ввод текста

Редактор Photoshop не предназначен для работы с большими текстом, однако позволяет легко делать надписи. Очень удобно, что текст вставляется в виде отдельного слоя в векторном формате, то есть, его можно перемещать и редактировать, как в любом текстовом редакторе, не затрагивая основной рисунок.

Для создания надписей служат четыре инструмента, которые связаны с одной кнопкой и клавишей T:

  • — горизонтальный текст
  • — вертикальный текст
  • — текстовая маска (создание выделенной области, которая повторяет форму текста)
  • — вертикальная текстовая маска
Надо выбрать нужный цвет букв как основной цвет, включить один из этих инструментов, выбрать параметры (шрифт, размер, сглаживание) и ввести текст с клавиатуры. Текст создается в виде отдельного слоя рисунка, это можно посмотреть в палитре Слои. Все текстовые слои обозначаются буквой T.

При использовании текстовых масок новый слой не создается. Действие этих инструментов сводится к тому, что выделяется область, соответствующая тексту. Затем эту область можно залить (например, узором) или изменить ее свойства (тон, яркость и т.п.).

Свойства (параметры) текста можно поменять в любой момент как для всех, так и для некоторых (выделенных) букв с помощью панели свойств.

Чтобы зафиксировать текст, надо нажать клавишу Enter или щелкнуть по кнопке [image] в правой части панели свойств инструмента. Также можно просто выбрать другой инструмент.

Для отмены надо щелкнуть по кнопке [image] или нажать клавишу Esc.

Создайте новый рисунок размером 300 на 300 и добавьте текстовую надпись. Найдите новый слой в палитре слои (клавиша F7).

В редакторе Photoshop можно вводить не только однострочный текст, но и целые абзацы. Для этого надо, включив инструмент Текст, сначала выделить прямоугольник, в котором должен находиться многострочный текст, а затем набирать его. Перенос на другую строку выполняется автоматически, для досрочного перехода надо нажать клавиши Shift+Enter. Размеры и положение ограничивающей рамки можно менять в любой момент.

Создайте многострочный текст на том же рисунке.

к началу К началу страницы

2. Параметры

Параметры текста удобно устанавливать с помощью панели свойств. Это можно сделать заранее (до ввода букв) или потом, когда текст уже введен.

Списки в панели свойств инструмента позволяют выбрать название (гарнитуру) шрифта, его размер и стиль:

  • Regular — обычный
  • Italic — курсив
  • Bold — жирный
  • Bold Italic — жирный курсив
Можно дополнительно усилить жирное и курсивное начертание. Для этого надо выделить нужные символы, вызвать контекстное меню правой кнопкой мыши и выбрать Ложный жирный или Ложный курсив.

Кнопка [image] изменяет направление текста с горизонтального на вертикальный и наоборот. С помощью кнопок [image] можно выбрать выравнивание относительно начальной точки.

Список справа от кнопки [image] в панели инструментов позволяет установить режим сглаживания границы. Первый вариант (Нет) отменяет сглаживание, остальные четыре вводят сглаживание разных типов (они мало отличаются и разницу заметит только специалист).

В панели свойств есть также область, закрашенная цветом текста. Щелкнув по ней, можно выбрать новый цвет для выделенной части надписи.

Редактирование

Для того, чтобы изменить текст или его свойства, надо выбрать соответствующий текстовый слой в палитре Слои, включить инструмент Текст и щелкнуть в области текста на рисунке. Мигающий текстовый курсор говорит о том, что текст можно редактировать, как в текстовом редакторе.

Некоторые свойства (сглаживание границ, выравнивание) меняются сразу для всего слоя, остальные — только для выделенных символов.

Чтобы переместить текст, надо включить инструмент Перемещение [image] или нажать клавишу Ctrl. При этом вокруг текста появляется рамка с маркерами, ее можно перетащить его в нужное место и, сдвигая маркеры, деформировать (менять размеры, вращать и т.п.).

Обложка компакт-диска

Оригинал | Результат

Откройте Обозреватель файлов и перейдите в папку PRACTICE/9. Откройте файл disk.jpg. Сохраните его с расширением PSD. Также откройте файл end_disk.jpg — образец выполнения работы.

Сначала раскрасим черно-белое изображение, используя приемы, изученные в Теме 7.

Используя инструмент Кисть в режиме Цветность и тонирование, раскрасьте цветы так, как показано на образце. Нужный цвет можно выбирать с помощью пипетки прямо в документе end_disk.jpg.

Установите черный фоновый и измените размер рисунка так, чтобы его размеры были 350 на 350 пикселей, причем новая область должна быть добавлена слева (в диалоговом окне надо выбрать щелчком нужный квадрат в поле Расположение).

Используя инструмент Горизонтальный текст, введите название диска Баллады, а с помощью инструмента Вертикальный текст — год выпуска.

С помощью текстовой маски выделите область для надписи Выпуск 1 в правом нижнем углу. Установив нужные параметры текста, нажмите клавишу Enter, чтобы закончить ввод. Увеличьте яркость выделенной область так, чтобы надпись хорошо читалась (Изображение — Коррекция — Яркость/Контрастность).

к началу К началу страницы

3. Изменение формы текста

Простейшие преобразования

Более сложный случай — добавить надпись на фотографию так, чтобы она выглядела естественно. Часто можно обойтись тремя преобразованиями:
  • изменение масштаба
  • поворот
  • наклон
В этом случае можно использовать рамку, ограничивающую текст (она появляется при нажатии клавиши Ctrl). Все изменения выполняются с помощью маркеров этой рамки. Важно, что при этих преобразованиях текст остается в векторной форме, то есть, его можно редактировать.
Оригинал | Результат

Откройте файл roads.jpg. Сохраните его с расширением PSD. Также откройте файл end_roads.jpg — образец выполнения работы.

Используя инструмент Пипетка [image], установите основной цвет такой же, как стрелки на знаке. Добавьте надпись Урюпинск и расположите ее в нужном месте. Чтобы наклонить надпись, при нажатой клавише Ctrl перетащите вниз маркер боковой стороны рамки.

Вызовите на экран палитру Слои (клавиша F7) и скопируйте только что созданный слой, перетащив его на кнопку [image] в палитре Слои. Введите в нем надпись Москва и расположите в нужное место. Сохраните файл.

Растеризация слоя

На следующем рисунке надпись еще сложнее. Левая и правая стороны знака не параллельны друг другу — угол съемки выбран так, что есть искажение перспективы.

Оригинал | Результат

В нынешней версии Photoshop такие искажения невозможно выполнить, не переводя изображение на слое в растровую (точечную) форму из векторной. Эта процедура называется растеризацией слоя. После этого текст нельзя редактировать, он превратился в набор точек.

Откройте файл spb.jpg. Сохраните его с расширением PSD. Также откройте файл end_spb.jpg — образец выполнения работы.

С помощью инструментов ретуши (штамп, лечащая кисть, вставка) удалите надпись на арабском языке.

Используя инструмент Пипетка [image], установите основной цвет такой же, как на рамке вокруг знака (светло-желтый). Добавьте надпись Санкт-Петербург 220 жирным шрифтом Arial размером 32 пункта и примерно расположите ее на знаке.

Перейдите в палитру Слои и выполните растеризацию слоя. Для этого надо нажать на правую кнопку мыли на текстовом слое и выбрать пункт Растеризовать из контекстного меню.

Сделайте слой с текстом активным и выберите пункт меню Редактирование — Произвольное трансформирование.

Удерживайте нажатой клавишу Ctrl — это позволит перемещать маркеры рамки независимо друг от друга. Перемещая маркеры на серединах боковых сторон, установите края надписи в нудные места. Затем, перемещая угловые маркеры, установите правильный наклон левой и правой сторон надписи.

Фигурный текст

В Photoshop есть средства, похожие на фигурный текст в редакторе Word (WordArt). Для их применения надо при редактировании текстового слоя в щелкнуть по кнопке [image] в палитре свойств инструмента. Далее в открывшемся окне можно выбрать нужную форму текста и установить параметры искажения.

Мы рассмотрим достаточно сложную задачу — размещение текста на фарфоровой чашке. Сделать это профессионально непросто, здесь обычно используют специальные фильтры — дополнительные модули, которые могут создавать эффект трехмерного расположения. Однако в простейшем случае можно использовать фигурный текст.
Оригинал | Результат

Откройте файл cup.jpg. Установите основной цвет — темно-серый, взяв его инструментом Пипетка с темного ободка чашки или блюдца.

Выберите инструмент Текст, шрифт Monotype Corsiva, размер 18 пунктов, сглаживание Плавное, выравнивание по центру.

Введите текст "Привет из Питера" в две строки, для перехода на новую строку используйте клавиши Shift+Enter

Щелкните по кнопке [image] в палитре свойств инструмента. Установите искажение Аркой и изгибом около -22. Разместите текст в нужном месте и разверните на нужный угол при нажатой клавише Ctrl. Сохраните результат в виде файла с расширением PSD.

к началу К началу страницы

4. Эффекты

Иногда желательно придать надписи объемный вид, создать тень или применить иной специальный эффект. В современных версиях Photoshop для этого не надо выполнять сложных операций, достаточно присто применить эффекты к текстовому слою. При этом он не переводится в растровую форму и сохраняется возможность редактирования текста.

Оригинал | Результат
В надписи, показанной на рисунке, использованы сразу несколько эффектов:
  • Тень
  • Внешнее свечение
  • Тиснение (объемный вид, в некоторых переводах — Фаска и рельеф)
  • Наложение цвета (золотистый)
Для того, чтобы применить эффекты, надо выбрать нужный слой в палитре Слои и щелкнуть по кнопке [image] в нижней части палитры. Затем остается выбрать один из нужных эффектов в появившемся меню, при этом открывается диалоговое окно, в котором можно включить другие эффекты и настроить их свойства.

Откройте файл mers.jpg. Сохраните его с расширением PSD. Также откройте файл end_mers.jpg — образец выполнения работы.

Добавьте надпись и оформите ее близко к образцу, используя названные эффекты.

 |  | Оглавление |
Многослойные документы | Назад | В начало | Вперед | Маски и каналы


Уроки по Adobe Photoshop CS: маски и каналы

Тема 10. Маски и каналы

  1. Введение
  2. Быстрая маска
  3. Редактирование маски
  4. Использование каналов
  5. Маски слоя

1. Введение

Маски

Маской обычно называют предмет, который закрывает (маскирует) некоторые части лица от наблюдателей. Маски в редакторе Photoshop позволяют защитить от изменений некоторые части изображения. В самом деле, когда мы выделяем область, мы создаем маску, которая защищает все, что не выделено.

В простейшем случае каждый пиксель изображения может быть полностью выделен (открыт для изменений) или невыделен (защищен). В теме Выделение областей мы уже отмечали, что может быть "частичное" выделение — на 50%, на 80% и т.д. Всего может быть 256 градаций, которые кодируются числами от 0 (защищенный пиксель) для 255 (полностью выделен). Считают, что защищенному пикселю соответсвует черный цвет (код 0), а выделенному — белый (код 255). Таким образом, маска может быть закодирована как черно-белое полутоновое изображение.

Каналы

Такие изображения в Photoshop называются каналами. Их можно увидеть, вызвав палитру Каналы (меню Окно — Каналы). В режиме RGB изображение содержит четыре канала — яркости красного, зеленого и синего, а также суммарный канал RGB.

Создайте новое изображение и залейте его градиентом от фиолетового к желтому. Вызовите палитру Каналы.

Известно, что фиолетовый цвет — сумма красного и синего, а желтый — сумма красного и зеленого. Поэтому скорее всего красный канал будет практически белым, синий залит градиентом от белого к черному, а зеленый — наоборот, от черного к белому. Канал RGB — составной, он складывается из красного, зеленого и синего.

Когда мы сохраняем выделенную область, она появляется в палитре Каналы в виде отдельного черно-белого канала. Такие каналы называются альфа-каналами.

Выделите круглую область, установив растушевку 10 пикселей и сохраните ее в канале Альфа. Найдите его в палитре Каналы. Затем удалите новый канал, перетащив его на кнопку [image] в нижней строке палитры.

Преобразуйте рисунок в серый полутоновый (Изображение — Режим — Градации серого), а затем — в битовый (Изображение — Режим — Битовый формат). Наблюдайте, как меняется содержимое палитры Каналы при этих переходах.

к началу К началу страницы

2. Быстрая маска

В Photoshop предусмотрено два режима выделения области, которые переключаются двумя кнопками [image] в нижней части палитры инструментов. Обычно "нажата" левая кнопка — стандартный режим выделения. Однако часто очень удобно редактировать маску как черно-белое изображение, добавляя белым цветом прозрачные области и "закрывая" черным непрозрачные пиксели. Для этого надо перейти в режим Быстрая маска, нажав на правую из этих двух кнопок. Для перехода между двумя режимами выделения можно также использовать клавишу Q.

Откройте Обозреватель файлов и перейдите в папку PRACTICE/10. Откройте файл egret.jpg. Сохраните его с расширением PSD.

Используя инструмент Волшебная палочка с чувствительностью 15-20, выделите (насколько это удастся) тело цапли, добавляя новые области при нажатой клавише Shift. Перейдите в режим быстрой маски.

В этом режиме защищенная часть изображения как бы закрыта полупрозрачной красной пленкой. Рисуя белым цветом, мы удаляем ее, а черным — восстанавливаем. Заметьте, что в палитре Каналы появился новый канал — Быстрая маска.

Включите инструмент Кисть и подправьте маску так, чтобы она более точно выделяла цаплю.

к началу К началу страницы

3. Редактирование маски

Иногда мелкие дефекты маски малозаметны в режиме Быстрая маска, потому что мешает само изображение. Однако их легко заметить и убрать, если оставить на экране только маску как черно-белое изображение.

Чтобы увидеть только маску как черно-белый канал, отключите канал RGB в палитре Каналы. Для этого надо щелкнуть на значке с изображением глаза [image] напротив канала RGB. Теперь окончательно доработайте маску кистью.

Перейдите обратно в стандартный режим выделения и сохраните выделение как альфа-канал с именем Цапля (меню Выделение — Сохранить выделенную область).

к началу К началу страницы

4. Использование каналов

Альфа-каналы

Теперь мы удалим нижнюю часть фона.

Снимите выделение, нажав на клавиши Ctrl+D. Создайте новый канал, щелкнув по кнопке [image] в нижней части палитры Каналы и залейте его градиентом от белого (внизу) к черному) Смените имя нового канала на Градиент. Для этого надо дважды щелкнуть на имени канала и ввести новое имя.

Загрузите выделение из альфа-канала Градиент. Затем загрузите выделение из канала Цапля, выбрав операцию Вычитание из выделенной области. Теперь изменения не затронут цаплю.

Граница выделения соответствует пикселям, которые выделены на 50%. Те, что выделены в большей степени, оказываются внутри области.

Установите белый фоновый цвет и залейте им выделенную часть (меню Редактирование — Выполнить заливку или клавиши Shift+F5).

Обработаем оставшийся фон художественным фильтром Coloured Pencil (Цветной карандаш).

Загрузите выделение из альфа-канала Градиент, отметив флажок Инверсия. То есть, фактически загружается обратное выделение. Затем загрузите выделение из канала Цапля, выбрав операцию Вычитание из выделенной области.

Примените к выделенной части фильтр Фильтр — Имитация — Цветные карандаши, выбрав параметры на свой вкус.

В нижней части рисунка сделайте надпись "Белая цапля", используя шрифт Monotype Corsiva, стиль Ложный жирный (из контекстного меню). Сравните полученный рисунок с образцом end_egret.jpg.

Получение черно-белых изображений

При первом знакомстве с редактором Photoshop (Тема 2) мы научились переводить изображения из цветного режима в черно-белый, выбирая команду меню Изображение — Режим — Градации серого. Однако профессионалы не считают этот вариант лучшим. Выполним ту же операцию, используя режим Lab. Вспомним, что в этом режиме изображение кодируется в виде трех каналов, два из которых — цветовые (каналы a и b), а канал L обозначает светлоту. Именно канал L можно использовать для получения черно-белого варианта рисунка.

Откройте файлы fish.jpg и fish.psd из папки PRACTICE/2. Первый файл — цветной оригинал, а второй — черно-белый вариант, полученный с помощью прямого преобразования режима.

Преобразуйте изображение к модели Lab, выбрав команду Изображение — Режим — Lab. Перейдите в палитру Каналы и удалите канал b, перетащив его на кнопку [image].

Рисунок автоматически был переведен в особый многоканальный режим, в палитре Каналы сейчас два канала: канал Альфа 1 (бывший канал L) и канал Альфа 2 (бывший канал a).

Таким же способом удалите канал Альфа 2. Затем преобразуйте изображение в полутоновое, выбрав пункт меню Изображение — Режим — Градации серого. Сохраните результат под именем fish2.psd.

Аналогично можно строить черно-белое изображение на основе одного из каналов модели RGB, чаще всего зеленого, потому что зеленый цвет примерно соответствует середине видимого спектра.

Для профессиональной настройки используется команда Микширование каналов (или Смешение каналов), которая позволяет не просто выделить один канал, а смешивать разные каналы в нужных пропорциях.

Снова откройте файл fish.jpg из папки PRACTICE/2. Выберите пункт меню Изображение — Коррекция — Микширование каналов. Включите флажок Монохромный (в результате строится монохромное, черно-белое изображение). Отрегулируйте положение движков так, чтобы изображение было наилучшим на ваш вкус. Сохраните его с именем fish3.psd. Сравните все версии черно-белой фотографии.

Оригинал | Градации серого
Канал L | Смешение каналов

к началу К началу страницы

5. Маски слоя

Что это такое?

Редактор Photoshop позволяет вместе с каждым слоем (кроме фона) хранить его маску. Изображение открыто только в тех местах, где пиксели маски — белые. Черные пиксели в маске обозначают закрытое изображение — в этих местах слой считается прозрачным.

Маску слоя удобно применять тогда, когда надо полностью сохранить изображение на слое в файле, но включить в рисунок только его часть.

Корректирующие слои, о которых шла речь в Теме 8, автоматически создаются с маской. Если ничего не было выделено, эта маска полностью белая, то есть, слой воздействуют на весь рисунок. Если в момент создания корректирующего слоя была выделена область, маска откроет только эту область — она ограничивает действие слоя.

Для создания белой маски, которая открывает весь слой, нужно щелкнуть по кнопке [image] в нижней части палитры Слои. Если удерживать нажатой клавишу Alt, создается черная маска, скрывающая все изображение. Эти операции можно выполнить с помощью меню Слой — Маска слоя.

Другой способ создания маски — предварительно выделить нужную область.

Откройте файл sky.jpg. Сохраните его с именем work.psd.

Откройте файл watch.jpg и расположите его окно так, чтобы видеть оба рисунка. Вызовите палитру Слои (клавиша F7) и перетащите слой с часами в первый рисунок. При нажатой клавише Ctrl переместите его в нужное положеие.

С помощью инструмента Лассо выделите часы вместе с частью ремешка. Установите растушевку 10 пикселей (Выделение — Растушевка).

Создайте маску слоя, которая открывает всю выделенную область. Для этого выберите пункт меню Слой — Маска слоя — Открыть выделение.

Теперь рядом с изображением слоя с часами показана маска слоя, которая закрывает часть изображения. Если щелкнуть на левом рисунке, мы будем редактировать изображение на слое, если на правом — маску (черно-белый канал).

Выделите маску слоя и подправьте ее, используя рисование кистью черного и белого цветов. Кисть черного цвета защищает пиксели, белая — открывает их.

Откройте файл comwatch.jpg и перетащите слой с командирскими часами в основной рисунок. При нажатой клавише Ctrl переместите его в нужное положеие.

Выделите циферблат часов с помощью инструмента Овальная область и создайте маску слоя так же, как и раньше.

Новый циферблат больше, чем нужно. Чтобы его уменьшить, примените команду Редактирование — Трасформирование — Масштаб и установите на нужное место.

Обычно маска слоя связана с изображением на этом слое, на это указывает знак "цепочка" между ними. Если щелкнуть на нем, связь разрывается и можно независимо двигать маску и изображение.

Разорвите связь между маской и изображением на каком-нибудь слое и попробуйте переместить их. Затем отмените эти действия.

Операции с маской слоя

Если слой имеет маску, с помошью верхнего меню Слой маску слоя можно
  • выключить (Маска слоя — Отключить) — временно отменить действие маски, в палитре Слои маска перечеркивается красным крестом; чтобы снова включить ее, надо щелкнуть по маске или выбрать пункт меню Слой — Маска слоя — Разрешить
  • удалить, оставив все изображение (Маска слоя — Удалить)
  • удалить, оставив только изображение, открытое маской, а остальные части сделать прозрачными (Маска слоя — Применить)
Эти команды доступны также из контекстного меню, которое появляется при щелчке правой кнопкой мыши по маске в палитре Слои. В контекстном меню также есть команды для выделения области, соответствующей маске слоя. Эту область можно добавить или вычесть из существующего выделения, найти пересечение маски и уже выделенной области.

Группировка слоев

Маска може воздействовать не только на "свой" слой, но и на лежащий выше. Для этого надо сгруппировать их, щелкнув при нажатой клавише Alt на границе между слоями или выбрать пункт меню Слой — Создать обтравочную маску (клавиши Alt+Ctrl+G). Верхний слой при этом смещается вправо в палитре Слои.

Попробуйте перемещать верхний слой с новым циферблатом. Затем сгруппируйте его со средним слоем и повторите перемещение. В чем разница?

Для того, чтобы отменить группировку, надо снова щелкнуть на границе между слоями при нажатой клавише Alt или выбрать пункт меню Слой — Отменить обтравочную маску.

Текст | Назад | В начало | Вперед | Фильтры


Уроки по Adobe Photoshop CS: фильтры

Тема 11. Фильтры

  1. Введение
  2. Коррекция изображений
  3. Художественные фильтры
  4. Специальные фильтры

1. Введение

Фильтр в Photoshop — это специальный алгоритм обработки пикселов, который применяется ко всему изображению или выделенной части.

Фильтры представляют собой файлы специального формата с расширением .8bf. Сама программа содержит несколько десятков стандартных фильтров, кроме того, можно подключать фильтры, разработанные другими фирмами.

Несмотря на разноообразие, на практике используется лишь несколько фильтров. Их можно разделить (очень условно) на 3 группы: фильтры для коррекции изображений, художественные фильтры и специальные фильтры.

Большинство фильтров использует диалоговые окна, в которых можно выбрать параметры и сразу посмотреть результат их применения (для этого надо отметить флажок Просмотр в окне настройки параметров фильтра). Некоторые фильтры не имеют параметров.

Если эффект оказался слишком слабым и действие фильтра надо повторить, достаточно выбрать первый сверху пункт меню Фильтр (в нем будет название последнего примененного фильтра) или нажать клавиши Ctrl+F.

Если наоборот действие фильтра надо ослабить, можно выбрать пункт меню Редактирование — Ослабить или нажать клавиши Shift+Ctrl+F. В этом случае итоговое изображение строится как результат наложения отфильтрованного рисунка (с заданным уровнем непрозрачности) и исходного. Степень непрозрачности устанавливается в диалоговом окне.

к началу К началу страницы

2. Коррекция изображений

Размытие

Одни из самых используемых фильтров — это фильтры, предназначенные для размытия изображения (Фильтр — Размытие или, в некоторых переводах, Смазывание). Чаще всего используются фильтры
  • Размытие по Гауссу (Gaussian Blur) — создает эффект туманности рисунка
  • Размытие в движении (Motion Blur) — имитирует эффект, возникающий на фотопленке при движении объекта
  • Размытие при малой глубине резкости (Lens Blur) — имитирует размытие из-за того, что при съемке часть предметов оказываются не в фокусе объектива камеры
  • Радиальное размытие (Radial blur) — имитирует размытие при съемке вращающейся камерой

Резкость

Фильтры группы Резкость для повышения резкости изображения уже использовались нами в Теме 5:
  • Резкость (Sharpen)
  • Резкость+ (Sharpen More)
  • Резкость на краях (Sharpen Edges)
  • Краевая резкость (Unsharp Mask) — имитирует процесс, который раньше применялся в фотографии для повышения резкости

Шум

Из группы Шум чаще всего применяют два фильтра
  • Добавить шум — для придания материалу неровности
  • Пыль и царапины — для борьбы с мелкими дефектами
Мы уже использовали раньше фильтр Пыль и царапины (см. Тему 5), однако видели, что изображение при этом несколько размывается, сглаживается, теряет резкость. Для того, чтобы не размывать все изображение, мы использовали инструмент Архивная кисть и копировали только нужные области. Использование новых средств, изученных после Темы 5, дает возможность использовать еще два новых способа решения этой задачи.

Способ 1. Сначала выделяем область с дефектами, затем применяем к ней фильтр Пыль и царапины. Так делаем для всех нужных областей. Этот способ имеет два недостатка. Во-первых, большой объем работы (дефектных областей может быть много). Кроме того, изображение вокруг дефекта все равно размывается.

Способ 2. Идея состоит в том, чтобы ниже рабочего слоя создать его копию и к этой копии применить фильтр Пыль и царапины. Затем инструментом Ластик надо аккуратно стереть часть верхнего слоя с дефектом — в верхнем слое образуется брешь, сквозь которую просвечивает обработанное (размытое) изображение. Таким образом, мы используем обработанный фильтром рисунок только там, где были дефекты. В конце работы слои объединяются.

Откройте Обозреватель файлов и перейдите в папку PRACTICE/11. Откройте файл oldphoto.jpg и сохраните результат с расширением PSD.

Скопируйте фоновый слой, перетащив его в палитре Слои на кнопку [image] в нижней части палитры.

Отключите копию фона (верхний слой), щелкнув по значку с изображением глаза. Затем выделите нижний слой и примените к нему фильтр Пыль и царапины, установив параметры так, чтобы все мелкие дефекты исчезли.

Включите верхний слой и сделайте его активным (выделите щелчком мыши). Выберите инструмент Ластик [image], форму Кисть небольшого радиуса (5-10 пикселей). Аккуратно сотрите все места с дефектами, чтобы через них проступил нижний размытый слой. Отключите нижний слой в палитре слои и убедитесь, что в этих местах образовались "дырки".

Снова включите нижний слой и объедините слои (Слой — Выполнить сведение). Сохраните результат.

Освещение

Фильтры, связанные с освещением, собраны в группе Рендеринг. Наиболее важны два из них:
  • Блик (Lens Flare) — моделирует блик на металлических поверхностях при освещении
  • Эффекты освещения (Lighning Effects) — мощный фильтр, который позволяет "осветить" нужную часть изображения, выбрав характеристики источника света и материала, создать рельеф (объемность).
В следующем примере мы заменим фон на портрете и с помощью фильтра Эффекты освещения сделаем его рельефным.

Оригинал | Результат

Откройте файл kush.jpg и сохраните его с расширением PSD.

Выделите фон вокруг головы с помощью инструмента Волшебная палочка с чувствительностью 20. Выделить точно не удалось, поэтому надо подправить выделение в редиме Быстрая маска (клавиша Q).

Преобразуйте фоновый слой в обычный (Слой — Новый — Из заднего плана) и удалите выделенную область, сделав ее прозрачной.

Создайте новый слой ниже существующего. Откройте рисунок с узором leaves.jpg и определите новый узор заливки, выбрав пункт меню Редактирование — Определить узор. Закройте файл leaves.jpg.

В основном изображении выделите весь нижний слой и залейте его только что созданным узором. Для этого используется команда Редактирование — Выполнить заливку (клавиши Shift+F5). В поле Использовать в окне параметров надо выбрать вариант Узор, а затем в списке образцов найти нужный (он будет последним).

Этот узор будет служить картой высоты поверхности: белый области соответствуют самым высоким точкам, а черные — самым низким.

Для того, чтобы переходы были плавные, примените к этому слою фильтр Смазывание Гаусса с радиусом около 3 пикселей. Далее с помощью команды Изображение — Коррекция — Яркость/Контрастность надо увеличить до предела яркость и уменьшить контраст (примерно до -70).

Выберите фильтр Рендеринг — Эффекты освещения.

В левой части виден слой, к которому применяется эффект. Окружность обозначает область действия света. Ее центр и еще четыре точки на окружности можно сдвигать мышкой, изменяя место и радиус действия источника.

В правой части есть три группы элементов управления (каждая обведена в рамку): свойства источника света, свойства материала и карта высоты. Движок Intensity регулирует интенсивность света, квадратик справа позволяет выбрать цвет источника света (его можно изменять, щелкнув дважды на квадрате).

Установите желтый цвет источника и выберите его интенсивность. В левой части окна установите центр и размеры зоны действия света так, чтобы она охватывала весь слой.

В окне Texture Channel можно выбрать любой из существующих каналов, включая альфа-каналы. Этот канал задает карту высот — рельеф поверхности. Для серого изображения, как у нас, красный, зеленый и синий каналы одинаковы, поэтому можно выбирать любой из них. Если выбран вариант None (Никакой), изображение освещается как плоская пластинка.

Флажок White is high означает, что белый цвет соответствует самым высоким точкам. Движок Height регулирует высоту рельефа.

Выберите зеленый канал в качестве карты высот и подберите высоту на ваш вкус. Примените фильтр и сохраните результат.

к началу К началу страницы

3. Художественные фильтры

Для художественной обработки фотографий служат многочисленные фильтры, входящие в группы
  • Имитация (Artistic)
  • Штрихи (Brush Strokes)
  • Искажения (Distort)
  • Эскиз (Sketch)
  • Стилизация (Stylize)
  • Текстура (Texture)
Самый удобный способ их применения — вызвать Галлерею фильтров (Фильтр — Галлерея фильтров), которая позволяет настроить параметры фильтра, сразу увидеть результат, а также применить последовательно несколько фильтров. Заметим, что в галлерее есть не все фильтры, входящие в меню Photoshop.

Откройте Обозреватель файлов и перейдите в папку PRACTICE/11. Откройте файл comwatch.jpg. Примените к нему фильтр Имитация — Целлофановая упаковка (Artistic — Plastic Warp), параметры настройте по вкусу. Сохраните результат с расширением PSD.

В Photoshop включено много фильтров, который имитируют разные технологии рисования: (набросок, акварель, масляные краски).

Оригинал | Перо | Акварель | Масло | Барельеф

Откройте файл girl.jpg. Примените к нему фильтр Эскиз — Перо (Sketch — Graphic Pen).

Восстановите сохраненное изображение (меню Файл — Вернуть или клавиша F12) и примените к нему фильтр Имитация — Акварель (Artistic — Watercolor).

Восстановите сохраненное изображение и примените фильтр Имитация — Масляная живопись (Artistic — Paint Daubs).

Восстановите сохраненное изображение и примените фильтр Эскиз — Рельеф (Sketch — Bas Relief).

к началу К началу страницы

4. Специальные фильтры

Cжижение

Фильтр Пластика (или Cжижение, Liquify, клавиши Shift+Ctrl+X) делает изображение "жидким" и "тягучим". После этого с помощью специальных инструментов можно искажать рисунок, размазывая и сдвигая его части. Этот фильтр идеально подходит для создания карикатур и шаржей.

Извлечение объекта

Мощный фильтр Извлечь (Extract, клавиши Alt+Ctrl+X) предназначен для выделения из рисунка сложного объекта, например, животного с густой шерстью или птицу с перьями.

Идея состоит в том, чтобы сначала кистью обвести контур (достаточно широкий), где находится граница объекта и фона, а потом залить внутреннюю область. Программа автоматически будет искать границу в отмеченной зоне и убирает весь фон вокруг объекта.

Откройте файл cat.jpg. Сохраните его с расширением PSD.

В этом изображении надо заменить фон так, как показано на рисунке.

Оригинал | Результат

Для этого надо извлечь из рисунка кошку, а затем построить новый фоновый слой.

Вызовите диалоговое окно фильтра Извлечь (клавиши Alt+Ctrl+X).

На левой стороне диалогового окна расположены инструменты:

  • Маркер края (Edge Highlighter, клавиша B) [image] для выделения полосы, ограничивающей объект
  • Заливка (Fill, клавиша G) [image] для того, чтобы залить контур, нарисованный кистью
  • Ластик (Eraser, клавиша E)
  • Увеличение (Zoom, клавиша Z)
  • Рука (Hand, клавиша H)

Установите в правой части окна размер кисти (Brush Size) около 30 пикселов и обведите полосу, ограничивающую кошку, включая шерсть. Выберите инструмент Заливка и залейте внутреннюю часть контура.

Стандартно контур будет выделяться зеленым цветом, а заливка — синим, хотя эти цвета можно поменять. При включенном флажке Smart Highlight (умное выделение) программа сама определяет границу объекта и выбирает оптимальную ширину кисти.

После щелчка по кнопке Просмотр (Preview) мы увидим результат автоматического выделения объекта. При этом становятся активными две кнопки в панели инструментов, которые используются для окончательной подчистки результатов выделения:

  • Cleanup [image] — инструмент, позволяющий стереть кистью ненужные части изображения или, при нажатой клавише Alt, добавить фрагменты к выделенной части; размер кисти можно увеличивать и уменьшать клавишами [ и ].
  • Edge Touchup [image] — инструмент, позволяющий сгладить "рваные" границы выделенной части. Курсор мыши принимает форму перекрестья, которым надо провести по границе.

Клавищи Ctrl+Z позволяют в любой момент отменить последнюю выпоненную операцию, в том числе и выделение изображения по кнопке Просмотр. Если надо восстановить рисунок в исходное состояние, не выходя из окна фильтра, нужно нажать клавишу Alt и щелкнуть по кнопке Reset (она появляется на месте кнопки Cancel).

Щелчок по кнопке ОК фиксирует результат, кнопка Cancel отменяет действие.

Добейтесь нужного результата и выделите кошку.

Теперь кошка окружена прозрачной областью.

Откройте файл back.jpg и перебросьте изображение из палитры Слои в рабочий документ. Расположите новый слой ниже слоя с кошкой.

Выделите текстуру, щелкнув по слою в палитре Слои при нажатой клавише Ctrl. Выберите пункт меню Редактирование — Трансформирование — Масштаб и растяните фон на всю верхнюю часть рисунка.

Таким же способом вставьте текстуру из файла back2.jpg и растяните ее на всю нижнюю часть фона. Объедините все видимые слои (Shift+Ctrl+E).

Используя фильтр Рендеринг — Эффекты освещения, подберите освещение так, чтобы свет падал сверху слева. Сохраните результат.

 |  | Оглавление |
Маски и каналы | Назад | В начало | Вперед | Иллюстрации для Интернета


Уроки по Adobe Photoshop CS: иллюстрации для Интернета

Тема 12. Иллюстрации для Интернета

  1. Введение
  2. Рисунки с палитрой (GIF, PNG)
  3. Рисунки JPEG
  4. Изображения с прозрачными областями
  5. Изображения из фрагментов

1. Введение

Последние версии Photoshop включают средства для оптимизации изображений, размещаемых в Интернет. Чтобы ускорить загрузку Web-страниц, надо пытаться в первую очередь уменьшать размеры рисунков на ней, пока их качество остается удовлетворительным.

Очень важно правильно выбрать формат рисунка в зависимости от типа изображения. Вспомним, что форматы GIF и PNG-8 могут хранить только изображения с палитрой от 2 до 256 цветов, а полноцветные рисунки записываются в форматах JPEG и PNG-24.

Если полноцветное изображение сохраняется c палитрой (GIF или PNG-8) и содержит больше цветов, чем есть в палитре, программа использует так называемый дизеринг (dithering) — цвета, отсутствующие в палитре, заменяются узором из пикселей других цветов, которые в палитре есть.

Пусть нам надо разместить на Web-странице кнопку [image]. Попробуем сохранить ее в разных форматах и сравнить качество рисунка и объем файла.

Формат | Размер | Качество
GIF, 8 цветов | 212 байт | хорошее
GIF, 16 цветов | 257 байт | лучшее
PNG-8, 8 цветов | 256 байт | хорошее
PNG-8, 16 цветов | 303 байт | лучшее
PNG-24 | 526 байт | лучшее
JPEG, качество 0 | 468 байт | плохое
JPEG, качество 50% | 684 байт | плохое
JPEG, качество 100% | 1384 байта | лучшее

Теперь сохраним в разных форматах фотографию девушки.

Вот что получается:
Формат | Размер | Качество
GIF, 32 цвета | 5,91 Кб | низкое
GIF, 128 цветов | 10,43 Кб | хорошее
GIF, 256 цветов | 13,40 Кб | хорошее
PNG-8, 32 цвета | 5,56 Кб | низкое
PNG-8, 128 цветов | 9,41 Кб | хорошее
PNG-8, 256 цветов | 12,25 Кб | хорошее
PNG-24 | 31,09 Кб | лучшее
JPEG, качество 0 | 1,90 Кб | плохое
JPEG, качество 50% | 5,82 Кб | хорошее
JPEG, качество 100% | 19,17 Кб | лучшее

Таким образом, рекомендуется использовать

  • форматы GIF или PNG-8 для
    • мелких изображений
    • рисунков с четкими границами
    • рисунков с прозрачными областями
    • черно-белых (двуцветных) рисунков
  • формат JPEG для
    • фотографий
    • размытых изображений
    • рисунков с градиентом

к началу К началу страницы

2. Рисунки с палитрой (GIF, PNG)

Окно сохранения

Откройте Обозреватель файлов и перейдите в папку PRACTICE/12. Откройте файл africa.psd.

Заметим, что это изображение содержит всего несколько различных цветов, поэтому для размещения в Интернете его следует сохранять в форматах GIF или PNG-8.

Выберите пункт меню Файл — Сохранить для Web (клавиши Alt+Shift+Ctrl+S).

В левой части специального диалогового окна сохранения выводится оптимизированный рисунок, который будет сохранен. Окно содержит четыре вкладки:
  • Original — только исходное изображение
  • Optimized — только оптимизированное изображение, готовое для сохранения
  • 2-Up — исходное и оптимизированное изображения
  • 4-Up — исходное и три варианта оптимизированных изображений с разными параметрами
Правую часть занимают элементы, позволяющие настроить параметры сохранения. В первую очередь надо отметить палитру Image Size (размер изображения). С ее помощью можно уменьшить размеры при выводе, при этом размеры рисунка, редактируемого в Photoshop, останутся без изменений. Для того, чтобы применить новые размеры, служит кнопка Apply.

В верхней части находится палитра для выбора формата файла.

Список, отмеченный цифрой 1, служит для выбора формата файла. Параметр Lossy задает допустимые потери при сжатии изображения (от 0% до 100%).

Палитра

В поле Colors надо выбрать количество цветов в палитре (от 2 до 256), при увеличении этого числа качество повышается, но размер файла увеличивается. Надо выбирать предельно малое число цветов, при котором изображение выглядит удовлетворительно.

Список, отмеченный цифрой 2, определяет, как выбираются цвета в палитре:

  • Перцепционная (Perceptual) — в первую очередь выбираются цвета, которые лучше воспринимаются человеческим глазом
  • Селективная (Selective) — преимущество в палитре отдается тем цветам, которые охватывают большие непрерывные области
  • Адаптивная (Adaptive) — в первую очередь выбираются цвета, которые встречаются чаще всего
  • Ограниченная (Web) (Restrictive (Web)) — используются только цвета из безопасной Web-палитры, которую браузеры не искажают
В левом нижнем углу окна можно увидеть размер файла в выбранном формате. Посмотрите, как он изменяется при изменении количества цветов в палитре.

Дизеринг

Поле Dither задает степень дизеринга при замене цветов, отсутствующих в палитре — применяется или нет узорная заливка. При значении 100% дизеринг применяется везде, при значении 0% отсутствующие цвета просто заменяются ближайшими из палитры. Список, отмеченный цифрой 3, определяет, каким методом будут заменяться цвета, отсутствующие в палитре (чаще всего используется Diffusion — взаимопроникновение пикселей двух цветов). Для рисунков с переходами цветов лучше использовать дизеринг.

Дизеринг 0% | Дизеринг 100%

Прозрачность

Флажок Transparency показывает, сохранять ли прозрачные пиксели рисунка. Если он установлен, прозрачность сохраняется, если нет — прозрачные пиксели заливаются цветом, который выбран в поле Matte.

Список, отмеченный цифрой 4, определяет, как обрабатываются полупрозрачные пиксели. Если выбран вариант No Transparency Dithering, пиксели с прозрачность менее 50% считаются полностью прозрачными, а для остальных цвет определяется как смешивание цвета изображения и цвета, выбранного в поле Matte. При любом другом варианте создается узор из прозрачных и непрозрачных пикселей так, чтобы имитировать полупрозрачное изображение.

Установите формат GIF и режим 16 цветов в поле Color. Сохраните файл. Сравните размеры исходного и нового файлов.

к началу К началу страницы

3. Рисунки JPEG

Откройте файл hands.psd.

Это полутоновое (серое) изображение с плавными переходами. Поэтому его следует сохранить в формате JPEG.

Выберите пункт меню Файл — Сохранить для Web (клавиши Alt+Shift+Ctrl+S). Выберите формат JPEG.

В формате JPEG изображение сжимается с потерями с помощью специальных алгоритмов. В поле Quality задается качество изображения в процентах. Кроме того, в списке под полем формата можно выбрать часто используемые варианты от Low (низкое, 0%) до Maximum (максимальное, 100%).

Установите качество Medium и сохраните файл.

Если установлен флажок Progressive, изображение в окне браузера будет появляться постепенно (сначала грубое, потом качество постепенно будет улучшаться).

Параметр Blur обозначает степень дополнительного размытия изображения. При увеличении размытия размер файла уменьшается.

Откройте файл lion.psd. Выберите формат JPEG, качество 60% и размытие около 0,2. Сохраните файл.

Откройте файл economy.psd. Выберите нужный формат и параметры так, чтобы сохранить качество и максимально уменьшить размер изображения. Сохраните файл.

к началу К началу страницы

4. Изображения с прозрачными областями

Программа Photoshop позволяет обрабатывать рисунки с прозрачными областями. Для размещения в сети Интернет их надо сохранять в форматах GIF или PNG, которые поддерживают прозрачность. Прозрачные области обозначаются "шахматкой" — клетчатым фоном, в котором чередуются серые и белые квадраты, как на шахматной доске.

Мы уже знаем, что фоновый слой — всегда непрозрачный. Поэтому для получения изображения с прозрачными областями этот слой надо удалить или преобразовать в обычный слой (Слой — Новый — Слой из фона или двойной щелчок по нему в палитре Слои).

Для стирания ненужных областей до прозрачных используют инструменты группы Ластик (клавиша E).

  • Ластик (Eraser) [image] — на любом слое, кроме фонового, стирает пиксели — делает их прозрачными
  • Стиратель фона (Background Eraser) [image] — при стирании на фоновом слое преобразует его в обычный и устанавливает фоновым цветом цвет пикселя, на котором щелкнули. Стирает пиксели до прозрачного состояния. Параметр Дискретизация (Sampling) на панели параметров может принимать значения
    • Непрерывная (Continuous) — удаляется тот цвет, который находится под курсором
    • Одиночная (Once) — удаляется тот цвет, который находился под курсором в начале движения кисти
    • Образец фона (Background Swatch) — удаляется фоновый цвет
  • Волшебный ластик (Magic Eraser) [image] — выделяет пиксели, как Волшебная палочка, и сразу делает их прозрачными. Если применяется к фоновому слою, автоматически преобразует его в обычный слой.

Откройте файл butterfly.psd. Включите инструмент Стиратель фона и попробуйте стереть белый фон вокруг бабочки.

Включите инструмент Волшебный ластик, установите чувствительность 20 и щелкните по белой области вокруг бабочки. Не устанавливайте флажок Не грубо, иначе будут стерты усы!

Белый фон должен быть удален, вокруг бабочки появляется "шахматка", обозначающая прозрачные области.

Проверим, как будет выглядеть рисунок на зеленом фоне.

Вызовите палитру Слои (клавиша F7) и создайте новый слой, щелкнув по кнопке [image]. Перетащите этот слой ниже слоя с бабочкой и залейте его светло-зеленым цветом. Для этого надо установить этот цвет основным и применить заливку (Редактирование — Залить или клавиши Shift+F5).

Можно заметить, что из-за неточности выделения вокруг бабочки образовались светлые пиксели, которые надо удалить.

Верните изображение в исходное состояние, нажав клавишу F12. Повторите сделанные операции, установив чувствительность инструмента Волшебный ластик равную 80.

Результат улучшился, но светлая кайма вокруг бабочки по-прежнему сохраняется. Попробуем использовать специальную команду, предназначенную для удаления каймы вырезанного объекта на отдельном слое.

В палитре Слои сделафйте активным слой с бабочкой и снимите выделение (клавиши Ctrl+D). Примените команду Слой — Обработка краев — Устранить кайму.

Теперь бабочка на зеленом фоне выглядит хорошо и можно сохранять изображение.

Удалите фоновый слой, перетащив его на кнопку [image] в палитре Слои.

Выберите пункт меню Файл — Сохранить для Web (клавиши Alt+Shift+Ctrl+S). Выберите формат GIF и установите флажок Transparent. Определите нужное число цветов в палитре и сохраните файл.

к началу К началу страницы

5. Изображения из фрагментов

Введение

При разработке дизайна Web-страниц чаще всего страница сначала рисуется целиком в графическом редакторе, например в Photoshop, а потом "режется на куски". Каждый такой фрагмент (slice) будет храниться в виде отдельного файла. Это дает несколько преимуществ:
  • маленькие файлы бастрее загружаются
  • для каждого фрагмента можно использовать оптимальные для него формат и параметры: например, один фрагмент удобнее сохранять в формате GIF, а другой — в JPEG
  • каждый фрагмент может служить гиперссылкой ссылкой на отдельный докмент
  • при создании анимационных рисунков можно ограничить область анимации: например, у автомобиля может мигать только фара, а остальная часть будет обычными рисунками, это уменьшает объем файлов) документ

В Photoshop есть специальные инструменты для работы с такими фрагментами:

  • Раскройка [image] позволяет "разрезать" рисунок на части
  • Выбор фрагмента [image] служит для перемещения и изменения границ фрагментов
Эти инструменты связаны с одной и той же кнопкой и вызываются по клавише K.

Порядок работы с "разрезанными" изображениями таков:

  • разделить рисунок на фрагменты с помощью инструмента Раскройка, для точного размещения можно использовать направляющие — специальные линии разметки
  • если нужно, передвинуть фрагменты и изменить их размеры с помощью инструмента Выбор фрагмента
  • настроить свойства каждого фрагмента: имя файла при сохранении, гиперссылку, всплывающую подсказку и т.д.
  • сохранить рисунок как Web-страницу: HTML-файл и набор файлов, гда хранятся фрагменты изображения

Как разрезать изображение?

Откройте файл menu.jpg и сохраните его в формате PSD.

Если на верхней и левой сторонах рисунка нет линеек с делениями, выберите пункт меню Просмотр — Линейки. Нажмите левую кнопку мыши на верхней линейке и, не отпуская мышь, вытащите направляющую горизонтальную линию в поле рисунка, установите ее между первым и вторым блоками меню. Еще две направляющих нужны для разделения остальных блоков.

Направляющие могут быть вертикальные и горизонтальные. Для того, чтобы переместить направляющую, надо перетащить ее при нажатой клавише Ctrl или включив инструмент Перемещение [image]. Если вытащить направляющую за пределы рисунка, она удаляется.

Для того, чтобы границы выделения "прилипали" к направляющим и краям, выберите пункт меню Просмотр — Привязать к — Направляющим, а затем — Просмотр — Привязать к — Границам документа.

Включите инструмент Раскройка и обведите прямоугольниками каждый из четырех блоков.

В левой верхнем углу каждого фрагмента выводится его номер и значок, показываюшщий тип фрагмента. Мы будем работать пока только с одним типом — фрагмент-рисунок.

Настройка фрагментов

Теперь с помощью инструмента Выбор фрагмента можно выбрать фрагмент, который нужно изменить, вокруг него появляется рамка с маркерами. Фрагмент можно перетащить мышкой или изменить его размеры. Если при этом остается свободное место, программа автоматически создает новые фрагменты так, чтобы все изображение было разбито на прямоугольники. Номера и значки таких авто-фрагментов выводятся серым цветом.

Включите инструмент Выбор фрагмента и попробуйте изменить границы какого-нибудь фрагмента. Затем отмените эти действия.

Для каждого фрагмента можно установить параметры:

  • имя файла, в котором он будет сохранен
  • адрес гиперссылки (URL), если фрагмент ссылается на другой документ
  • имя окна (фрейма), в котором открывается новый документ
  • надпись, которая появляется в строке состояния при наведении мыши
  • текст всплывающей подсказки
Для того, чтобы вывести на экран окно параметров, надо щелкнуть дважды на нужном фрагменте при выбранном инструменте Выбор фрагмента или выбрать пункт Редактировать свойства фрагмента из контекстногом меню (правая кнопка мыши на нужном фрагменте).

Установите параметры для всех фрагментов подобно тому, как показано на рисунке ниже для фрагмента 1.

Сохранение

Выберите пункт меню Файл — Сохранить для Web.

В окне сохранения можно задать отдельные параметры сохранения для каждого фрагмента (формат файла, количество цветов в палитре, степень сжатия и т.д.). Для этого надо включить инструмент Выбор фрагмента (уже в окне сохранения) и щелкнуть на нужном фрагменте. В левом нижнем углу показан размер файла для этого фрагмента, а в правой можно установить параметры сохранения.

Установите разные параметры сохранения для каждого фрагмента.

После нажатия на кнопку ОК в списке Тип файла выберите вариант HTML and Images и сохраните документ с именем menu.html.

При таком сохранении создается HTML-файл и связанные с ним рисунки (каждый фрагмент записывается в отдельный файл). Все рисунки помещаются в подкаталог images. На Web-странице фрагменты помещаются в таблицу вплотную друг к другу так что между ними не остается зазора и изображение кажется цельным. Однако учтите, что "швы" могут стать заметны, если для сохранения фрагментов используются разные параметры (например, один сохраняется с палитрой 16 цветов, а второй — как черно-белый рисунок).

Откройте файл menu.html в браузере. Проверьте работу всплывающих подсказок и изменение строки состояния. Просмотрите код Web-страницы, выбрав пункт Просмотр HTML-кода из контекстного меню.

Поскольку рисунок является ссылкой на другой документ, Photoshop почему-то вставляет команды изменения строки состояния в тэг <A>, а не в тэг <IMG>. Поэтому в строке состояния большинства браузеров отображается адрес перехода, а не введенный нами текст. Если исправить эту ошибку (переставить команды в тэг <IMG>), все работает правильно.

Фильтры | Назад | В начало | Вперед | Анимация в Image Ready


Уроки по Adobe Photoshop CS: анимация в Image Ready

Тема 13. Анимация в Image Ready

  1. Введение
  2. Анимация по слоям
  3. Ручная настройка кадров
  4. Промежуточные кадры
  5. Реакция на события мыши

1. Введение

Вместе с программой Photoshop поставляется вторая программа — Image Ready, которая специально разработана для подготовки иллюстраций, размещаемых в Интернете. Когда мы сохраняли рисунки на прошлом уроке, мы использовали именно ее возможности.

Две программы очень хорошо взаимодействуют между собой и понимают формат PSD. Работая с изображением, можно быстро переключаться из Photoshop а Image Ready и обратно, нажав на клавиши Ctrl+Shift+M (или через меню Файл — Редактировать в Image Ready).

Программа Image Ready позволяет создавать анимированные ("оживленные") рисунки. Они строятся по очень простому принципу: в файле хранятся несколько изображений одинакового размера. Они сменяют друг друга через заданные промежутки времени. За счет этого можно показывать движение объектов.

Надо учитывать, что для того, чтобы движение было более плавным, нужно увеличивать количество кадров, но при этом обязательно увеличивается и размер файла. Так что на практике необходим компромисс между качеством анимации и размером файла.

к началу К началу страницы

2. Анимация по слоям

Анимация в Image Ready основана на использовании многослойной структуры документа. В простейшем случае надо построить многослойный рисунок, в котором каждый слой будет соответствовать кадру.

Запустите программу Image Ready и откройте файл flags.psd в папке PRACTICE/13. Вызовите палитру Слои (клавиша F7).

Изображение в этом файле имеет 4 слоя, которые показывают различные положения рук матроса-сигнальщика, передающего сообщение с помощью флажного семафора.

Проверьте, видима ли палитра Animation. Если нет, выберите пункт меню Window — Animation или нажмите клавишу F11.

В этой палитре отображаются кадры и настраиваются их свойства. Сейчас есть всего один кадр, то есть никакой анимации нет.

Щелкните по кнопке [image] на палитре Animation и выберите команду Сделать кадры из слоев (Make Frames from Layers).

Для просмотра анимации нажмите на кнопку [image] на панели Animation.

В основном окне документа сейчас можно увидеть, что матрос очень быстро двигает руками, так что невозможно что-либо понять. Дело в том, что по умолчанию устанавливается нулевое время смены кадров, то есть компьютер меняет кадры с максимальной скоростью.

Остановите просмотр, щелкнув по кнопке [image]. Выделите все кадры. Для этого надо щелкнуть на первом кадре и затем, удерживая клавишу Shift, на последнем (как в Проводнике!).

Можно также добавлять и исключать из выделения отдельные кадры, щелкая по ним в палитре Animation при нажатой клавише Ctrl. Для перехода по кадрам служат кнопки [image] (назад) и [image] (вперед). Кнопка [image] позволяет перейти к первому кадру.

Щелкните мышкой ниже любого выделенного кадра в той области, где показано время отображения кадра и выберите время 1 секунда (для всех выделенных кадров). Снова запустите анимацию и сравните результат с тем, что было.

Для каждого кадра можно установить собственное время.

Выделите щелчком последний кадр (паузу) и установите время 2 секунды. Проверьте, что изменилось.

Кадры можно менять местами, перетаскивая их мышкой в палитре Animation. Если перетащить кадр на кнопку [image], он удаляется.

Измените порядок кадров так, чтобы матрос передал сообщение "Мир" вместо "Рим".

В левой части палитры Animation можно выбрать варианты Forever (анимация работает постоянно) или Once (один раз).

Анимация может быть сохранена в нескольких форматах. Для размещения на Web-страницах чаще всего используют формат GIF, поддеживающий анимацию (File — Save Optimized As...), или формат Macromedia Flash (SWF) (File — Export — Macromedia Flash). Для того, чтобы задать параметры сохраняемого изображения (количество цветов, дизеринг) используют палитру Optimize (Windows — Optimize), где можно установите все те же свойства, как и при сохранении файлов для Интернет из программы Photoshop.

Вместе с основным файлом можно сохранить и простейшую Web-страницу в формате HTML, которая позволит просмотреть анимацию в браузере. Для этого в окне сохранения в списке Тип файла надо выбрать HTML and Images.

Сохраните файл в формате GIF. Посмотрите, как будет выглядеть файл на Web-странице, выбрав команду File — Preview in — iexplore (клавиши Ctrl+Alt+P).

к началу К началу страницы

3. Ручная настройка кадров

Как мы видели, в простейшем случае каждый слой соответствует одному кадру анимации. Однако в Image Ready для каждого кадра можно можно выбрать несколько слоев, которые видимы в данный момент.

Откройте в программе Image Ready файл house.psd из папки PRACTICE/13. Вызовите на экран палтиру Слои (клавиша F7).

В этом файле несколько слоев: фон и части дома (фундамент, стены, ...). Мы построим анимацию, изображающую строительство. Сначала появляется фундамент, через некоторое время — стены и т.д.

Перейдите к палитре Animation (F11) и создайте 5 новых кадров, щелкая по кнопке [image].

Уже знакомая нам кнопка [image] удаляет выделенные слои.

Выберите первый кадр и отмените в палитре Слои видимость всех слоев, кроме фона.

На всех остальных слоях также остался только фон. Теперь мы подключим нужные слои для каждого кадра.

Выделите второй кадр и подключите слой Фундамент. Для третьего кадра надо сделать видимым еще слой Стены и т.д.

Установите для всех кадров время показа 0,5 секунды, а для последнего — 2 секунды, чтобы можно было посмотреть на результат.

Проверьте, как работает анимация, и сохраните файл в формате GIF.

Программа Image Ready может напрямую редактировать анимированные файлы формата GIF.

Закройте рабочий документ и откройте только что сохраненный файл house.gif.

Обратите внимание на палитру Слои — при сохранении в формате GIF все видимые слои для каждого кадра были объединены, так что теперь каждый кадр соответствует отдельному слою.

к началу К началу страницы

4. Промежуточные кадры

В программе Image Ready есть возможность построить автоматически промежуточные кадры между существующими для создания более плавной анимации. При этом надо учитывать, что добавление новых кадров увеличивает размер файла.

Запустите Photoshop и откройте файл valaam.jpg в папке PRACTICE/13 и сохраните его в формате PSD. С помощью инструмента Текст [image] добавьте в нижней части надпись "Валаам". Щелкнув по кнопке [image] в палитре Слои, установите эффекты слоя на ваш вкус.

Перейдите в программу Image Ready, щелкнув по кнопке [image] в нижней части палитры инструментов или выбрав пункт Файл — Редактировать в Image Ready (клавиши Shift+Ctrl+M).

В палитре Animation один кадр. Анимация, которую мы хотим построить, заключается в том, что надпись "Валаам" постепенно появляется, перемещаясь от линии горизонта вниз.

Передвиньте надпись "Валаам" на линию горизонта. Создайте новый кадр, щелкнув по кнопке [image] в палитре Animation.

Каждый кадр можно настраивать отдельно от других. Настройка состоит в том, что можно сделать видимыми любые слои (а не только один, как раньше) и настроить их свойства, например, положение текста, прозрачность и эффекты.

Выделите первый кадр. Перейдите в палитру Слои и сделайте надпись прозрачной, установив непрозрачность (Opacity) 0%.

Выделите второй кадр и установив непрозрачность текстового слоя 100%. Передвиньте текст в нижнюю часть рисунка.

Выделите оба кадра и установите время показа 0,2 секунды. Посмотрите, как работает анимация.

Теперь добавим промежуточные кадры.

Выделите первый кадр и щелкните по кнопке [image] в палитре Animation. В списке Tween with выберите вариант Next Frame (до следующего кадра), а в поле Frames To Add введите нужное количество промежуточных кадров (например, 5).

Программа автоматически строит 5 промежуточных кадров, меняя все свойства текстового слоя, в данном случае — положение и прозрачность. Однако, в конце анимации есть неприятное мигание — резкий переход с последнего кадра на первый — и нет времени прочитать надпись.

Выделите последний кадр и установите для него время показа 2 секунды. Сохраните окончательный результат в виде файла PSD (File — Save) и готовый ролик в виде файла формата GIF.

к началу К началу страницы

5. Реакция на события мыши

Запустите Image Ready и откройте файл worker.psd.

В этом файле три слоя. Верхние 2 слоя изображают разные стадии работы, а самый нижний — отдыхающего человечка. Мы сделаем кнопку, которая реагирует на наведение мыши. В нормальном состоянии человечек сидит, а при наведении мыши работает.

Найдите на экране палитру Web Content. Если ее нет, откройте ее через меню (Window — Web Content).

Видно, что у этого рисунка одно состояние — нормальное (Normal). Это значит, что он не реагирует на движение мыши.

Щелкните по кнопке [image] в палитре Web Content, чтобы создать новое состояние.

Это новое состояние автоматически получает название Over. Это значит, что оно включается при наведении мыши (событие Mouse Over).

Щелкните дважды справа от надписи worker_01, чтобы настроить свойства рисунка на Web-странице. Измените название файла на worker, в поле Alt введите текст всплывающей подсказки "Рабочий Вася Пупкин".

Кроме того, в поле URL можно задать адрес перехода, если рисунок является гиперссылкой, но сейчас мы не будем это делать.

Нажав Ctrl+Alt+P, просмотрите рисунок в браузере. Пока при наведении мыши появляется только всплывающая подсказка, а рисунок не меняется.

Рабочий Вася Пупкин

Выделите состояние Normal в палитре Web Content. Затем в палитре Слои сделайте видимым только слой Отдых. Теперь выделите состояние Over и сделайте видимым только слой Работа 1. Посмотрите, что получилось.

Рабочий Вася Пупкин

Программа сохраняет на диске два рисунка: worker.gif (он загружается в самом начале) и worker_over.gif. Если посмотреть в код Web-страницы, можно увидеть, что при наведении мыши загружается второй рисунок, worker_over.gif, а после ухода мыши — снова worker.gif.

Каждый из этих рисунков может содержать анимацию. Сделаем так, чтобы при наведении мыши человечек работал, то есть, попеременно менялись состояния Работа 1 и Работа 2. Для этого надо добавить анимацию во второй файл, который загружается при наведении мыши.

Выделите состояние Over. Создайте новый кадр в палитре Animation и сделайте видимым только слой Работа 2. Установите для обоих кадров время показа 0,2 секунды и проверьте, что получилось. Сохраните окончательный результат в виде файла PSD (File — Save) и Web-страницу (File — Save Optimized As). Откройте Web-cтраницу в браузере.

Рабочий Вася Пупкин

Существуют и другие состояния рисунка, например, состояния при нажатии и отпускании левой кнопки мыши, но они очень редко используются. Для того, чтобы добавить эти состояния, надо щелкнуть по кнопке [image] в палитре Web Content.

 |  | Оглавление |
Иллюстрации для Интернета | Назад | В начало | Вперед | Векторная графика в Photoshop


Уроки по Adobe Photoshop CS: векторная графика

Тема 14. Векторная графика в Photoshop

  1. Введение
  2. Инструмент Перо
  3. Редактирование контуров
  4. Выделение объекта на фоне
  5. Текст вдоль контура
  6. Обтравочный контур
  7. Фигуры

1. Введение

Контуры

Контуры — это векторные объекты. Это значит, что их можно изменять и растягивать сколько угодно, не теряя деталей. С помощью контуров можно строить сложные фигуры, которые на заключительном этапе работы замечательно переводятся в растровый формат с любым нужным разрешением.

Photoshop включает множество стандартных фигур, записанных в библиотеку. Однако мы начнем изучение с ручного построения контуров. Если освоить эти приемы, разобраться со стандартными фигурами будет очень просто. Вот пример контура

Контур состоит из сегментов (отрезков и линий) и узлов, которые их ограничивают. Узлы можно перемещать, изменяя форму контура. Можно добавлять новые узлы и удалять ненужные.

Сегменты бывают двух типов:

  • прямолинейные (отрезки)
  • криволинейные, которые управляются с помощью направляющих отрезков
Узлы также бывают двух типов:
  • гладкие узлы — кривая входит в узел и выходит из него под одним и тем же углом
  • угловые узлы — кривая резко изменяет направление, например, когда узел соединяет прямолинейные сегменты
Контуры бывают замкнутые и разомкнутые. Контур может содержать несколько несвязанных компонентов. На рисунке показан контур с тремя компонентами.

к началу К началу страницы

2. Инструменты для работы с контурами

Для работы с контурами предназначены две группы инструментов. При создании и редактировании контуров используются инструменты (все они связаны с одной кнопкой на панели инструментов и клавишей P):
  • Перо [image] — самый мощный инструмент, добавляет, передвиагет и удаляет узлы;
  • Свободное перо [image] — позволяет мышкой нарисовать произвольную линию, которая затем преобразуется в контур;
  • Перо+ [image] — добавление узлов;
  • Перо- [image] — удаление узлов;
  • Угол [image] — преобразование угловых узлов в гладкие и наоборот.
Еще два инструмента служат для выделения контуров и их элементов служат два инструмента:
  • Выделение контура [image] — для выделения и перемещения контура или его компонента
  • Стрелка [image] — для выделения и перемещения отдельных узлов и сегментов контура, при нажатой клавише Shift позволяет выделять сразу несколько узлов и сегментов.

Инструмент Перо

Чаще всего используется инструмент Перо. В простейшем случае щелчками мыши устанавливаются углы ломаной линии. Если при этом удерживать клавишу Shift, все звенья будут иметь наклон, кратный 45 градусам.

Для замыкания линии надо щелкнуть на начальной точке (к указателю мыши добавляется кружок). Если надо закончить контур, не замыкая его, щелкните еще раз по кнопке инструмента Перо или в любом месте рисунка при нажатой клавише Ctrl.

Для создания гладкого узла надо, не отпуская левой кнопки мыши, "вытянуть" из нового узла направляющий отрезок.

При включенном флажке Оптимизация (на панели свойств инструмента). инструмент Перо автоматически переключается в режимы

  • Перо+ — при наведении на сегмент (добавления нового узла)
  • Перо- — при наведении на существующий узел (удаление)
  • Угол — при наведении на существующий узел при нажатой клавише Alt (изменение свойств узла)
  • Стрелка — при удерживании клавиши Ctrl (перемещение узла или сегмента)

к началу К началу страницы

3. Редактирование контуров

Создайте новый рисунок размером 300 на 300 пикселей и сохраните его в папке PRACTICE/14.

Сделайте так, чтобы были видны линейки (Просмотр — Линейки или Ctrl+R). Убедитесь, что на линейках отображаются размеры в пикселях (щелчок правой кнопкой мыши по линейке). "Вытащите" с линеек 5 вертикальных направляющих и расставьте их через 50 пикселей. Затем установите три горизонтальных направляющих на отметки 50б 100 и 250 пикселей.

Включите инструмент Перо [image] и установите в палитре свойств инструмента режим Контуры.

Проверьте, чтобы были включены флажки Просмотр — Привязка и Просмотр — Привязать к... — Направляющие.

Щелчками мыши постройте замкнутый контур, приближенно описывающий форму сердца. Сделайте активной палитру Контуры (Окно — Контуры) и убедитесь, что в ней появился рабочий контур. Щелкните дважды по его названию и измените его.

Включите инструмент Выбор контура [image] (клавиша A) и выделите созданный контур щелчком мыши. Сдвиньте его в другое место, затем верните обратно.

Включите инструмент Перо (клавиша P) и, удерживая клавишу Alt, вытяните направляющие из узлов, как показано на рисунке.

При нажатой клавише Alt вытяните вниз направляющие боковых точек, чтобы сделать сердце более полным.

Установите основной цвет — красный и залейте контур, щелкнув по кнопке [image] в палитре Контуры. Затем выберите инструмент Кисть диаметра 15-20 пикселей. Выберите желтый цвет и сделайте обводку контура, щелкнув по кнопке [image].

Теперь сделаем вторую обводку вокруг желтого контура точечной линией. Но сначала мы расширим (трансформируем) контур.

Выберите пункт меню Редактирование — Свободное трансформирование контура и расширьте его до внешних границ желтой обводки.

Выберите основной цвет для точечной обводки. Включите инструмент Кисть с диаметром 5 пикселей и жесткостью 100%. Вызовите окно свойств кисти (кнопка [image] в правой части панели свойств инструмента). Щелкните на словах Форма отпечатка кисти, включите флажок Интервалы и отрегулируйте нижний движок так, чтобы линия стала точечной. Затем выполните обводку контура, щелкнув по кнопке [image] в палитре Контуры.

к началу К началу страницы

4. Выделение объекта на фоне

Контуры очень удобно использовать, когда надо выделить объект на неоднородном фоне, причем этот объект имеет сложные сглаженные границы. Для этого можно воспользоваться инструментом Перо, который при включенном флажке Оптимизации (в панели свойств инструмента) автоматически превращается в Перо+ (при наведении на линию), Перо- (при наведении на узел), Стрелка (при наведении на узел и нажатии клавиши Ctrl) и Угол (при наведении на узел и нажатии клавиши Alt).

Откройте файл butterfly.jpg в папке PRACTICE/14.

В этом примере мы вырежем бабочку и заменим унылый серый фон на естественный, природный.

Бабочка | Фон

Используя инструмент Перо [image], щелчками мыши наметьте контур бабочки, замкните его.

С помощью инструментов группы Перо отредактируйте контур, сделав его скругленным в нужных местах. Используйте большое увеличение для более точной работы.

Перейдите в палитру Контуры (Окно — Контуры) и щелкните дважды на словах "Рабочий контур". Дайте вновь созданному контуру имя Бабочка.

Выделите внутреннюю част контура, щелкнув по кнопке [image] в нижней части палитры Контуры. Откройте файл grass.jpg и перетащите в его окно бабочку при нажатой клавише Ctrl (временно включается инструмент Перемещение). Расположите бабочку в нужное место.

Видно, что светлая бабочка теряется на пестром фоне. Чтобы выделить ее, увеличим контраст бабочки и сделаем нерезким фон.

В палитре Слои (клавиша F7) выделите слой с бабочкой. С помощью окна Изображение — Кореркция — Яркость/Контраст уменьшите яркость бабочки и добавьте контраст, чтобы выделить ее на фоне травы. Включите падающую тень в свойствах слоя с бабочкой (кнопка ) [image] в палитре Слои), настройте ее параметры.

Теперь выделите в палитре Слои фоновый слой и примените небольшое размытие по Гауссу. Сохраните результат.

к началу К началу страницы

5. Текст вдоль контура

Средствами Photoshop можно размещать текст вдоль любой линии. Для этого надо создать контур, затем включить инструмент Текст и щелкнуть на контуре в том месте, где должен начинаться текст. Затем, как обычно, вводим текст, настраиваем его свойства и если нужно, перемещаем вдоль контура в нужное место.

Контур, связанный с текстом, можно передвигать, деформировать — текст будет двигаться вслед за ним.
Оригинал | Результат

Откройте файл lion.jpg в папке PRACTICE/14 и сохраните его в формате PSD.

Сначала мы сделаем виньетку овальной формы с изображением льва.

Установите белый фоновый цвет. Используя команду Изображение — Размер холста увеличьте высоту и ширину рисунка на 100 пикселей, добавив белую рамку.

Выберите инструмент Овальная область, установите растушевку около 10 пикселей и выделите льва.

Инвертируйте выделение (Shift+Ctrl+I) и удалите "лишние" части вне овала.

Теперь построим контур, вдоль которого надо расположить текст. Легче всего сначала выделить овальную область, а затем преобразовать ее в контур.

Снова инвертируйте выделение (чтобы выделить льва). Расширьте область на 10 пикселей (Выделение — Модификация — Расширить).

Перейдите на палитру Контуры (Окно — Контуры) и создайте из выделения рабочий контур, щелкнув по кнопке [image].

Далее вводим текст и настраиваем его свойства.

Включите инструмент Текст. Наведите курсор на любую часть контура (он примет вид [image]) и щелкните мышью, чтобы начать ввод. Установите шрифт Arial, жирный (Bold), размер 48 пунктов, и введите надпись "ОБЩЕСТВО ОХРАНЫ ДИКИХ ЖИВОТНЫХ".

Выберите инструмент Выделение контура [image]. Перетащите крестик (точку начала текста на контуре) и кружок (конец текста) так, чтобы надпись была симметрична с разрывом внизу.

Включите инструмент Выделение контура [image] и попробуйте перетащить контур за внутреннюю часть. Затем попробуйте перетащить какую-нибудь часть линии (автоматически включается инструмент Стрелка и контур меняет форму).

При создании текста была создана копия рабочего контура, поэтому первый контур можно удалить, чтобы сократить объем файла.

Перейдите в палитру Слои и удалите Рабочий контур, перетащив его на кнопку [image]. Сохраните результат.

к началу К началу страницы

6. Обтравочные контуры

Обтравочные контуры служат для того, чтобы сделать некоторые области (вне контура) прозрачными. Это бывает нужно, например, для экспорта в программы векторной графики, например, в Adobe Illustrator

Откройте файл bird.jpg в папке PRACTICE/14.

Выделите птицу контуром, отредактируйте его при большом увеличении. Перейдите в палитру Контуры и дайте контуру имя, например, Контур 1.

В палитре Контуры щелкните по кнопке меню [image] и выберите пункт Обтравочный контур.

Теперь сохраним файл в векторном формате и загрузим в Adobe Illustrator.

Выберите пункт меню Файл — Сохранить как и сохраните файл в формате Photoshop EPS, установив в окне параметров в поле Просмотр TIFF (8 бит на пиксель) и в поле Кодировка — JPEG (высокое качество).

Откройте сохраненный файл в Adobe Illustrator.

к началу К началу страницы

7. Фигуры

Фигуры — это векторные объекты, границы которых представляют собой контуры. В отличие от обычных контуров, они заливаются сплошным цветом и занимают отдельный слой рисунка. К этому слою можно применять всевозможные эффекты, например, придавать объемность.

Мы изучим работу с фигурами на примере создания логотипа ВАЗ. Существует рисунок логотипа низкого качества, требуется построить векторное изображение, которое можно увеличивать до нужных размеров, не теряя качество.

Оригинал | Результат

Откройте файл lada.gif в папке PRACTICE/14. Переведите его в режим RGB (Изображение — Режим — RGB) и сохраните в формате PSD.

Установите белый основной цвет. Включите инструмент Эллипс [image] и постройте овал по границе логотипа.

В палитре Слои можно посмотреть, что был создан новый слой Фигура 1, залитый белым цветом. У слоя есть маска, но в отличие от ранее изучавшихся масок слоя (см. Тему 10) эта маска — векторная, то есть, она сохраняет точную форму при любом изменении размеров.

Выключите векторную маску, щелкнув по ней в палитре слои правой кнопкой мыши и выбрав команду Disable Vector Mask. Снова включите ее (ПКМ — Enable Vector Mask).

В палитре Слои установите непрозрачность нового слоя около 20%, чтобы видеть фоновое изображение. Используя команду Редактировние — Трансформирование контура — Масштабирование, отрегулируйте размеры и положение фигуры.

По умолчанию каждая следующая фигура создается на новом слое, потому что в палитре свойств инструмента включен режим Создать новый слой-фигуру [image]. Мы будем строить все изображение на одном слое, используя другие режимы:

  • — Добавить к области фигуры
  • — Вычесть из области фигуры
  • — Область пересечения фигур
  • — Вычесть область пересечения фигур

Включите режим Вычесть из области фигуры и нарисуйте внутренний эллипс.

В палитре Слои видно, что фигура строится на том же слое. Теперь надо выделить внутренний субконтур и расположить его правильно.

Включите инструмент Выделение контура [image] и выделите внутренний эллипс. Используя команду Редактировние — Трансформирование контура — Масштабирование отрегулируйте его размеры и положение.

Увеличьте непрозрачность слоя и посмотрите на результат. Снова уменьшите непрозрачность.

Теперь сделаем перемычку в верхней части конутра логотипа.

Включите инструмент Перо [image] в режиме Слой-фигура [image] и выделите контуром перемычку.

Включите режим Добавить к области фигуры [image] и постройте (на том же слое) контур, ограничивающий ладью. Возможно, будет удобно добавлять эту область по частям: отдельно мачту, парус и корпус. Увеличьте непрозрачность слоя до 100%.

В палитре Слои выделите фоновый слой и залейте его темно-синим цветом (Редактирование — Выполнить заливку или клавиши Shift+F5).

Выделите слой Фигура 1 в палитре Слои. В палитре свойств инструмента откройте выпадающий список Стили и выберите стиль Chiseled Sky [image]. Сохраните результат.

Анимация в Image Ready Назад В начало Оглавление